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Para P-40B z 47 Pursuit Squadron USAAC, której udało się wystartować 7 grudnia 1941r do walki z japońskim nalotem na Pearl Harbor. Pilotują je porucznicy: Kenneth Taylor i George Welch.
47 PS był w tym czasie oddelegowany na ćwiczenia strzeleckie w ustronny, północny zakątek wyspy Oahu, na polowe lądowisko Haleiwa. To obszar nie był blokowany przez japońskie samoloty. (Pearl Harbor leżało na przeciwnym brzegu wyspy). Pas startowy biegł wzdłuż brzegu morza. Tak ta para samolotów mogła wyglądać zaraz po starcie. Fotografia tła przypomina autentyczny fragment brzegu w pobliżu lotniska Haleiwa
Tworzenie tej sceny jest opisane w IV tomie tej książki.
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Bo zawsze chciałem stworzyć model samolotu w komputerze. A gdy już to zrobiłem — stwierdziłem, że to dobra zabawa, i że warto tym doświadczeniem podzielić się z innymi.
Dawno temu byłem zwykłym modelarzem i robiłem redukcyjne modele samolotów. To hobby dość specyficzne. Ślęczymy miesiącami nad naszym dziełem, starając się nanieść na kawałek materiału maleńkie nity, złącza blach, czy drobne detale tablic przyrządów. Sądzę, że postronnym obserwatorom zajęcia wędkarzy wydadzą w porównaniu z modelarzami mniej męczące, choć podobnie monotonne. W dodatku, zamiast tworzyć ładne, błyszczące miniaturki, nanosimy na ich powierzchnię (o zgrozo!) zabrudzenia i przetarcia, jakie powstawały podczas intensywnego używania. Szpecimy je, aby wyglądały jak rzeczywiste, zużyte i gdzieniegdzie pordzewiałe maszyny. Całą naszą nagrodą jest pokazanie naszych dzieł komuś, kto potrafi docenić ich finezję. Zdarza się to raz na jakiś czas. Mówiąc szczerze, dziwnym trafem są to zazwyczaj inni modelarze. A może ukrytą nagrodą jest możliwość nawiązania dyskusji na tak ezoteryczne tematy, jak wyższość Spitfire’a IX nad FW 190 A4? Albo paląca kwestia, jak był pomalowany P-40, na którym Witold Urbanowicz latał nad Chinami w 1943r?
Otóż chciałbym teraz zaoferować kolegom modelarzom (i nielicznych koleżankom – jakoś tak się te proporcje układają) zupełnie nowy materiał i narzędzia. Zamiast własnego, czasami nieco pobrudzonego aerografem biurka — okno na inny świat, w głębi ekranu.
Jest tu niezwykle plastyczny materiał, który można „wytłaczać” w dowolne powłoki, bez obawy że go zabraknie. Są tu farby, dla których można dokładnie ustalić odcień i zasady nakładania. Jest tu możliwa do osiągnięcia dokładność, której nie uzyskasz nigdzie indziej, ani w skali 1:24, ani w 1:18. Tu, gdy stwierdzisz, że okapotowanie silnika samolotu, który zrobiłeś rok temu, powinno mieć inny kształt, zawsze możesz ten błąd poprawić. I to nie raz! Tu nigdy Twój model nie obrośnie kurzem. Nie będziesz wysłuchiwał narzekań domowników na to, że nie ma już gdzie zmieścić Twojej kolekcji. Możesz tu powielić swoje dzieło – choćby po to, by odwzorować je w kilku różnych wersjach malowania. I możesz przesłać swój model innym hobbystom, takim jak Ty, bez obawy że coś się z nim stanie podczas transportu. Z obiektów, które w ten sposób stworzysz, można szybko budować całe sceny.
Jedyne, do czego trzeba się przyzwyczaić, to to, że niczego w tym świecie nie można dotknąć. Możesz tylko patrzeć, i łapać wszystko myszką. Przynajmniej na obecnym etapie rozwoju technologii, urządzenia dotykowe (ang. haptic devices) są nadal drogie i prymitywne. Za to możemy obserwować szybki rozwój drukarek 3D. Przypuszczam że za dwa — trzy lata będziemy mogli na nich „drukować” np. dokładne części modeli.
Ten świat wirtualnego modelarstwa stał niepostrzeżenie dostępny. W istocie każdy komputer, kupiony po 2005r, to silna stacja graficzna, o której w latach 90-tych można było tylko pomarzyć. Około 15 lat temu „ruszył z miejsca” nowy model matematyczny, służący do odwzorowania powierzchni. Mam na myśli powierzchnie podziałowe (ang. subdivision surfaces). Pozwoliły stworzyć Shreka i dziesiątki innych postaci z filmów animowanych za pomocą komputera. Ten nowy model matematyczny skierował do lamusa powierzchnie NURBS, wykorzystywane od lat 70-tych. Powierzchnie podziałowe pozwalają łatwo uzyskiwać naprawdę złożone kształty. W miarę dobrze radzą sobie ze zmorą NURBS – otworami i wycięciami.
Co więcej – odpowiednie programy, które potrafią to wszystko wykorzystać, stały się dostępne za darmo! Stworzyły je dziesiątki programistów Open Source. Ludzie ci chcą pokazać, że stać ich co najmniej na to samo, co twórców najlepszych programów komercyjnych. I to zaczęło im się udawać! Być może, trochę w tym zdrowej ambicji („ja to zrobię lepiej!”), oraz innego rytmu powstawania takich produktów. Podczas pracy nad nimi nie ma, typowego dla komercyjnych projektów pośpiechu, związanego z napiętymi terminami. (A pośpiech rodzi błędy). W efekcie pracy odpowiednio dużej grupy entuzjastów powstaje dobry, stabilny program.
Podsumowując – kupując do domu komputer do gier, kupiłeś wszystko, co potrzeba do wejścia w świat wirtualnego modelarstwa. Nie będę oszukiwał, że nie ma tu tego, co jest nieodłączną cechą pracy każdego modelarza: wielotygodniowego wysiłku. Mam jednak nadzieję, że ta książka ułatwi Ci, drogi Czytelniku, jak najszybsze osiągnięcie pożądanych rezultatów. Potem możesz pójść dalej i zrobić to samo jeszcze lepiej, niż tu proponuję. Przeczytanie dalszych stron, oszczędzi Ci dużo czasu i – niekiedy – frustracji. Ta ostatnia bywa nieodłącznym składnikiem pracy z „tą głupią maszyną” – komputerem. Postaram się nie zanudzać i pokazywać dużo obrazków, więc mam nadzieję, że „Wirtualne modelarstwo” Cię zainteresuje.
Witold Jaworski
„Wirtualne Modelarstwo” uczy „od zera”, jak tworzyć takie modele samolotów, jak pokazany na okładce. Aby szybciej udostępniać Czytelnikom uaktualnione fragmenty tej książki, zdecydowałem się stworzyć i opublikować wyciągi z jej tekstu, związane z określoną dziedziną. Są to: „Tom I: Przygotowania”, „Tom II: Modelowanie”, „Tom III: Materiały i tekstury”, oraz „Tom IV: Detale i renderowanie”. Przebieg pracy prezentuję na przykładzie modelu myśliwca Curtiss P-40B. Maszyna ta zawiera klasyczne rozwiązania, stosowane w większości samolotów tego okresu. Z całym rozmysłem nie wybrałem Spitfire, Mustanga, Thunerbolta, Focke-Wulfa czy Messerschmita. Nie chciałem zabierać Ci przyjemności samodzielnego odwzorowania tych słynnych samolotów.
Możesz tworzyć model każdego myśliwca z okresu II wojny światowej1, czytając jednocześnie kolejne rozdziały z tej książki. To wcale nie musi być P-40. Wszystkie te samoloty wykonuje się podobnie. W trakcie pracy na pewno zetkniesz się ze wszystkimi zagadnieniami, które są tu opisane.
Ta książka ma służyć zarówno tym, którzy dopiero zaczynają swoją przygodę „w 3D”, jak i tym, którzy mają już w tej dziedzinie pewne doświadczenie. W związku z tym zdecydowałem się ją podzielić na dwie części:
część pierwsza ("Budowa modelu") to tekst podstawowy, który koncentruje się na tym, co trzeba zrobić;
część druga ("Szczegóły obsługi programów") to szczegółowe opisy, jak posłużyć się odpowiednim programem, by osiągnąć efekt, pokazany w części pierwszej.
Cały tekst ma dużo stron, z czego "Szczegóły obsługi programów" zajmują ok. 40%. Układ tej części przypomina tekst systemu pomocy (Help) do programu. To krótkie (na jedną lub dwie strony), nie zawierające więcej niż kilka ilustracji, opisy pojedynczych poleceń.
Dzieląc materiał na część podstawową i „szczegółową”, starałem się uniknąć niepotrzebnych, wydłużających niezmiernie tekst, wskazówek w rodzaju „kliknij tu, a potem naciśnij tamto”. W odpowiednich miejscach części pierwszej umieściłem odnośniki do części drugiej. Jeżeli nie znasz programu, o którym akurat piszę, korzystaj z tych odnośników i czytaj umieszczone w nich informacje szczegółowe2. Przygotowałem je tak, abyś nauczył się posługiwać wszystkimi narzędziami "od zera", w trakcie czytania głównego tekstu. Gdy już będziesz wiedział, jak zrobić to, co opisuję — po prostu przestaniesz do nich zaglądać.
Książka zawiera jeszcze jedną część: „Dodatki”. To materiały, które mogą być ciekawe dla co dociekliwszych Czytelników. Tematyka „Dodatków” przypomina trochę "groch z kapustą": od pewnych zagadnień optyki (deformacja obrazu na fotografii), do odwzorowania profili lotniczych. A oprócz tego: metody zaawansowanej weryfikacja rysunków samolotu (na poziomie tworzenia planów modelarskich), oraz szczegółowy opis właściwości powierzchni podziałowych. Nie musisz do „Dodatków” zaglądać, choć sądzę, że niektórzy mogą w tych materiałach znaleźć dla siebie coś interesującego.
Wskazówki dotyczące klawiatury i myszki oparłem na założeniu, że masz standardowe:
klawiaturę — w normalnym układzie amerykańskim, 102 klawisze (dodam także parę uwag o klawiaturze notebooka, bo sam na takiej pracuję);
myszkę — wyposażoną w dwa przyciski i kółko przewijania (które daje się także naciskać: wtedy działa jak trzeci, środkowy przycisk).
Wywołanie polecenia programu będę zaznaczał następująco:
| Menu→Polecenie | taki zapis oznacza wywołanie z menu „Menu” polecenia „Polecenie”. W przypadku bardziej zagnieżdżonych menu może wystąpić więcej strzałek! |
| Panel:Przycisk | taki zapis oznacza naciśnięcie w oknie dialogowym lub panelu "Panel" przycisku „Przycisk”. Czasami mogę także w ten sposób napisać o przełączniku lub liście rozwijalnej. ("Panel" to pojęcie związane z ekranem Blendera, wyjaśnienia — patrz „Tom II: Modelowanie”) |
Naciśnięcie klawisza na klawiaturze:
| Alt-K | myślnik pomiędzy znakami klawiszy oznacza jednoczesne naciśnięcie obydwu klawiszy na klawiaturze. W tym przykładzie trzymając wciśnięty Alt, naciskasz K; |
| G, X | przecinek pomiędzy znakami klawiszy oznacza, że je naciskasz (i zwalniasz!) po kolei. W tym przykładzie najpierw G, a potem X (tak, jak gdybyś chciał napisać wyraz „gx”). |
Naciśnięcie klawisza myszki:
| LPM | lewy przycisk myszy |
| PPM | prawy przycisk myszy |
| SPM | środkowy przycisk myszy (naciśnięte kółko przewijania) |
| KM | kółko przewijania (pełni tę rolę, gdy jest obracane) |
Na koniec — „w kwestii formalnej”: jak mam się do Ciebie zwracać? Zazwyczaj w poradnikach używa się formy bezosobowej („teraz należy zrobić”). To jednak, mówiąc szczerze, czyni czytany tekst mniej zrozumiałym. Aby ta książka była jak najbardziej czytelna, zwracam się do Czytelnika w krótkiej, drugiej osobie („teraz zrób”). Czasami używam także osoby pierwszej („teraz zrobiłem”, „teraz zrobimy”). Tak jest mi łatwiej1.
„Wirtualne modelarstwo” najlepiej jest czytać na możliwie dużym, kolorowym tablecie, takim jak Kindle Fire 8.9”, lub na komputerze stacjonarnym, w aplikacji Kindle for PC. Ze względu na kolorowe ilustracje o dużej rozdzielczości, zdecydowanie odradzam próby użycia mniejszych czytników wykorzystujących technologię e-ink, takich jak Kindle Touch czy Kindle Paperwhite1.
Ta książka jest dostępna w kilku popularnych formatch. Użyj tej matrycy format/platforma aby lepiej zorientować się we właściwościach każdego z nich dla każdego z najpopularniejszych czytników/komputerów. To pozwoli zdecydować, który z tych formatów będzie najlepiej pasować do Twoich potrzeb. Każdą wersję tej książki możesz pobrać ze strony tego projektu.
Na stosunkowo dużym ekranie Kindle Fire 8.9” książkę można czytać w układzie pionowym (Rysunek i.3.1). Ilustracje „Wirtualnego modelarstwa” dostosowują się dynamicznie do szerokości ekranu:
Rysunek 0.3.1 Strony książki na Kindle Fire 8.9”
W tym poradniku chciałem, aby tekst i powiązane z nim ilustracje pojawiały się jak najbliżej siebie. W tym celu musiałem połączyć je w jedną, ciągłą zawartość i pozwolić czytnikowi dzielić ją na strony. Dlatego czasami może się zdarzyć, że ilustracja znajdzie się na jednej stronie, a jej podpis — już na następnej. Wynika to z niedoskonałości obecnie używanych formatów książek elektronicznych. (Nie mogłem zastosować żadnego rozwiązania które wymusiłoby na czytniku pozostawianie ilustracji i jej podpisu razem).
W ustawieniach czytnika dla tej książki proponuję wybrać niezbyt duży rozmiar czcionki (Settings: Font Size: 3 lub 4). W ten sposób podstawowy tekst będzie miał wysokość dopasowaną do odsyłaczy na ilustracjach (tekst podstawowy powinien być o około 50% wyższy od tekstu na ilustracjach). Ustaw także wąskie marginesy (Margins:Narrow), aby ilustracje były jak największe (Rysunek i.3.2):
Tło wszystkich ilustracji jest białe, stąd książka najlepiej wygląda z białym tłem (Color Mode). Odstęp pomiędzy liniami tekstu (Line Spacing) można ustawić na szeroki, a domyślną czcionkę (Font) — na szeryfową Georgia.
Gdy ustawisz tablet poziomo, czytnik podzieli treść książki na dwie „rozłożone” strony (Rysunek i.3.3):
Rysunek i.3.3 Domyślny sposób wyświetlania przy poziomym układzie tabletu
Uważam, że w takim układzie jest mniej czytelna, przede wszystkim ze względu na zmniejszone ilustracje.
Na szczęście możemy taki tryb wyłączyć. W opcjach programu (Settings) naciśnij More Options, aby przejść na drugi ekran. Przełącz tam tryb Two Column na Off (Rysunek i.3.4):
Rysunek i.3.4 Wyłączenie trybu „rozłożonych stron”
Rysunek i.3.5 Powiększanie ilustracji poprzez obrót tabletu
Rozmiar wszystkich ilustracji w tej książce zależy od rozmiaru ekranu: ich szerokość jest ustawiona jako % aktualnej szerokości ekranu. Stąd w ustawieniu poziomym wszystkie ilustracje są proporcjonalnie większe gdyż ekran tabletu jest szerszy.
Gdy wyłączysz tryb Two Column, możesz szybko powiększać ilustracje z bieżącej strony poprzez obrót tabletu, jak na Rysunku i.3.5:
Rozmiar czcionki każdego tekstu spoza ilustracji pozostaje taki sam w obydwu położeniach: pionowym i poziomym. Położenie poziome wydłuża linie tekstu do więcej niż 72 znaków na linię. (Optymalną długość linii tekstu to 66-72 znaki. Linie dłuższe lub krótsze czyta nieco trudniej). Co więcej, ekran Kindle Fire w położeniu poziomym nie jest zbyt wysoki, i potrafi wyświetlic tylko jedną ilustrację i kilka linii tekstu. Stąd proponuję używać ustawienia poziomego do szybkich powiększeń, a pionowego — do normalnego czytania.
Kindle Fire wyświetla przełącznik Two Column tylko wtedy, gdy tablet jest ustawiony poziomo!
Ta książka zawiera mnóstwo hipertekstowych odsyłaczy. Są wyróżnione cienkim podkreśleniem. W głównym tekście te hipertekstowe skróty sa przypisane do symboli nagłówków, sekcji, czy numerów stron (Rysunek i.3.6):
Rysunek i.3.6 Użycie skrótów hipertekstowych
Używaj przycisku Back (Rysunek i.3.6) do powrotu z takiego „hipertekstowego skoku” w poprzednie położenie w książce. (Gdy tablet jest ustawiony poziomo, znajdziesz ten przycisk z prawej strony ekranu).
Wyjątkiem w użyciu przycisku Back jest powrót z przypisu na Kindle Fire: użyj w tym celu numeru fizycznej strony, umieszczonego za numerem przypisu (Rysunek i.3.6). (Rób tak, dopóki Amazon nie usunie błędu z oprogramowania dla tego tabletu. W przeciwnym razie po jakimś kolejnym naciśnięciu Back zamknie się książka i trzeba ją ponownie otworzyć).
W tej książce referencją jest każdy numer fizycznej strony. Numery te pochodzą z książki formacie PDF, i choć nie odpowiadają stosowanym przez Kindle „lokalizacjom” (loc)to pozostawiłem je aby tekst tej publikacji był we wszystkich formatach taki sam. (No, może poza tą sekcją wproadzenia, która jest specyficzna dla każdego z zastosowanych formatów).
Starając się by ta publikacja elektroniczna była bardziej czytelna niż typowe papierowe poradniki, przesunąłem większość szczegółowych opisów z tekstu głównego do podrozdziałów. W ich miejscu pozostawiłem hipertekstowe odsyłacze. Skorzystaj z tych skrótów aby poznać wszystkie niuanse opisywanych operacji. W ten sposób główny wątek książki pozostaje wolny od rozpraszających uwagę detali.
* * *
Przypuszczam że często będziesz czytał ten poradnik pracując jednocześnie na komputerze. I choć sądzę, że najlepiej się taką książkę czyta na tablecie, to możesz czasami możesz nie mieć żadnego „pod ręką”. Wtedy użyj darmowego programu Kindle for PC, dostarczanego przez Amazon na komputery z systemami Windows (Rysunek i.3.7). (Istnieją jeszcze Kindle for Mac i Kindle for Android. Wszystkie wyglądają bardzo podobnie):
Rysunek i.3.7 Przeglądanie tej książki w programie Kindle for PC
Zauważ że ta aplikacja ma pod menu rozwijalnym pasek narzędzi. Kliknij w jedną z jego ikon (Rysunek i.3.7) aby otworzyć panel ustawień (Settings — Rysunek i.3.8):
Rysunek i.3.8 Ustawienia Kindle for PC
Podobnie jak na Kindle Fire możesz ustawić tu rozmiar podstawowego tekstu, szerokość marginesów czy barwę tła (białą).
W Kindle for PC nie ma możliwości zmiany kroju czcionki podstawowego tekstu — niezależnie od oryginalnych ustawień, wszystko jest wyświetlane w jednolitej czcionce szeryfowej (prawdopodobnie to Georgia).
Kursor myszki zmienia się ponad każdym hipertekstowym linkiem we „wskazującą dłoń” (Rysunek i.3.8). Gdy w takim miejscu klikniesz myszką — przejdziesz do odpowiedniej strony (Rysunek i.3.9):
Rysunek i.3.9 Powrót do poprzedniego położenia w książce
Aby powrócić z takiego „skoku” do poprzedniego miejsca w książce, naciśnij przycisk Back, umieszczony w pasku ponad tekstem (Rysunek i.3.9).
Wersja tej aplikacji Amazon na tablety firmy Apple — Kindle for iOS — nie otwiera poprawnie tej książki. Dopóki Amazon nie usunie tego błędu2, najlepszym rozwiązaniem dla tabletów IPad jest pobrać tę książkę w formacie EPUB i czytać ją w darmowej aplikacji iBooks.
W tej części stworzymy model P-40B. Zakładam, że dla wielu Czytelników będzie to wprowadzenie w świat grafiki komputerowej. Nie znaczy to jednak, że nasz samolot będzie jakiś uproszczony! (Choć, przyznam, gdy zaczynałem pisanie tej książki, chciałem parę zagadnień pominąć). Wykonamy go „w pełnej wersji”: z chowanym podwoziem i większością detali kabiny pilota. W trakcie pracy postaram się przekazać Wam całą wiedzę, jaką do tej pory na ten temat zgromadziłem.
W tym rozdziale omówimy pokrótce instalację oprogramowania, z którego będziemy korzystać. W tym tomie to:
GIMP: pomocniczy, do edycji obrazów rastrowych;
Inkscape: pomocniczy, do edycji obrazów wektorowych;
To oprogramowanie jest udostępniane w zasadach licencji GPL. Oznacza to m.in., że nie można pobierać za nie żadnych opłat. (Oczywiście, jeżeli masz gest, a program Ci się bardzo spodoba, możesz wspomóc twórców dotacją — ale na zasadzie zupełnej dobrowolności. Szczegółowy opis, jak to zrobić, znajdziesz na stronie internetowej każdego z tych projektów.)
Przypuszczam, że większość czytelników tej książki używa komputera z Windows. Podczas opisu instalacji koncentruję się wyłącznie na tym środowisku. Sam go używam. Nie mam żadnych doświadczeń z Linuksem, ani z Mac OS, więc nie będę pisał o instalacjach, których nie wykonałem. Jeżeli używasz systemów innych niż Windows — poszukaj wskazówek na stronach tych programów (ich adresy są w kolejnych sekcjach rozdziału).
Przygotowałem także trochę materiałów dodatkowych, i udostępniłem je jako spakowane pliki zip:
Pliki towarzyszące tej książce możesz pobrać ze strony: http://samoloty3d.pl/wm3_p.xml . Utrzymuję tam ich aktualne wersje1.
Następujące pliki są ważną częścią tej książki:
source.zip: zawiera skrypty Pythona, plany P-40B, udostępnione przez producenta fragmenty rysunków technicznych (P-40E), i inne pomocnicze materiały;
Rozpakuj wszystkie pobrane pliki *.zip do tego samego folderu. W trakcie ich rozpakowania stworzą odpowiednie podkatalogii (pliki nie wymienione powyżej należą do innych części tej publikacji):
Aby zainstalować GIMP, zajrzyj na stronę tego projektu — http://www.gimp.org . Od kilku lat plik do pobrania jest dostępny pod adresem: http://www.gimp.org/downloads (Rysunek 1.1.1):
Rysunek 1.1.1 Strona, z której można pobrać program instalacyjny GIMP
Ten uniwersalny program instalacyjny zawiera obydwie wersje GIMPA: 32-bitową i 64-bitową. Po uruchomieniu rozpoznaje typ systemu operacyjnego, i, gdy jest to możliwe, instaluje wersję 64-bitową1.
W procesie instalacji Gimpa nie ma żadnych “haczyków”. Po jej zakończeniu warto zmienić język interfejsu na angielski i przełączyć program w tryb pojedynczego okna (Windows→Single-Window Mode). Szczegółowy opis, jak to zrobić, znajdziesz na str. 51.
Podczas pracy nad tą edycją książki używałem GIMP v. 2.8.10.
Zajrzyj na stronę projektu Inkscape — http://www.inkscape.org (Rysunek 1.2.1):
Rysunek 1.2.1 Strona projektu Inkscape
Obecnie pliki instalacyjne są udostępnione na http://www.inkscape.org/downloads/ (Rysunek 1.2.2):
Rysunek 1.2.2 Strona z plikami instalacyjnymi Inkscape
„Oficjalny” pakiet instalacyjny zawiera Inkscape w wersji 32-bitowej. Ja jednak sugeruję zainstalować odmianę 64-bitową, która nam obsłuży o wiele bardziej złożone rysunki (np. obraz detali poszycia samolotu).
W chwili gdy piszę ten rozdział, wygląda na to, że 64-bitowy Inkscape jest kompilowany nie przez samych twórców, a przez kogoś innego (to i tak dobrze — dawniej była dostępna wyłącznie odmiana 32-bitowa). Gdy klikniesz w odpowiedni link na stronie Inkscape (na stronie pokazywanej przez Rysunek 1.2.2 jest to www.pratha.com ), możesz się znaleźć na takim portalu jak ten pokazywany przez Rysunek 1.2.3:
Rysunek 1.2.3 Pobieranie 64-bitowej odmiany Inkscape
Na pierwszy rzut oka wydaj się być to portal poświęcony GIMP, a nie Inkscape! Jeżeli jednak przyjrzysz się uważniej jego zawartości, znajdziesz odpowiedni skrót (w lewym dolnym rogu — por. Rysunek 1.2.3).
Możesz pobrać stąd program instalacyjny, a następnie uruchomić go na swoim komputerze. Proces instalacji Inkscape jest prosty, wystarczy abyś naciskał wszystkie przyciski domyślne. Gdybyś miał jakieś wątpliwości — szczegółowy opis instalacji znajdziesz na str. 90.
64-bitowa wersja Inkscape pobrana ze strony www.pratha.com ma pewną wadę: niestandardowy, zbyt ciemny kolor okien (por. str. 93). Można sobie z tym problemem poradzić tak, jak to opisuję w szczegółowym opisie instalacji.
Proponuję jednak prostsze rozwiązanie: przygotowałem gotowy do rozpakowania plik *.zip, zawierający odpowiednio skonfigurowaną 64-bitową wersję 0.48.10 Inkscape dla Windows 7 i 8. Aby jej użyć wystarczy:
pobrać plik http://airplanes3d.net/downloads/wm3/inkscape-048-64.zip ;
rozpakować jego zawartość (czyli przenieść folder Inkscape) do katalogu C:\Program Files\;
Potem dodaj skrót do C:\Program Files\Inkscape\inkscape.exe na pulpit lub do menu Start, i już możesz zacząć używać ten program.
W tej edycji książki używałem właśnie tego Inkscape (0.48.10, 64bit).
W tym rozdziale przedstawię metodę przygotowania rysunków samolotu, które wykorzystamy jako wzorzec w Blenderze. Zrobię to tu na przykładzie myśliwca P-40, ale tok postępowania jest taki sam dla każdego innego samolotu. W tym rozdziale będę się posługiwał wyłącznie GIMP. Przy okazji możesz się tu nauczyć podstaw jego obsługi.
Model cyfrowy powstaje na podstawie rysunków wzorcowych — rzutu z boku, góry, dołu, przodu, ewentualnie także z tyłu. Rysunki takie muszą być dokładne. Inaczej tylko utrudnią nam pracę1.
Na szczęście mamy w Polsce co najmniej dwa dobre plany modelarskie P-40, opracowane przez dwóch różnych autorów:
Jacka Jackiewicza — rysunki opublikowane w monografii “Curtiss P-40”, wydanej w latach 2000-2001 przez AJ Press, w ramach serii “Monografie lotnicze” (zeszyty nr 64, 65, 66);
Mariusza Łukasika — rysunki opublikowane w monografii “Curtiss P-40”, wydanej w latach 2008-2009 przez Kagero, w ramach serii “Monografie” (zeszyty nr 36, 40)
Jeżeli chcesz samodzielnie wykonać model P-40, gorąco polecam zakup co najmniej jednej z podanych powyżej publikacji. W materiałach załączonych do tej książki nie ma rysunków (byłoby to naruszenie praw ich autorów). Rysunki to zresztą nie wszystko - podczas pracy nieodzowne są także bliskie zdjęcia różnych części samolotu. Takie fotografie znajdziesz w Internecie, są także publikowane w specjalnych wydawnictwach dla modelarzy, nazywanych po angielsku “walk around”. Na przykład, na potrzeby tej pracy kupiłem zeszyt “Kittyhawk I/IA”, wydawnictwa Model Detail Photo Monograph (zeszyt nr 14). Zawiera ponad 100 fotografii i szkiców fragmentów P-40E. Właściwie im bardziej szczegółowy zamierzasz zbudować model, tym więcej takich materiałów powinieneś zgromadzić. Na pewno się przydadzą!
Wróćmy jednak do naszych rysunków: należy je zamienić na obrazy komputerowe, więc muszą być zeskanowane. W sumie jest to jedyny moment, gdy potrzebujesz skorzystać ze skanera. Nie stosuj jakichś wysokich rozdzielczości - obraz zeskanowany w trybie 300x300 dpi jest zupełnie dobry.
Przy okazji przygotowywania rysunków, będę się starał dokładnie zweryfikować poprawność kształtu samolotu. Może i czasami będziemy coś upraszczać, ale to uproszczenie ma polegać na rezygnacji z jakiegoś szczegółu. Stąd nie ma tu miejsca na jakąś “taryfę ulgową”. Sam się przekonasz, ile i jakiego rodzaju błędów potrafią zawierać nawet szczegółowe plany.
W tym rozdziale pokażę podstawowy proces przygotowania rysunków. Trzeba je wyprostować, sprawdzić poprawność proporcji i zapisać w plikach o ujednoliconych wymiarach. Użyjemy do tego Gimpa. Po zapoznaniu się z tymi sekcjami będziesz w stanie sam przygotować zestaw rysunków, których użyjesz w Blenderze.
Jeżeli chciałbyś dowiedzieć się, jak można dokładniej zweryfikować plany2 — polecam Rozdział 5 (“Szczegółowa weryfikacja planów samolotu”, str. 126). Porównuję tam rysunek, jaki przygotowaliśmy, z fragmentami rysunków fabrycznych P-40, a także ze zdjęciami. Korekty kształtu nanoszę w Inkscape. Tam ostatecznie możesz sprawdzić, na ile nasze rysunki nie kłamią! Metody, które stosuję, mogą być wykorzystane nawet do opracowywania nowych planów modelarskich.
Rysunki po zeskanowaniu nie nadają się do natychmiastowego użycia. Zazwyczaj są mniej lub bardziej zniekształcone — na przykład osie samolotu nie są idealnie poziome lub pionowe. Mogą im się także przytrafić problemy z wzajemną prostopadłością. Takie rzeczy trzeba sprawdzić i skorygować. Stworzymy w ten sposób ich poprawione wersje: każdy rzut w oddzielnym pliku. Najłatwiej jest to zrobić w Gimpie. (Jeżeli zupełnie nie znasz tego programu — patrz “Wprowadzenie”, str. 55).
Wczytaj do Gimpa jeden z zeskanowanych arkuszy, zawierający rzut z boku (szczegóły — str. 60). Zazwyczaj najlepiej jest użyć w tym celu jednego z głównych arkuszy planów. Raczej nie korzystaj z zestawienia różnych wersji samolotu. (Na rysunkach robionych metodą tradycyjną — w tuszu — zestawienie sylwetek wersji jest zawsze narysowane mniej starannie.) W tym konkretnym przypadku (publikacji AJ-Press) był z tym problem. Rzut z lewej znajduje się w niej pobliżu szwu zeszytu. W takim miejscu podczas skanowania kartka jest nieco wygięta, i rzut z boku wychodził zdeformowany. Nie chciałem rozcinać stron, i w ten sposób niszczyć mojego egzemplarza monografii. Przyjrzałem się więc dokładnie innym arkuszom planów. Na rysunkach Jacka Jackiewicza zestawienie wersji samolotu wydawało się tak samo dokładne, jak główny rzut. Zdecydowałem się więc z nich skorzystać, bo były najmniej zniekształcone przez wygięcie strony.
Rysunek 2.1.1 pokazuje, jak w Gimpie może wyglądać materiał “wejściowy” — zeskanowany arkusz planów modelarskich.
Rysunek 2.1.1 Wycięcie z planów modelarskich pojedynczego rzutu z lewej (w GIMP)
Wytnij z tego obrazu fragment, zawierający pojedynczy rzut z boku (szczegóły — patrz str. 63).
Teraz sprawdzimy, czy rysunek nie jest obrócony ani przekoszony. Umieść linie pomocnicze (guides: szczegóły — patrz str. 64) na kluczowych liniach konstrukcyjnych, o których wiesz, że powinny być pionowe lub poziome (Rysunek 2.1.2):
Rysunek 2.1.2 Przykładowe rozmieszczenie linii pomocniczych
Zapewne zapytacie, skąd wiem, które łączenia blach na kadłubie P-40 były pionowe lub poziome. No cóż, nie ma na to precyzyjnej odpowiedzi. Zacznijmy od poziomych. Na każdym rysunku i wielu zdjęciach widać na kadłubie długi “szew”, ciągnący się od ogona do okapotowania silnika (Rysunek 2.1.2). Jego linia przebiega odrobinę poniżej osi śmigła. W opisie technicznym samolotu można wyczytać, że kadłub P-40 był składany z dwóch połówek: górnej i dolnej. Co więcej, na zachowanych zdjęciach z odbudowy pewnego nowozelandzkiego P-40N widać, że granica podziału biegnie właśnie wzdłuż tego szwu. Wydaje się to tym bardziej prawdopodobne, że blachy w P-40 były łączone “na zakładkę”. Krawędź dolnej połówki kadłuba — ta niewidoczna, schowana “pod zakładką” — znajduje się jakieś 2 cm powyżej szwu. Wygląda na to, że leży na osi śmigła. To prawdopodobnie ślad po oryginalnej osi samolotu, jaka występowała na jego rysunkach konstrukcyjnych. Linie pionowe, które sprawdzam — są to po prostu linie głównych wręg. Krawędź steru kierunku — zakładam, że jest prostopadła do osi, bo na taką wygląda. (Zazwyczaj technolodzy, gdy robią już coś ukośnego, to jest to pochylone o jakiś znaczący kąt, a nie o ułamek stopnia).
W dużym pomniejszeniu szwy na rysunku zdają się doskonale przylegać do linii pomocniczych. Czy tak jest jednak na pewno? Trzeba to sprawdzić w większym zbliżeniu. (Zmiana widoku w GIMP — patrz str. 65.) Przejrzyj rysunek fragment po fragmencie, w powiększeniu. W strefie silnika i wokół kabiny wszystkie linie wydają się być w porządku. (Nie widać odchyleń narysowanych linii szwów od linii pomocniczych). Kłopot zaczyna się na ogonie (Rysunek 2.1.3). Linia głównego szwu, biegnąca poziomo przez cały kadłub, w tym obszarze wyraźnie jest zagięta w dół. Nie jest to duże odchylenie, ale wykracza poza tolerancję “zamiany linii na piksele”, dokonywanej przez skaner. Co więcej, linia szwu biegnącego powyżej jest odchylona w podobny sposób.
Rysunek 2.1.3 Szczegółowe sprawdzanie równoległości linii rysunku - odchylenia na ogonie
To mogłoby wskazywać na deformację rysunku w tylnej części, wywołaną np. nieznacznym wygięciem strony podczas skanowania. W takim jednak przypadku wszystkie linie w tym obszarze byłyby zdeformowane w ten sam sposób. A tak nie jest. Nałożyłem dodatkową linię pomocniczą na rząd nitów, biegnących tuż powyżej jednej ze zdeformowanych linii. Nie ma odchyleń! Zmierzyłem kąt zaklinowania statecznika poziomego — zgodnie z opisem technicznym samolotu powinien wynosić +2º — i tak jest! Więc co o tym sądzić?
Przyjrzyjmy się dokładniej. Rysunek Jacka Jackiewicza, który tu analizujemy, wygląda na wykonywany metodą tradycyjną. (Kreślony najpierw ołówkiem, potem — poprzez kalkę — tuszem.) Sądzę tak, gdyż poszczególne linie wydają się być odrobinę nierówne. Takie odstępy pomiędzy kropkami nitów są różne w różnych miejscach1. Wygląda na to, że odchylenia, znalezione na tym rysunku to drobna pomyłka, wynikająca z ręcznego wykonania. Widać linijka podczas kreślenia została przyłożona odrobinę nierówno do kalki. Pozostaje tylko pamiętać, podczas korzystania z rysunku, że na ogonie dwie linie są narysowane z drobnym błędem.
No dobrze, rzut z boku jest już przycięty i sprawdzony. Korekty w postaci drobnego obrotu nie potrzebuje, bo odpowiednie linie są poziome i pionowe. Teraz pozostaje usunąć z niego niepotrzebne resztki innych sylwetek, a potem zapisać na dysk jako oddzielny plik.
Do usunięcia z rysunku pozostałości innych sylwetek użyj “gumki” (Rysunek 2.1.4, szczegóły — str. 77):
Rysunek 2.1.4 Wymazywanie z rysunku niepotrzebnych elementów
Gdy oczyścimy obraz z „naleciałości”, czas go zapisać do oddzielnego pliku (szczegóły — patrz str. 61). Proponuję nadać obrazowi nazwę składającą się z:
krótkiego oznaczenia typu,
inicjałów autora (bo będziemy korzystać z obydwu),
nazwy rzutu (“Left”, “Top”, “Bottom”, “Right”, “Front”, “Back”).
Proponuję także nadać mu rozszerzenie .tif. (GIMP wybiera format zapisu na podstawie rozszerzenia nazwy pliku — „.tif” oznacza zapis w popularnym formacie TIFF).
Ostatecznie przygotowany plik będzie nosił nazwę: P40B-JJ-Left.tif. Będzie tak nazywany w całej książce. Przyznam, że uprościłem nieco oznaczenie tego samolotu. Ściśle rzecz biorąc, to sylwetka Curtiss Tomahawk IIA dostosowanego do celów rozpoznania. (Posiada kamerę w luku kadłuba i dodatkową antenę.) W istocie jednak ten typ (oznaczenie fabryczne Hawk 81-A2) był eksportową wersją P-40B, produkowanych równolegle dla USAAC. Antenę i kamerę podczas tworzenia modelu P-40B zignoruję, i wszystko będzie w porządku.
Przygotowanie zestawu rysunków, potrzebnych do stworzenia modelu, zawsze zaczynaj od rzutu z lewej. Ten rzut jest najczęściej najdokładniejszy2. Staraj się unikać pobierania rzutu z lewej z mniej ważnych fragmentów planów, np. zestawienia różnych wersji samolotu (str. 22).
Każdy rzut kadrujemy z zeskanowanego arkusza planów modelarskich do oddzielnego pliku (str. 22). (Zazwyczaj każdy arkusz planów zawiera więcej niż jeden rzut).
Sprawdzamy, czy uzyskany obraz nie ma deformacji (str. 23). (Gdyby były, należałoby je skorygować - patrz następna sekcja tego rozdziału).
Usuwamy niepotrzebne fragmenty obrazu (zazwyczaj resztki innych rysunków — str. 24).
Gotowy rysunek zapisujemy na dysk pod nową nazwą. Warto tu przyjąć jakąś zasadę nazewnictwa — ułatwi nam to później pracę (str. 24).
Przygotujmy teraz — w podobny sposób jak rzut z lewej — rysunek prawej strony. Zazwyczaj wybieram na ten rzut jakąś wersję z otwartym podwoziem. Podobnie jak rzut z lewej, odpowiednio ją kadrujemy (Rysunek 2.2.1):
Rysunek 2.2.1 Wykadrowanie rzutu z prawej
Teraz powinniśmy rysunek obrócić, aby ustawić sylwetkę poziomo. Wcześniej dodaj poziomą linię pomocniczą. Ustaw ją tak, by przechodziła przez czubek kołpaka śmigła (Rysunek 2.2.2). (W tym punkcie umieścimy oś obrotu):
Rysunek 2.2.2 Umieszczenie poziomej linii odniesienia
Trzeba jeszcze zwiększyć rozmiar obrazu w kierunku pionowym o jakieś 70%, aby zmieścił się w nim “wyprostowany” (obrotem) rzut z boku (szczegóły — str. 82). Inaczej statecznik pionowy znajdzie się poza rysunkiem.
Przygotowania do obrotu zakończone — linia pomocnicza jest na miejscu, rozmiar obrazu odpowiednio powiększony. Rozpocznij obrót. Zacznij od przesunięcia środka tam, gdzie linia pomocnicza przecina kołpak śmigła (Rysunek 2.2.3 — szczegóły str. 82):
Rysunek 2.2.3 Sylwetka samolotu przed obrotem
Podczas obracania staraj się doprowadzić do sytuacji, gdy lina pomocnicza będzie równoległa do głównego szwu kadłuba (Rysunek 2.2.4). Wartość, przy której to osiągnęliśmy — 13.43º — jest niemal idealnie zgodna z rysunkami gabarytowymi Curtiss (13.30º).
Rysunek 2.2.4 Sylwetka samolotu po obrocie
Po zatwierdzeniu obrotu przyjrzyjmy się kluczowym liniom rzut z prawej i podobnym liniom na opracowanym poprzednio rzucie z lewej (Rysunek 2.1.2).Sprawdź uważnie oś kadłuba. W widoku z lewej strony oś biegnie od czubka kołpaka śmigła, ale niemal dotyka głównego szwu kadłuba. A na naszym rzucie (Rysunek 2.2.4), jest od niego zdecydowanie odsunięta. Wygląda na to, że widok z prawej ma wyżej podniesiony nos samolotu!
Popatrzmy uważniej na ten obszar (Rysunek 2.2.5):
Rysunek 2.2.5 Zniekształcenie nosa samolotu (rzut z prawej)
Tym razem to nie jest błąd autora — wygląda na to, że przód samolotu jest wygięty do góry. Przyczyną było najprawdopodobniej wygięcie w tym miejscu strony podczas skanowania. (Ten fragment był niedaleko od szwu zeszytu monografii, takie wygięcia mogą się zdarzyć).
W sumie — nie wiadomo, czy rysunek nie zawiera innych, mniej rzucających się w oczy różnic. Najlepiej byłoby nałożyć na siebie obydwa rzuty — z prawej i lewej, i sprawdzić, gdzie ich linie się “rozjeżdżają”. (Takie nałożenie to bardzo wymagający test dla rysunków kreślonych ręcznie. Człowiek praktycznie nie jest w stanie narysować w sposób identyczny dwóch tak złożonych kształtów).
GIMP umożliwia taką operację. Dodamy rzut z lewej jako oddzielną warstwę rysunku. Następnie zwiększymy przejrzystość tej warstwy, by widać było jednocześnie linie obydwu sylwetek.
Na razie zapisz tę sylwetkę z boku do nowego pliku: P40B-JJ-Right.tif. Aby porównać ten rysunek z rzutem z lewej, wykonaj lustrzane odbicie aktualnego obrazu (Layer→Transform→Filp Horizontally). (Nie martw się, na koniec wykonamy je znowu, aby powrócić “na właściwą stronę”).
Teraz wczytaj plik P40B-JJ-Left.tif jako nową warstwę (File→Open as Layers), i zwiększ jej przejrzystość (szczegóły — str. 68). Rysunek 2.2.6 pokazuje, jak takie złożenie może początkowo wyglądać:
Rysunek 2.2.6 Efekt włączenia przejrzystości na górnej warstwie obrazu
Warstwa z wczytanym rzutem z lewej nazywa się tak jak plik — P40B-JJ-Left.tif. Nasuń ją na rysunek prześwitujący “spod spodu” (szczegóły — str. 83). Podczas dopasowywania położenia rzutów największą uwagę zwracaj na takie linie charakterystyczne, jak główne szwy oraz krawędzie sterów. (Wszystko to, co jest narysowane prostymi liniami i wyznacza ważne miejsca konstrukcyjne.) Pamiętaj, że na rysunkach kreślonych ręcznie różnice mogą wystąpić na wszelkich krzywiznach. (Na przykład — obrysy kadłuba lub steru kierunku mogą się różnić.) Nałóż na siebie sylwetki tak, aby główny szew kadłuba oraz ostatnia wręga były w tym samym miejscu.
Przyjrzyjmy się rezultatom. Wygląda na to, że środek kadłuba jest narysowany na obydwu sylwetkach dokładnie tak samo. Różnice pojawiły się z przodu (Rysunek 2.2.7) i na ogonie (Rysunek 2.2.8).
Rysunek 2.2.7 Porównanie dwóch sylwetek z tych samych planów - część przednia
Rysunek 2.2.8 Porównanie dwóch sylwetek z tych samych planów - część tylna
Widoczne są wyraźne odchylenia kształtu statecznika i steru kierunku. Sądzę, że jest to przekoszenie. (Linie żeber i inne linie, które powinny być poziome, są poziome. Linie pionowe za to są pochylone. A to świadczy o tym, że nie jest to obrót).
Nim zaczniemy korygować znalezione różnice, musimy zmienić kolejność warstw. W zakładce sterującej warstwami (okno przybornika — Rysunek 2.2.9):
Włącz pełną nieprzejrzystość warstwy P40B-JJ-Left.tif (Opacity na 100%);
Przesuń na liście warstwę P40B-JJ-Right.tif tak, by znalazła się u samej góry;
Zmień nieprzejrzystość warstwy P40B-JJ-Right.tif (Opacity na 50%);
Zaczniemy od skorygowania przekoszania ogona. Ustaw linię pomocniczą tak, by wyznaczała prawidłowe położenie końcowej krawędzi kadłuba (Rysunek 2.2.10). (Jest to jednocześnie miejsce, gdzie zaczyna się ster kierunku). To nasz wzór, na którym będziemy sprawdzać, czy krawędź steru stała się już pionowa.
Zaznacz na rysunku prostokątny obszar (szczegóły — str. 78). Tę deformację poprawimy także przekoszeniem (Tools→Transform Tools→Shear — szczegóły na str. 85), tylko w drugą stronę.
Rysunek 2.2.10 Prostowanie (przez przekoszenie) obszaru usterzenia
Zwróć uwagę na wybór deformowanego obszaru (Rysunek 2.2.10). Linie pionowe są w tej transformacji poddane niewielkiemu obrotowi. Pionowe granice zaznaczonego obszaru poprowadziłem więc przez kadłub tam, gdzie przecinają same poziome łączenia blach kadłuba. Z kolei linie poziome ulegną tylko przesunięciu. Poprowadziłem je więc wzdłuż linii szwu na kadłubie. W ten sposób przesunięcie tych pikseli nie zepsuje zbytnio rysunku.
Rysunek 2.2.11 przedstawia uzyskany efekt — uzgodniony obrys usterzenia pionowego.
Rysunek 2.2.11 Obrys statecznika po korekcie
Przy takich transformacjach, dokonywanych na obrazach rastrowych, zawsze wystąpią efekty uboczne. W oknie głównym zmień nieprzejrzystość aktualnej warstwy z powrotem na 100. Teraz zobaczymy, co nam na rysunku się popsuło (Rysunek 2.2.12):
Rysunek 2.2.12 Niedokładności, o których trzeba pamiętać (aby ich nie przenieść na model)
Przyglądając się efektom, z ulgą można stwierdzić, że defekty są stosunkowo niewielkie (Rysunek 2.2.12):
przesunęły się trzy linie nitów (ale, dzięki pozostałościom u dołu, widać gdzie być powinny),
fragment głównego szwu kadłuba jest odrobinę przesunięty do dołu (ale widać, gdzie powinna przebiegać);
tylna krawędź kadłuba jest lekko wykrzywiona;
zanika najniższe żebro steru kierunku.
Moglibyśmy jeszcze raz użyć narzędzi Gimpa, aby poprawić te błędy. Naszym ostatecznym celem nie jest jednak naprawa planów P-40. Korygujemy rysunki tylko w takim zakresie, by wystarczyły do stworzenia jak najdokładniejszego modelu. Najważniejszą rzeczą jest zgodność kształtu. W przypadku drobnych nieprawidłowości w liniach nitów lub szwów wystarczy pamiętać, że ten obraz był w tym miejscu poprawiany. Podczas modelowania zignorujemy te różnice, traktując rzut z lewej jako wzór.
Otwartą sprawą pozostaje kwestia, skąd wzięła się ta poprawiona deformacja. Przypuszczam, że może być efektem odkształcenia podczas druku. Inną możliwością jest pomyłka autora planów. W każdym razie takie różnice pozwalają nam ocenić granice możliwego błędu przygotowywanych rysunków.
Do prostowania przodu samolotu użyjemy obrotu (Rysunek 2.2.13):
Rysunek 2.2.13 Prostowanie przodu samolotu
Zwróć uwagę, że linie łączeń blach pod skrzydłem są zgodne, a kabiny, położonej ponad nimi - nie. Tego obszaru nie można “wybrać prostokątem”. Zastosuj inną metodę selekcji: dowolnym obrysem (szczegóły — str. 79). Ważne jest także takie dobranie punktu obrotu, aby wiatrochron kabiny nie uniósł się do góry. Jednocześnie linie łączenia blach przed wiatrochronem powinny przesunąć się do przodu. Rysunek 2.2.13 pokazuje położenie osi obrotu, dla której efekt końcowy wydaje się całkiem zadowalający (por. Rysunek 2.2.14 - z Rysunek 2.2.7, str. 29):
Rysunek 2.2.14 Wyprostowany nos samolotu (obydwie sylwetki są na siebie nałożone)
W wyniku obrotu nosa obydwie sylwetki niemal idealnie się pokryły (Rysunek 2.2.15). Jedynie celownik przed kabiną jest odrobinę wyżej. Właściwie tylko po różnicy w pozycji odsuniętej owiewki można poznać, że są tu nałożone na siebie dwa rysunki. Niemal udało się uniknąć “ubocznych” deformacji:
Rysunek 2.2.15 Niedokładności, pozostałe po wyprostowaniu nosa samolotu
Końcówki śmigła leżą (w zakresie akceptowalnej tolerancji) na tej samej linii pionowej. Większość łączeń blach przyjęła poprawne położenia, za wyjątkiem dwóch (Rysunek 2.2.15). (Będzie trzeba o nich pamiętać).
Gotowy obraz przerzuć z powrotem w poziomie w przeciwną stronę (Image→Transform→Filp Horizontally).
Na koniec usuń warstwę z rzutem z lewej (szczegóły — str. 74) — nie będziemy jej więcej używać. Oczyść rysunek z niepotrzebnych linii (str. 77) i zapisz (jako P40B-JJ-Right.ti).
Podsumowanie
Sprawdzanie rysunku rozpocznij od porównania z liniami pomocniczymi (str. 28);
Następnie porównaj go z rzutem z przeciwnej strony (str. 29);
Wykryte deformacje można skorygować za pomocą różnych transformacji: obrotu (pamiętaj, ważne jest położenie środka tej transformacji! — str. 28), przekoszenia (Shear — str. 30), przesunięcia, i zmiany skali w jednym kierunku (ta ostatnia jest opisana w następnej sekcji);
Podczas korygowania używaj linii pomocniczych, które pozwolą Ci w trakcie transformacji na bieżąco sprawdzać, czy osiągnąłeś już cel (str. 30).
W sylwetkach bocznych samolotu, które do tej pory opracowaliśmy, koncentrowaliśmy przede wszystkim na odchyleniach od osi poziomej. To dlatego, że wysokość rzutu z boku jest o wiele mniejsza od jego długości. Pewne deformacje wzdłuż osi Y, nawet jeżeli istnieją, powodują odchylenia mieszczące się w granicach tolerancji.
Zupełnie inaczej jest z rzutem z góry lub z dołu. Tutaj ważne są obydwa kierunki, i każdy z nich musi być starannie sprawdzony. Pokażę to na przykładzie przygotowywania rzutu z góry z rysunków Jacka Jackiewicza.
Rysunek 2.3.1 “Wyprostowanie” rzutu z góry, poprzez obrót całego arkusza
Rysunek 2.3.1 ilustruje przekształcenia, jakim należy poddać obraz po załadowaniu:
obróć obraz o 90º (Image→Transform→Rotate 90º counter-clockwise) ;
dodaj pionową linii pomocniczej. Umieść ją tak, by przechodziła przez czubek kołpaka śmigła. (To dlatego, że punkt ten leży mniej więcej w środku rysunku, w pobliżu górnej krawędzi);
obróć cały obraz (Tools→Transform Tools→Rotate), tak, by oś kadłuba znalazła się dokładnie pod linią pomocniczą.
Po tym wstępnym “wyprostowaniu” należy sprawdzić, czy skrzydła nie są przekoszone. (Od tej pory wszelkie błędy obrazu będziemy poprawiali transformacją Shear w kierunku równoległym do osi samolotu. Przyczyna jest prosta — wszystkie linie równoległe do osi wzdłużnej są już wyprostowane. Dalsze obroty mogłyby tylko coś popsuć).
Zgodnie z przyjętą konwencją, zapisz ten obraz pod nazwa P40B-JJ-Top.tif.
Zweryfikujmy, czy końce krawędzi płata leżą w tym samym miejscu (Rysunek 2.3.2):
Rysunek 2.3.2 Sprawdzanie deformacji płata
Nałóż na rysunek kilka poziomych linii pomocniczych, umieszczając je w punktach charakterystycznych lewej końcówki płata. Gdyby skrzydła nie były zdeformowane, linie powinny przejść przez analogiczne punkty na prawej końcówce. Tak się jednak nie dzieje — widać wyraźną różnicę (Rysunek 2.3.2).
Skoryguj przekoszenie w kierunku osi Y (Tool→Transform Tools→Shear). Nie zaznaczaj żadnego obszaru, by deformowany był cały obraz. (Taka deformacja dotyczy zazwyczaj całego zeskanowanego arkusza.) GIMP sam ustala środek (punkt neutralny) transformacji — jest to środek obrazu, a więc punkt w pobliżu osi podłużnej kadłuba. W przypadku, jaki pokazuje Rysunek 2.3.2, konieczne się stało skorygowanie przekoszenia w kierunku osi Y o -19 pikseli (przy rozmiarach obrazu rzędu 2400 x 2900 px).
Teraz płat jest już poprawny. Przy przeglądaniu rysunku znajdujemy kolejną deformację — statecznika poziomego (Rysunek 2.3.3):
Rysunek 2.3.3 Kolejny problem - wykrzywiony statecznik poziomy
Wygląda na to, że po wyprostowaniu skrzydła powiększyła się deformacja usterzenia poziomego. (Stało się jeszcze bardziej przekoszone). Przynajmniej kadłub i skrzydło mamy już wyprostowane.
Tym razem musimy to poprawić, ograniczając transformację do obszaru usterzenia. Jak pokazuje Rysunek 2.3.4, zrobiłem to obszarem prostokątnym (szczegóły — str. 78):
Rysunek 2.3.4 Prostowanie statecznika poziomego
Przy właściwym doborze obszaru deformacji, możliwe jest, w tym przypadku, uniknięcie “popsucia” innych linii na planach (Rysunek 2.3.5):
Rysunek 2.3.5 Wyprostowane usterzenie poziome
Pomijam w tej sekcji następny sprawdzian — porównanie sylwetek rzutu z góry z rzutem z dołu. Należy je porównać w ten sam sposób (poprzez nałożenie), w jaki porównywaliśmy rzuty z lewej i z prawej (str. 28). W tym przypadku trudniej jest mi poradzić, który rzut jest ważniejszy. Gdy znajdziesz różnice — pozostaje porównanie ze zdjęciami, aby określić która wersja jest bliższa rzeczywistości. Ja traktuję rzut z góry jako “ważniejszy”.
Na koniec pozostaje sprawdzić, czy rysunek ma właściwe proporcje. Chodzi o prostą sprawę: stosunek długości i rozpiętości powinien być taki sam, jak w rzeczywistym samolocie.
Znalazłem w Internecie (http://www.p40warhawk.com) oryginalne rysunki gabarytowe P-40B/C, zaakceptowane przez USAAC w kwietniu 1939 (Rysunek 2.3.6). Zostały opublikowane (odtajnione) przez firmę Curtiss w 1941, ponad dwa lata po oblocie prototypu. Nie oszałamiają dokładnością linii, ale zawierają rzecz cenną: kilka dodatkowych wymiarów poza rozpiętością i długością. Zwymiarowano na nich np. trapez skrzydła (poprzez podanie cięciwy u nasady, na końcu, i kąta pochylenia krawędzi natarcia). Podano także rozpiętość usterzenia poziomego. Wymiary, naniesione w sposób tak jednoznaczny przez producenta — to dobre narzędzie weryfikacji.
Rysunek 2.3.6 Gabaryty P-40B/C — w stopach i calach (Curtiss, 1941)
Zmierzmy długość i rozpiętość rysunku, używając pikseli jako jednostki. GIMP wyświetla aktualne współrzędne kursora w lewym dolnym narożniku ekranu (Rysunek 2.3.7):
Rysunek 2.3.7 Odczytywanie współrzędnych początku kadłuba
Wystarczy ustawić kursor myszki na początku kadłuba, i odczytać współrzędną Y aktualnej pozycji. Podobnie — ustawiając kursor — można odczytać pozostałe trzy wymiary, potrzebne do określenia długości i rozpiętości rysunku. Tabela 2.3.1 pokazuje wyniki pomiaru:
| Wymiar | Początek (px) | Koniec (px) | Różnica (px) |
| Kadłub | Y: 124 | Y: 2476 | 2352 |
| Płat | X: 328 | X: 3126 | 2798 |
Tabela 2.3.1 Zmierzone wymiary rysunku (piksele — px)
Zgodnie z fabrycznymi rysunkami P-40B miał długość 967 cm (31 stóp i 8 9 / 16 cala). Rozpiętość wynosiła - 1137 cm (37 stóp i 3 1 / 2 cala). Daje to stosunek długości do rozpiętości = 967 / 1137 = 0.85048. Jeżeli zmierzona rozpiętość rysunku to 2798 px (Tabela 2.3.1), to długość powinna wynosić 2798 px * 0.85048 = 2379 px.
Różni się to od wartości zmierzonej (2352 px). Wynikałoby z tego, że kadłub w rzucie z góry jest za krótki o 27 pikseli. Czy na pewno? Równie dobrze można przyjąć, że długość rysunku Jacka Jackiewicza jest poprawna, a rozpiętość wymaga małego “ściśnięcia” (o 2798 - (2352 / 0.85048) = 32 piksele).
Załóżmy, że długość kadłuba jest poprawna. Daje to skalę 2.43 pikseli / cal. Stosując tę wartość, można określić inne wymiary, które warto sprawdzić:
cięciwa największego żebra skrzydła (leży w osi kadłuba) powinna mierzyć na rysunku 667 pikseli (wg planów Curtissa miała dokładnie 9 stóp, czyli 108 cali);
rozpiętość usterzenia poziomego powinna wynosić na rysunku 949 pikseli (wg planów Curtissa wynosiła 12 stóp i 9 5 / 8 cala).
Przedłużmy na planach Jacka Jackiewicza linie krawędzi natarcia i krawędź spływu skrzydła (Rysunek 2.3.8). Ich przecięcie z osią kadłuba wyznacza początek i koniec “żebra kadłubowego”. Ten odcinek powinien mieć długość 667 pikseli, a ma 676 — o 9 za dużo. Wygląda więc na to, że płat jest za duży w stosunku do kadłuba. (Ma większe obydwa podstawowe wymiary: cięciwę i rozpiętość).
Podobnie za duża jest rozpiętość statecznika poziomego. Powinna wynosić 949 pikseli, a wynosi 960 — o 11 pikseli za dużo (Rysunek 2.3.8):
Rysunek 2.3.8 Różnice pomiędzy planami a rzeczywistymi wymiarami samolotu.
W którym kierunku skorygować rysunek? Aby to ostatecznie rozstrzygnąć, sprawdźmy, jak pasuje rzut z lewej do widoku kadłuba z góry. Czy długości poszczególnych elementów się zgadzają? Przygotujmy rysunek do porównania:
dokonaj konwersji obrazu na odcienie szarości (o ile nie zrobiłeś tego wcześniej): Image→Mode→Grayscale;
obróć rysunek o 90º w lewo: Image→Transform→Rotate 90º counter-clockwise;
Załaduj jako nową warstwę plik P40B-JJ-Left.tif (File→Open as Layers) . W przyborniku, w zakładce Layers, zmniejsz nieprzejrzystość (Opacity) warstwy P40B-JJ-Left.tif ze 100 na 50;
Na koniec spróbuj nasunąć rzut z lewej na kadłub rzutu z góry. Zrób to tak, aby linie kołpaka śmigła jak najlepiej się pokryły (Rysunek 2.3.9):
Rysunek 2.3.9 Złożenie — kadłub, rzutu z lewej i rzutu z góry
Na pierwszy rzut oka wygląda to jak plątanina linii. Jednak w zbliżeniu na obydwu rzutach dostrzeżesz wspólne punkty charakterystyczne. Długość kadłuba na obu rysunkach jest idealnie zgodna. Obrys kołpaka - również. Nie można znaleźć większej różnicy w pozycjach poszczególnych linii w okolicach usterzenia. (Krawędzie sterów są w tym samym miejscu).
Za to środek kadłuba — tu mamy różnice! (Rysunek 2.3.10) Krawędź natarcia skrzydła w rzucie z góry jest przesunięta do przodu o 12 pikseli. (W stosunku do krawędzi natarcia w rzucie z boku.) Z kolei cały obszar kabiny, zaczynając od przedniej krawędzi skrzydła, wydaje się być przesunięty do tyłu o 4-5 pikseli.
Rysunek 2.3.10 Różnice w położeniu szczegółów kadłuba i skrzydła
Załóżmy (coś trzeba założyć), że rzut z lewej jest poprawny1. Będziemy go traktować jako wzór. W tej sytuacji wygląda na to, że należy dokonać jeszcze następujących poprawek:
przeskalować cały rysunek wzdłuż osi Y, aby zmniejszyć rozpiętość płata o 32 piksele (i — proporcjonalnie — usterzenia poziomego);
“ścisnąć” skrzydło, wraz z fragmentem kadłuba, o 9 pikseli wzdłuż osi X. (Krawędź spływu pozostaje, mniej więcej, w dotychczasowym miejscu). W ten sposób płat ulegnie proporcjonalnemu (przynajmniej w przybliżeniu) zmniejszeniu.2
rozciągnąć sam kadłub w kierunku osi X, od statecznika pionowego do okapotowaniu silnika. Przy okapotowaniu silnika powinna nastąpić największa deformacja — o 5 pikseli do przodu;
Nim wykonamy krok 1, przytnij obraz tak, by zawierał wyłącznie rzut z góry (szczegóły — str. 63). Zrób to tak, by jego krawędzie — górna i dolna — były jak najbliżej końcówek skrzydeł.
Przygotowując rysunek do poprawek, zmień kolejność warstw: Layer→Stack→Reverse Layer Order.
zmień nieprzejrzystość (Opacity) warstwy z rzutem z lewej (P40B-JJ-Left.tif) na 100 (kompletnie nieprzejrzysta).
zmień nieprzejrzystość (Opacity) warstwy z rzutem z góry (P40B-JJ-Top.tif) ze 100 na 75;
(Szczegóły zarządzania warstwami znajdziesz na str. 68). Rysunek 2.3.11 pokazuje, jak powinno wyglądać ułożenie warstw przed dalszymi transformacjami. Zwróć uwagę, aby podświetlona (aktywna) była warstwa z rzutem z góry.
Teraz wykonaj pierwszy z zaplanowanych kroków: zmniejsz rozmiaru całości wzdłuż osi Y (rozpiętość) o 32 piksele (szczegóły — str. 87). Przekształć w ten sposób całą aktywną warstwę (tzn. nie zaznaczaj wcześniej żadnego obszaru).
Następnie wykonamy krok drugi: “ściśnięcie” obszaru skrzydła, wraz z kadłubem, o 9 pikseli. Obramuj skrzydło prostokątnym obszarem selekcji (Rysunek 2.3.12), a następnie wybierz znów polecenie zmiany skali.
Rysunek 2.3.12 “Ściśnięcie” skrzydła w kierunku X
Po zakończeniu zmiany skali znów należy - podobnie jak poprzednim razem - odrobinę przesunąć przeskalowany obszar. Tym razem trzeba dosunąć go do tyłu. (Gdy wpisujesz nowy rozmiar w pola Width lub Height, środkiem skalowania jest w GIMP zawsze lewy górny narożnik obszaru selekcji. W związku z tym, w wyniku zmiany skali, przesunęła się w lewo krawędź spływu płata, a nie jego krawędź natarcia — por. Rysunek 2.3.13.) Lukę po skalowaniu poprawimy przesunięciem o 9 pikseli w prawo. Wywoła to efekt “krótkiej kołderki” z przodu selekcji. Luka pojawi się teraz w obszarze okapotowania silnika, pomiędzy rurami wydechowymi a początkiem skrzydła. (Spokojnie, skorygujemy ją wykonując trzeci, ostatni krok zaplanowanej transformacji.)
Rysunek 2.3.13 Po skalowaniu: przerwę z tyłu zamieniamy na przerwę z przodu
Ostatni krok transformacji ma polegać na wyciągnięciu w kierunku silnika samego kadłuba, bez skrzydła. Żadna z metody selekcji, które dotychczas poznaliśmy, nie jest do tego odpowiednia. Zaznaczenie prostokątem objęłoby i przesunęło nie tylko kadłub, ale także fragment skrzydła. Z kolei Free Select zbyt zależy od losowych drgnięć ręki. Jak możesz się przekonać, nie mam jej zbyt pewnej (Rysunek 2.2.14, str. 32).
Pozostaje mi skorzystać z innej możliwości Gimpa: narysowania obszaru selekcji. Opisując rzecz w skrócie, robi się to w następujący sposób:
tworzysz na chwilę nową, (przejrzystą) warstwę (patrz str. 73);
rysujesz na niej kształt selekcji (patrz str. 75);
wywołujesz polecenie Layer→Transparency→Alpha to Selection (por. 80) ;
“sprzątasz” po operacji: usuwasz niepotrzebną już warstwę z kształtem selekcji (patrz str. 74);
Nim zamienisz narysowany kształt w selekcję, wprowadź pewną poprawkę. Wykonaj za pomocą „gumki” (Eraser — patrz str. 77) niewielkie wgłębienia wszędzie tam, gdzie z kadłubem styka się jakaś linia skrzydła (Rysunek 2.3.14):
Rysunek 2.3.14 Przygotowanie obszaru selekcji — wymazanie “naddatków”, wykonanie wgłębień
Takie wgłębienia pozwolą uniknąć pozostałości po transformacji w postaci brzydkich, krótkich, poprzecznych linii. Teraz możesz przekształcić narysowany kształt na selekcję: Layer→Transparency→Alpha to Selection.
Następnie przeskaluj zaznaczony obszar. Tym razem, po wywołaniu polecenia Scale, nie wpisuj wartości w oknie dialogowym. Zamiast tego użyj jednego z uchwytów obszaru selekcji, by dopasować położenie kabiny do zaznaczonych na rysunku linii pomocniczych (Rysunek 2.3.15). (Linie te nanieś na podstawie rzutu z lewej — patrz Rysunek 2.3.10, str.40)
Rysunek 2.3.15 Zmiana skali za pomocą uchwytów obszaru selekcji
Po przeskalowaniu nie zapomnij o wywołaniu Layer→Anchor Layer, by zatwierdzić transformację! Rysunek 2.3.16 pokazuje efekt rozciągnięcia kadłuba. Udało się dopasować do rzutu z lewej linie kabiny i dalsze szwy, w kierunku ogona.
To, co pozostało po tej transformacji, to nieco wysunięte do przodu (w stosunku do wzoru) łączenia blach przed kabiną. Różnice są jednak niezbyt duże. W dodatku położenie tych szwów w rzucie z góry nie wydaje się godne zaufania — nawet nie są pionowe! Wygląda to na niedokładność podczas kreślenia. Po oryginalnych “wgłębieniach” w okolicach łączenia linii skrzydła i kadłuba pozostały teraz przesunięte przerwy (Rysunek 2.3.16). W wykorzystaniu rysunku do naszych celów nie będzie to przeszkadzać. Zapewniam, że to wygląda o wiele lepiej, niż gdybyśmy takich wgłębień w kształcie selekcji nie zrobili.
Rysunek 2.3.16 Efekt trzeciego kroku - kadłub w rzucie z góry jest “dociągnięty” do rzutu z lewej
Mamy więc ostatecznie “wyprostowany” rzut z góry, uzgodniony z rzutem z boku. Na koniec:
usuń wszystkie warstwy pomocnicze, pozostawiając tylko rzut z góry (P40B-JJ-Top.tif);
obróć rysunek o kolejne 90º (Image→Transform→Rotate 90º counter-clockwise);
wymaż “gumką” wszystkie niepotrzebne fragmenty które pozostały ze skanowanego arkusza (Tools→Paint Tools→Eraser);
przełącz tryb barw z powrotem na odcienie szarości (Image→Mode→Grayscale);
Dodatkowo możesz “spłaszczyć” rysunek (poleceniem Image→Flatten Image)3.
Rysunek 2.3.17 pokazuje ostateczną postać rzutu z góry z planów Jacka Jackiewicza. Zapisz go (pod nazwą P40B-JJ-Top.tif).
Rysunek 2.3.17 Ostateczna postać rzutu z góry
W rzutach z góry i z dołu wyszukaj i popraw ewentualne przekoszenia skrzydła i statecznika poziomego (str. 35 - 36).
Duże korekty kształtu (np. całego skrzydła) powodują pojawienie się mniejszych, lokalnych deformacji (str. 42 - 43). Od razu staraj się je przewidzieć, by potem skutecznie wykonać odpowiednie lokalne poprawki.
Porównaj z rzutem z lewej rzuty z góry i z dołu. Sprawdź, czy pozycje elementów kadłuba są na nich takie same (str. 39).
Sprawdź proporcje rysunku, przede wszystkim rozpiętości do długości (por. str. 37 - 39). W miarę możliwości, należy sprawdzić także inne wymiary (jeżeli są znane).4 Wnioski z tej weryfikacji mogą prowadzić do dalszych korekt.
Niektóre z korekt — jak wydłużenie w tej sekcji samego kadłuba, bez skrzydła — wymagają użycia selekcji “przez narysowanie” (str. 42).
Do pracy nad modelem w Blenderze potrzebne są następujące rzuty samolotu (w nawiasach podaję nazwy, jakie nadałem odpowiednim plikom):
widok z lewej (P40B-JJ-Left.tif);
widok z prawej (P40B-JJ-Right.tif);
widok z góry (P40B-JJ-Top.tif);
widok z dołu (P40B-JJ-Bottom.tif);
widok z przodu (P40B-JJ-Front.tif).
Oprócz tego, możesz także przygotować dodatkowo:
widok z tyłu (czasami się przydaje) (P40B-JJ-Rear.tif);
W poprzednich sekcjach pokazałem, jak przygotowywać rzuty w GIMP, uzyskując obrazy 1, 2, 3 (Rysunek 2.4.1). Teraz przygotuj w ten sam sposób pozostałe elementy (4, 5, 6) z powyższego zestawienia. Powinieneś uzyskać ostatecznie sześć rysunków:
Rysunek 2.4.1 Unifikacja rozmiarów i położenia sylwetek “podkładów” dla Blendera
Zwróć uwagę, że odpowiednie wysokości i szerokości (wymiary A i B) poszczególnych rysunków zostały ujednolicone (Rysunek 2.4.1), podobnie jak położenie sylwetki wewnątrz obrazu (wymiary f,g,h). Rysunek 2.4.1 pokazuje rzut z dołu (4) obrócony o 90º w lewo. Ustawiłem go w ten sposób wyłącznie na tej ilustracji. Chciałem w ten sposób pokazać, że długość boku A i odstęp f są takie same, jak na rzucie z boku.
Odpowiednie odległości A, B, f, g, h powinny mieć taką samą długość (mierzoną w pikselach) na każdym z rysunków
Aby takie ujednolicenie uzyskać, ostatnimi krokami, które wykonywałem w GIMP, były:
zmiana rozmiaru obrazu na “standardowy” (czyli taki z wymiarem A, B);
załadowanie, w charakterze wzorca, poprzednio przygotowanego rysunku (do nowej warstwy);
dopasowanie sylwetki na obrazie do rozmiarów i położenia sylwetki — wzorca;
usunięcie warstwy ze wzorcem;
zapisanie sprawdzonego w ten sposób obrazu do pliku.
Ujednolicone wymiary rysunków, które pokazałem na przykładowym zestawieniu (Rysunek 2.4.1), wynoszą: A = 2390px, B = 2827px. Nie są to żadne “magiczne” liczby. Po prostu szerokość pierwszego rysunku — rzutu z lewej — zdeterminowała mi wymiar A. Podobnie szerokość rzutu z góry określiła wymiar B. Położenie osi samolotu względem krawędzi tych rysunków podyktowało mi wymiary f,g,h, do których dopasowałem pozostałe sylwetki.
Ujednolicenie położenia sylwetek względem granic obrazu nie jest konieczne. Jednak narzucenie sobie tej reguły bardzo ułatwi późniejsze pozycjonowanie rysunków jako “podkładów” w Blenderze
Do tej pory pokazywałem wszystkie operacje na przykładzie rysunków Jacka Jackiewicza. Na początku tego rozdziału wspomniałem, że mamy do dyspozycji także drugie plany - opracowane przez Mariusza Łukasika1. W istocie obydwa opracowania nie różnią się specjalnie. Wydaje mi się, że Mariusz Łukasik korzystał w szerokim zakresie z rysunków Jacka Jackiewicza. (Nie ma w tym nic złego, plany są także po to publikowane). Porównując te rysunki, dostrzegłem następujące różnice:
Kadłub na rysunkach M.Ł. jest o ok. 2% dłuższy od rysunków J.J. Wygląda na to, że został proporcjonalnie rozciągnięty wzdłuż osi X.
Rzut z przodu na planach J.J. ma zbyt nisko narysowany kołpak i śmigło, oraz zbyt wąski rozstaw kół. M.Ł. skorygował te błędy. Co prawda z rozstawem kół podwozia nie do końca się udało2. Dodatkowo linie płata w rzucie z tyłu i z przodu na rysunkach M.Ł. nie pokrywają się.
M.Ł zastosował bardziej poprawny obrys steru wysokości. (Na rysunkach J.J. krawędź spływu steru jest zbyt “wypukła”).
Sądzę, że gdy Mariusz Łukasik znalazł na rysunkach Jacka Jackiewicza niewłaściwe proporcje rozpiętości i długości, zdecydował się je poprawić przez wydłużenie kadłuba. (My zmniejszyliśmy skrzydła i stateczniki — por. str. 38). Aby te sylwetki uzgodnić, na planach M.Ł. wydłużyłem rzut z boku i kadłub w rzucie z góry o 2%. Nałożyłem tak przygotowane sylwetki na rysunki J.J. Okazało się, że doskonale do siebie pasują. Można je stosować zupełnie wymiennie! Na przykład - zamierzam wykorzystać rzut z prawej z rysunków M.Ł, gdyż ma “odjęte” skrzydło (Rysunek 2.4.2). (Takiego ujęcia nie ma na rysunkach Jacka Jackiewicza).
Rysunek 2.4.2 Rzut z prawej — z planów Mariusza Łukasika
Rysunki Mariusza Łukasika zostały wykonane za pomocą komputera. Tu już się nie zdarzają “poślizgi linijki”, jak na rysunkach robionych ręcznie. Mają także bardziej jednorodne, wyraźne linie. Przygotowałem drugi zestaw sześciu rzutów na podstawie tych planów. Nadałem tym plikom nazwy zaczynające się od “P40C-ML-”. (Na przykład Rysunek 2.4.2 to P40C-ML-Right.tif).
Z rysunkami, które opracowaliśmy w tym rozdziale, można wykonać model P-40. Czy jednak będzie naprawdę taki, jak oryginał? Jeżeli jesteś modelarzem, a nie tylko grafikiem komputerowym, zapewne będziesz chciał to sprawdzić. Zapraszam do zajrzenia do dodatkowych materiałów, na końcu tej książki (Rozdział 5, “Szczegółowa weryfikacja planów samolotu”, str. 126). Dla “pobudzenia apetytu” pokazuję rezultat weryfikacji rzutu z boku (Rysunek 2.4.3):
Rysunek 2.4.3 Korekty rzutu z boku, naniesione po dokładnej weryfikacji
Czerwonymi liniami oznaczyłem różnice. Jest ich sporo, nieprawdaż?
Podsumowanie
Warto jest ujednolicić szerokość i wysokość poszczególnych rysunków samolotu (str. 46). Także położenie sylwetki samolotu względem lewego górnego narożnika rysunku powinno być takie samo.
Rysunki można poddać dalszej weryfikacji, polegającej na dokładnym porównaniu kształtu ze zdjęciami (str. 126). Nie jest to jednak niezbędne.
Zawartość tej części bardzo przypomina zawartość plików podpowiedzi do trzech programów: GIMP, Inkscape i Blendera. Są tu zestawione opisy tych poleceń, które zostały wykorzystane w poprzednich częściach książki. Z założenia będziesz z nich korzystał wyrywkowo (por. „Jak czytać tę książkę?”, str. 11). Nie doszukuj się więc w kolejności rozdziałów i sekcji tej części jakiejś przemyślanej metody wprowadzania w obsługę programu. Do tego służy część pierwsza — „Budowa modelu”. To tam specjalnie dobrałem kolejność prezentowanego materiału w ten sposób, byś mógł stopniowo poznawać wszystkie potrzebne zagadnienia.
Gdy zdecydujesz się wydrukować tę książkę dla własnych potrzeb, proponuję pozostawić tą część w postaci elektronicznej. W przeglądarce PDF szybciej znajdziesz podaną w części pierwszej stronę, niż kartkując gruby wydruk. (No i zużyjesz mniej drzew z lasów...).
Nazwa GIMP pochodzi, jak sądzę, od pierwszych liter angielskiego G raphic Im age P rocessor. Jest to jeden z pierwszych, dużych i ukończonych projektów Open Source.
Pobierz ze strony http://www.gimp.org/downloads/ plik instalacyjny i uruchom go (do przeprowadzenia tej operacji musisz mieć uprawnienia Administratora). Program instalacyjny wyświetla najpierw się okno dialogowe pozwalające ustalić język w jakim będą wyświetlane poszczególne ekrany (Rysunek 3.1.1a), a następnie ekran startowy (Rysunek 3.1.1b):
Rysunek 3.1.1 Instalacja GIMP — pierwsze dwa ekrany
Jeżeli chcesz np. zmienić folder programu — przejdź do Customize. Na jednym z ekranów, które się wówczas pojawią, możesz na przykład zmienić folder w którym zostaną umieszczone pliki programu. Potem wrócisz na ekran startowy.
Ja jednak proponuję zainstalować GIMP bez jakiejkolwiek zmiany domyślnych parametrów: naciśnij od razu przycisk Install. Spowoduje to rozpoczęcie całej operacji (Rysunek 3.1.2a):
Rysunek 3.1.2 Dalsze ekrany programu instalacyjnego
Po zakończeniu kopiowania plików i rejestracji komponentów program instalacyjny wyświetli ekran końcowy (Rysunek 3.1.2b).
Potem możesz uruchomić GIMP. Na początku pojawi się okno startowe (Rysunek 3.1.3):
Rysunek 3.1.3 GIMP — okno startowe
Pierwsze uruchomienie GIMP trwa zazwyczaj najdłużej — przez minutę lub dwie program rozpoznaje swoje komponenty. Gdy otworzą się główne okna, proponuję od razu zmienić język interfejsu z polskiego na angielski.
Dlaczego? Większość „samouczków” do GIMP, które możesz znaleźć w Internecie, opisuje ten program w języku angielskim. W tym języku jest prowadzona jest także większość forów dyskusyjnych. Będziesz mógł o wiele łatwiej i szybciej przyswajać sobie wszelkie wskazówki na temat tego programu gdy będziesz oswojony z jego „międzynarodową” nomenklaturą.
Język przełącza się bardzo łatwo (Rysunek 3.1.4):
Rysunek 3.1.4 Ustalanie języka programu
otwórz okno Edycja→Preferencje (Rysunek 3.1.4a);
w oknie Preferencji przejdź do sekcji Interfejs (Rysunek 3.1.4b);
zmień Język z Język systemowy na angielski (w wersji amerykańskiej: Rysunek 3.1.4c);
naciśnij OK aby zamknąć okno Preferencje, po czym zamknij GIMP i otwórz go ponownie.
Domyślnie GIMP otwiera trzy okna: jedno na obraz i dwa „narzędziowe” (Rysunek 3.1.5):
Rysunek 3.1.5 Trzy domyślne okna GIMP
Myślę, że do środowiska Windows bardziej pasuje program zawarty w pojedynczym oknie. Przełączmy GIMP w taki tryb opcją Windows→Single-Window Mode (Rysunek 3.1.6):
Rysunek 3.1.6 Przełączenie GIMP w tryb pojedynczego okna
Gdy ta opcja jest włączona, GIMP wyświetla wszystkie swoje panele w pojedynczym oknie (Rysunek 3.1.7):
Rysunek 3.1.7 GIMP w trybie pojedynczego okna
Po zainstalowaniu GIMP, możesz także pobrać z tej samej stron ( http://www.gimp.org/downloads/ ) pakiet instalacyjny rozbudowanego systemu podpowiedzi (Help). Rysunek 3.1.8a) pokazuje pierwszy ekran, jaki pojawia się po uruchomieniu tego instalatora:
Rysunek 3.1.8 Pierwsze dwa ekrany instalacji podpowiedzi
Na kolejnym ekranie (Rysunek 3.1.8b) można ustalić folder w którym zostaną umieszczone pliki systemu pomocy.
Na kolejnym ekranie (Ready to Install — Rysunek 3.1.9a) naciśnij przycisk Install aby rozpocząć kopiowanie plików:
Rysunek 3.1.9 Instalacja GIMP — ekrany: rozpoczęcia operacji i finalny
Instalacja systemu podpowiedzi kończy się ekranem finalnym (Rysunek 3.1.9b).
Ładowanie wszystkich komponentów zajmuje Gimpowi parę sekund podczas uruchamiania. W tym czasie pokazywane jest “okno startowe” (Rysunek 3.2.1):
Rysunek 3.2.1 Okno startowe GIMP — pokazuje postęp ładowania komponentów
Po zakończeniu ładowania, ujrzysz główne okno programu (Rysunek 3.2.2):
Rysunek 3.2.2 Domyślny ekran GIMP (2.8, tryb pojedynczego okna)
Obszar pośrodku okna to miejsce na obrazy. Po jego obu stronach są umieszczone panele dialogowe z przyborami rysunkowymi lub innymi pomocami. Paneli dialogowych jest w programie dużo, i mogą być łączone w zakładki (jak te z prawej strony przykładowego okna).
Obszar paneli możesz zawęzić (nawet do zera), jeżeli będzie Ci brakować miejsca na ekranie.
Rysunek 3.2.3a) przedstawia ważniejsze elementy okna przybornika (Toolbox) i panelu z opcjami narzędzi (domyślnie umieszczonego z lewej strony okna):
Rysunek 3.2.3 Przybornik i panel dialogowa
Przyjrzyj się nagłówkowi obszaru zakładek w oknie Toolbox. Jest tam, po prawej stronie, taki niepozorny przycisk „strzałki”. Gdy w niego klikniesz — otworzysz menu rozwijalne sterowania panelami (Rysunek 3.2.3b). Pierwszą jego pozycją jest submenu, odpowiadające aktywnej zakładce tego zestawu. (Na tej ilustracji zestaw zawiera pozycję o nazwie Tool Options).
Jeżeli w obszarze masz więcej niż jedną panel, możesz każdą z nich „wyciągnąć” w oddzielne okno „pływające” ponad ekranem. Służy do tego polecenie Detach Tab z menu panelu.
Polecenie Close Tab zamyka aktualną zakładkę (jeżeli była to ostatnia zakładka — zniknie cały obszar).
Zajmijmy się jednak innym poleceniem z tego menu: Add Tab. Jest to zagnieżdżone menu, prezentujące do wyboru wszystkie dostępne zakładki (Rysunek 3.2.4a). Gdy wybierzesz z tego menu jedną z zakładek (np. Layers — kształty narzędzi), GIMP doda ją do przybornika (Rysunek 3.2.4b):
Rysunek 3.2.4 Dodawanie do przybornika dodatkowej zakładki
Na ekranie możesz mieć otwartych kilka obszarów z panelami. Panele można przenosić pomiędzy obszarami metodą „przeciągnij i upuść”, „łapiąc” myszką (LPM) za zakładkę (Rysunek 3.2.5):
Rysunek 3.2.5 Przenoszenie pojedynczego panelu pomiędzy obszarami dialogowymi
Jeżeli nie chcesz przez nieuwagę przeciągnąć myszką jakiegoś panelu — możesz wyłączyć możliwość takiego przeciągania, włączając w jego menu (por. Rysunek 3.2.3b) opcję Lock Tab to Dock.
Posługując się tymi poleceniami możesz w skompletować zakładki, które są Ci potrzebne do pracy. Wydaje mi się, że do naszych celów na razie wystarczą trzy: Tool Options, Brushes i Layers (por. Rysunek 3.2.6):
Rysunek 3.2.6 Sugerowany układ ekranu
Jeżeli brakuje Ci miejsca na ekranie, można przenieść wszystkie potrzebne panele na jedną stronę ekranu, a potem szerokość przeciwległego obszaru zmniejszyć do zera.
W centrum okna programu wyświetlany jest edytowany obraz. Rysunek 3.2.7 przedstawia kilka istotnych elementów tego obszaru, które pojawiają się gdy wczytałeś istniejący plik lub stworzyłeś nowy:
Rysunek 3.2.7 Elementy obszaru obrazu
W GIMP możesz naraz otworzyć wiele obrazów. Każdy z nich zostanie umieszczony w odrębnej zakładce (Rysunek 3.2.8). Można także ten sam obraz otworzyć w kilku zakładkach (View→New View).
Rysunek 3.2.8 Praca z wieloma obrazami naraz
Jeżeli chcesz widzieć różne obrazy lub fragmenty obrazu w oknach ustawionych obok siebie — wyłącz opcję Windows→Single-Window Mode.
Jednym z typowych elementów interfejsu użytkownika są kontrolki umożliwiające określenie jakiejś ograniczonej wartości (np. intensywność jakiegoś efektu). Podstawowym problemem w przypadku takich elementów jest pogodzenie możliwości szybkiej i łatwej zmiany za pomocą myszki z możliwością wpisania dokładnej wartości. We wcześniejszych wersjach programu starano się to umożliwić za pomocą zespołu dwóch kontrolek: suwaka i pola tekstowego (Rysunek 3.2.9a). W wersji 2.8 GIMPa połączono te dwa elementy w całość (Rysunek 3.2.9b):
Rysunek 3.2.9 Nowy rodzaj kontrolki — połączenie suwaka i pola tekstowego
W taką kontrolkę można wpisać za pomocą klawiatury dokładną wartość — podczas pisania zachowuje się tak, jak klasyczne pole liczbowe (Rysunek 3.2.10a). Alternatywnie możesz także przesunąć pasek wartości klikając myszką w górną krawędź kontrolki (Rysunek 3.2.10b). Przeciągnięcie granicy paska wzdłuż dolnej krawędzi pozwala uzyskać drobniejsze zmiany (Rysunek 3.2.10c):
Rysunek 3.2.10 Szczegóły obsługi nowej kontrolki zakresu
W GIMP polecenia z palety narzędzi (przybornika) są dostępne także poprzez menu Tools (Rysunek 3.2.11). Twórcy programu pogrupowali je tam w kilka submenu: Selection Tools, Paint Tools, Transform Tools. W tekście książki łatwiej i bardziej jednoznacznie jest mi podawać polecenia z menu, niż umieszczać obrazki ikon do naciśnięcia. Będę więc powoływał się na nazwy poleceń. Jeżeli wolisz korzystać z przybornika — otwórz tylko raz podane przez mnie menu, aby upewnić się o którą ikonę chodzi. (Są zawsze widoczne obok napisów) Gdy już rozpoznasz ten symbol — używaj przybornika.
Wszystkie programy w tej książce pokazuję w wersji anglojęzycznej. GIMP ma także dobre tłumaczenie na język polski. Program instalacyjny domyślnie wgrywa odp. wersję narodową (patrz str. 51 i dalsze).
Aby otworzyć obraz, wybierz z menu polecenie File→Open (Rysunek 3.3.1).
Spowoduje to pojawienie się okna dialogowego wyboru pliku (Rysunek 3.3.2). Okno to nie przypomina standardowego okna Windows. Dzieje się tak dlatego, że GIMP używa do obsługi okienek zestawu komponentów o nazwie GTK+1. Tak właśnie wygląda w GTK+ komponent do wyboru plików.
Rysunek 3.3.2 GIMP — okno wyboru plików
GIMP rozpoznaje wiele różnych formatów zapisu obrazu. Po naciśnięciu Open załaduje wskazany w oknie dialogowym plik.
Istnieje także prostsza metoda na załadowanie obrazu. Gdy GIMP nie zawiera żadnego obrazu, możesz „przeciągnąć” myszką jakiś plik z obrazem do okna GIMP, i tam go „upuścić”.
Pliki *.tif, *.jpg lub *.png nie przechowują informacji o warstwach. Dlatego gdy GIMP importuje ich zawartość używając polecenia File→Open, tworzy pojedynczą warstwę nazwaną tak samo jak importowany plik.
W obecnej wersji GIMP polecenie File→Save As pozwala zapisać obraz tylko we własnym formacie programu (*.xcf). Używaj go wtedy, gdy chcesz zapisać obraz w tej postaci, i/albo jako plik o zmienionej nazwie. Jeżeli chcesz zachować obraz w innym formacie (np. *.jpg, *.png, *.tif,…) należy użyć polecenia File→Export As (Rysunek 3.4.1):
Rysunek 3.4.1 Różne metody zapisywania pliku
Każde z nich spowoduje to pojawienie się okna (Rysunek 3.4.2), podobnego do tego, w którym wybieraliśmy plik do załadowania (por. Rysunek 3.3.2, str. 60):
Rysunek 3.4.2 Okno zapisywania do pliku
W oknie Export Image (Rysunek 3.4.2) wybieramy folder, do którego zapiszemy rysunek. Wpisujemy także nazwę pliku. Bardzo ważne jest także wpisanie właściwego rozszerzenia pliku — np. .png, .tif, albo .jpg. (GIMP określa sposób zapisu obrazu na podstawie rozszerzenia pliku, które podasz). Na koniec naciśnij na w oknie Export Image przycisk Export.
W zależności od formatu zapisu, który wybrałeś, GIMP może jeszcze pokazać pomocnicze okno, z dodatkowymi opcjami. Rysunek 3.4.3 pokazuje takie okno dla formatu TIFF. Można tu ustalić sposób kompresji obrazu. Wybieraj zawsze opcję LZW. (Nie sprawdzałem innych, ale LZW jest bardzo popularną metodą, i poprawnie wczytuje się do Blendera).
Po naciśnięciu kolejnego przycisku Export, nasz rysunek zostanie ostatecznie zapisany na dysku.
Gdyby GIMP wyświetlił komunikat o braku możliwości zapisania informacji o przejrzystości w pliku TIFF, wywołaj polecenie Image→Flatten Image i spróbuj jeszcze raz.
Inne okno dialogowe wyświetla się dla zapisu w postaci pliku *.jpg (Rysunek 3.4.4). Format JPEG pozwala uzyskać pliki o najmniejszym rozmiarze, ale za pewną cenę: pogorszenia jakości obrazu. W modelowaniu stosuj go tylko wtedy, gdy pliki których używasz — tekstury, rysunki referencyjne — nie mogą być zbyt duże. Podczas zapisu do JPEG powinieneś znaleźć kompromis pomiędzy rozmiarem pliku a jakością obrazu. Służą do tego kontrolki w oknie Export Image as JPEG. Gdy je stosujesz, włączaj opcję Show preview in image window. Spróbuj zmniejszyć wartość Quality poniżej 90. W oknie dialogowym będziesz widział jak zmniejsza to rozmiar pliku, a w oknie głównym GIMP — jaki ma to wpływ na obraz. W ten sposób szybko dobierzesz odpowiednią wartość.
W przypadku zapisu do pliku PNG (Rysunek 3.4.5) pozostawiaj poziom Compression level na najwyższej wartości (9). W odróżnieniu od JPEG, PNG (podobnie jak TIFF) jest tzw. „formatem bezstratnym”: przechowuje oryginalne wartości każdego piksela obrazu. W takim przypadku najwyższy poziom kompresji nie wpływa na jakość, a pozwala uzyskać najmniejsze pliki.
Wybierz z menu polecenie Tools→Selection Tools→Rectangle Select, (lub naciśnij na klawiaturze R). Przesuwając myszkę z wciśniętym LPM, zaznacz obszar dookoła rzutu z boku (Rysunek 3.5.1).
Rysunek 3.5.1 Zaznaczenie rzutu z boku
Następnie poleceniem Image→Crop to Selection ogranicz cały obraz do zaznaczonego obszaru (Rysunek 3.5.2):
Rysunek 3.5.2 Odcięcie reszty obrazu
Linie pomocnicze (guides) służą do oznaczenia jakiegoś istotnego miejsca, a także porównań.
Aby dodać do rysunku linię pomocniczą, “złap” myszką (LPM) za linijkę, umieszczoną ponad obrazem. Trzymając przez cały czas wciśnięty LPM przesuń ją do dołu. Zobaczysz wówczas, że przesuwasz poziomą linię pomocniczą (Rysunek 3.6.1):
Rysunek 3.6.1 “Pobranie” linii pomocniczej
Gdzie zwolnisz LPM (“upuścisz” linię pomocniczą), tam zostanie. Nie jest częścią obrazu. Możesz ją powtórnie złapać myszką i przesunąć w inne miejsce. (Jeżeli nie reaguje na myszkę — naciśnij na klawiaturze M, aby przejść w tryb przesuwania).
W podobny sposób pobierz także kolejne linie pomocnicze, tym razem pionowe, z linijki po lewej stronie obrazu. Umieść je na kluczowych liniach konstrukcyjnych, o których wiesz, że powinny być pionowe lub poziome (Rysunek 3.6.2):
Rysunek 3.6.2 Przykładowe rozmieszczenie linii pomocniczych
Aby usunąć linię pomocniczą, przesuń ją z powrotem tam, skąd ją „wyciągnąłeś”: do linijki ponad obrazem (linie poziome) lub z lewej strony (linie pionowe)
W GIMP powiększenie można zmienić na dwa sposoby (Rysunek 3.7.1):
szybko i mniej dokładnie: trzymając wciśnięty Ctrl i obracając kółkiem myszki (KM);
dokładnie, ale nie tak szybko: wybierając z listy u dołu ekranu jedno z predefiniowanych powiększeń, lub wpisując bezpośrednio nową wartość w jej pole tekstowe;
Rysunek 3.7.1 Trzy metody zmiany powiększenia (Zoom)
Przesunięcie widoku to ruch myszki z wciśniętym SPM (Rysunek 3.7.2):
Rysunek 3.7.2 Przesuwanie widoku (Pan)
Oczywiście, można się także posługiwać paskami przewijania, ale w większości przypadków to najmniej wygodna metoda.
Alternatywną metodą przesunięcia obrazu jest wykorzystanie kontrolki w prawym dolnym rogu obszaru obrazu (Rysunek 3.7.2). Gdy naciśniesz ją myszką (LPM), otworzy się miniaturka obrazu z zaznaczonym widocznym obszarem (Rysunek 3.7.3):
Rysunek 3.7.3 Alternatywna metoda przesuwania widoku (Pan)
Wystarczy ruch myszki, by przesunąć obraz. Ta metoda jest szczególnie przydatna w przypadku pracy w dużym powiększeniu.
Aby zmienić rozmiar obrazu (np. powiększyć), użyj polecenia Image→Canvas size... W oknie dialogowym, które się pojawi (Rysunek 3.8.1), rozłącz powiązanie pomiędzy wysokością i szerokością (przycisk z “ogniwami”). Potem np. zwiększ wysokość (Height).
Rysunek 3.8.1 Okno zmiany rozmiaru obrazu
Następnie przesuń (LPM) miniaturę aktualnego obrazu, aby przestrzeń, którą dodajemy, znalazła się w odpowiednim miejscu. Gdy skończysz, naciśnij przycisk Resize.
Na koniec nie zaszkodzi wywołać polecenie Layer→Layer to Image Size.
Warstwy w GIMP możesz sobie wyobrazić, jako oddzielne powierzchnie przejrzystej folii. Każda z nich może zawierać oddzielny obraz. Obrazy te nakładają się na siebie (Rysunek 3.9.1). Do zarządzania warstwami służy zakładka Layers, dostępna w przyborniku.
Rysunek 3.9.1 Warstwy — na obrazie i w zakładce Layers
Zakładka Layers zawiera listę warstw, oraz kilka pomocniczych kontrolek. Rysunek 3.9.2 wyjaśnia, jak się nią posługiwać:
Rysunek 3.9.2 Funkcje zakładki Layers
Warstwy mogą zasłaniać się wzajemnie. Jak w świecie rzeczywistym, obowiązuje zasada, że warstwa leżąca wyżej zasłania warstwę leżącą niżej. Stąd, w przykładzie na ilustracji (Rysunek 3.9.1), warstwa P40B-JJ-Left.tif zasłoniła obraz na warstwie P40B-JJ-Right.tif. Tę nieprzejrzystość można jednak zmniejszyć. Służy do tego suwak Opacity, umieszczony powyżej listy warstw (Rysunek 3.9.2).
Kolejność warstw także można zmienić — wystarczy “złapać” pojedynczy wiersz LPM i przesunąć w nowe położenie na liście (Rysunek 3.9.2).
Na liście Layers zawsze jedna warstwa jest podświetlona na niebiesko. To warstwa aktywna.
Prawie wszystkie polecenia, które wywołujesz w GIMP (rysowanie, usuwanie, transformacje, filtry, itp.) dotyczą wyłącznie zawartości warstwy aktywnej! Pozostałe warstwy nie ulegają zmianie.
Warstwa może być powiązana (z warstwą aktywną). Takie powiązanie powoduje, że można przesuwać (poleceniem Move — M, por. str. 83) zawartość kilku warstw naraz. Do włączenia/wyłączenia blokady służy ikona “łańcucha”, po lewej stronie nazwy warstwy (Rysunek 3.9.2). To powiązanie nie działa jednak podczas innych transformacji — np. obrotu, ani malowania. Osobiście nigdy go nie używałem1.
Warstwę można ukryć. Służy do tego ikona “oka”, umieszczona z lewej strony nazwy każdej warstwy. Piksele warstwy można także zablokować przed zmianami. Służą do tego opcje Lock (w nagłówku listy warstw — por. Rysunek 3.9.2).
Aby zmienić nazwę warstwy — kliknij w nią dwukrotnie. W wierszu pojawi się chwilowe pole edycji, w którym będziesz mógł ją poprawić.
Na koniec może wyjaśnię, pochodzenie nazw warstw w przykładzie pokazywanym przez Rysunek 3.9.2:
P40B-JJ-Right.tif — gdy wczytujesz plik obrazu w typowym formacie rastrowym: JPEG, PNG, TIFF, GIMP umieszcza jego zawartość na pojedynczej warstwie. Nadaje jej taką nazwę, jak nazwa wczytanego pliku.
P40B-JJ-Left.tif — warstwa powstała poprzez wczytanie dodatkowego obrazu (File→Open As Layer, por. str. 71). GIMP nadaje w takim przypadku nazwę wczytanego pliku.
Inną ciekawą funkcją jest możliwość grupowania warstw, którą wprowadzono w wersji 2.8 GIMP. Aby dodać nową grupę wywołaj polecenie Layer→New Layer Group., lub kliknij ikonkę foldera u dołu okna warstw (Rysunek 3.9.3a):
Rysunek 3.9.3 Grupowanie warstw
Spowoduje to wstawienie nowej grupy ponad warstwą aktywną. Taka pusta grupa jest reprezentowana przez ikonę folderu. Podobnie jak warstwy, możesz ją przesuwaćw górę i w dół, a także zmieniać nazwę. W przykładzie pokazywanym przez Rysunek 3.9.3b) przesunąłem ją do dołu i zmieniłem nazwę na Reflectivity. Następnie przesunąłem (metodą „przeciągnij i upuść”) do jej wnętrza odpowiednie warstwy (Rysunek 3.9.3c).
Grupy warstw można np. wykorzystać do uporządkowania pliku skin.xcf, w którym przechowuję trzy zestawy warstw: jeden dla tekstury odbić, drugi dla tekstury barwy, i trzecią — z plikami referencyjnymi (schemat barw, rozwinięcia UV). Trzymam te warstwy razem, gdyż tekstury barwy i odbicia światła zależą od siebie nawzajem (np. namalowane zabrudzenia muszą być bardziej matowe). Plik powstał we wcześniejszych wersjach GIMP, w którym grupowania jeszcze nie było. Do tej pory musiałem pamiętać, jakie warstwy ukryć, aby wygenerować teksturę barwy, a jakie — aby uzyskać teksturę odbić. Pomagałem w tym sobie nadając nazwom poszczególnych warstw przedrostki — Ref-* dla składników tekstury odbić, i Color-* dla składników tekstury barwy. Teraz mogłem stworzyć dla wszystkich składników tekstury odbić grupę Reflectivity, do której poprzenosiłem odpowiednie tekstury Ref-* (Rysunek 3.9.4a):
Rysunek 3.9.4 Przykład połączenia warstw w grupy
Zawartość pliku GIMP podzieliłem na trzy grupy (Rysunek 3.9.4b):
| Reference | Grupa zawiera warstwy z rysunkami referencyjnymi. Takie obraz powinny być zawsze widoczne, stąd jest umieszczona u góry, i ma włączony tryb (Mode) na Multiply. Jednocześnie, aby żaden z rysunków referencyjnych nie był za bardzo kontrastowy, zmniejszyłem przejrzystość (Opacity) tej grupy. Grupa jest zawsze widoczna, bo włączam w jej środku widoczność tej warstwy, która jest mi w danym momencie potrzebna; |
| Reflectivity | Grupa zawiera warstwy z obrazem tekstury odbić. |
| Color | Grupa zawiera warstwy z obrazem tekstury barwy; |
Od tej chwili, gdy chcę wyeksportować z pliku teksturę odbić, wystarczy że wyłączę widoczność grupy Color i Reference. Podobnie w przypadku eksportu tekstury barwy. Nazwy grup pozwolą mi szybko zorientować się w strukturze, choćbym do tego pliku zajrzał po wielu latach.
Zwróć uwagę, że nazwy grup składowych nadal mają przedrostki — Ref-* i Color-*. Przyczyna jest prosta:
Grupy warstw to nie foldery plików: nadal każda warstwa GIMP musi mieć unikalną nazwę w obrębie całego pliku, niezależnie od tego do jakiej grupy należy.
Wczytamy zawartość drugiego pliku jako dodatkowy obraz, do nowej warstwy. Zazwyczaj chodzi o to, aby nałożyć na siebie dwa rysunki, i je porównać. Dlatego pokażę od razu, jak ustawić częściowa przejrzystość warstwy z wczytanym obrazem.
Aby efekt przejrzystości był możliwy, aktualny rysunek nie może zapisywać barw jako tzw. indeksowanych kolorów. Jeżeli w menu Image→Mode zobaczysz, że twój rysunek ma włączony tryb Indexed, musisz to zmienić. Najlepiej będzie, jeżeli wywołasz polecenie Image→Mode→Grayscale, To zmieni odwzorowanie barw na 256 odcieni szarości. Możesz także przełączyć się w tryb barwny — Image→Mode→RGB,.
Załaduj drugi plik jako nową warstwę: File→Open as Layers. W oknie dialogowym wyboru pliku znajdź i wskaż obraz — powiedzmy, że nazywa się P40B-JJ-Left.tif.
W efekcie zobaczysz w oknie obrazu obydwa rysunki. Wczytany obraz przykrył dotychczasowy (Rysunek 3.10.1):
Rysunek 3.10.1 Dodana do rysunku warstwa z nowym obrazem
Otwórz w przyborniku zakładkę sterującą warstwami (Layers — Rysunek 3.10.1). Widać tu listę z dwoma wierszami. Każdy z nich to jedna z warstw. Dotychczasowa zawartość rysunku znajduje się na warstwie P40B-JJ-Right.tif. Druga warstwa nosi nazwę obecnie wczytanego pliku. Efekt „nałożenia” obydwu rysunków na siebie wziął się stąd, że warstwa P40B-JJ-Left.tif znajduje się powyżej warstwy P-40B-JJ-Right.tif, i po prostu ją zasłania.
Domyślna nazwa warstwy to nazwa oryginalnego pliku *.tif, *.jpg lub *.png, który otworzyliśmy w GIMP — nie tylko poleceniem File→Open as Layers, ale także zwykłym poleceniem File→Open. GIMP traktuje obraz z takiego pliku jak obraz importowany z obcego formatu, który zawiera jedną, domyślną warstwę. Aby ta warstwa nie była „bezimienna”, nadaje jej taką samą nazwę jak nazwa importowanego pliku
Teraz zmienimy przejrzystość warstwy P40B-JJ-Left.tif. Upewnij się, że jest podświetlona na liście Layers (oznacza to, że jest aktywna). Następnie zmień wartość, ustawioną na suwaku Opacity, np. z 100 na 40 (Rysunek 3.10.1).
Zobaczysz, że spod spodu zaczną “prześwitywać” linie warstwy P40B-JJ_Right.tif(Rysunek 3.10.2).
Rysunek 3.10.2 Efekt zwiększenia przejrzystości górnej warstwy obrazu
W wyniku polecenia Layer→New Layer pojawi się okno dialogowe New Layer (Rysunek 3.11.1).
W polu Layer name wpisz nową nazwę warstwy. Spośród grupy opcji Layer Fill Type wybierz sposób wypełnienia tła warstwy. Zazwyczaj wybieram tło w pełni przejrzyste (Transparency).
Po naciśnięciu OK nowa warstwa zostanie stworzona.
Warstwę możesz usunąć na dwa sposoby:
Poleceniem Layer→Delete Layer. Usuwa aktualną warstwę (zawsze się upewnij, która jest aktualna...)
W zakładce Layers: Podświetl wiersz, odpowiadający warstwie, którą chcesz usunąć. Następnie naciśnij przycisk z ikoną kosza (Rysunek 3.12.1).
Rysowanie pokażę na przykładzie “z życia wziętym”: na półprzeźroczystej warstwie narysujemy kształt kadłuba. Linie rysunku wzorcowego, do którego mamy się dopasować, są widoczne na warstwie leżącej pod spodem (Rysunek 3.13.5 pokazuje, co ma być narysowane).
Nim zaczniesz rysować, upewnij się, że tryb koloru twojego rysunku jest ustawiony na RGB. W razie czego — przestaw go w ten tryb (Image→Mode→RGB). Inaczej zamiast czerwonego będzie szary!
Zacznijmy od momentu, gdy warstwy są odpowiednio ustawione. Przed rozpoczęciem rysowania często zmienia się aktualny kolor. W tym przypadku wybierz czerwony (Rysunek 3.13.1):
Rysunek 3.13.1 Ustalenie aktualnego koloru
Z palety narzędzi wybierz “pędzelek” (Tools→Paint Tools→Paintbrush z menu, albo P na klawiaturze). Następnie ustal formę narzędzia (Rysunek 3.13.2), oraz jego rozmiar (Rysunek 3.13.3):
Rysunek 3.13.2 Wybór kształtu “pędzelka” | Rysunek 3.13.3 Ustalenie rozmiaru rysowania |
W trybie rysowania, gdzie tylko naciśniesz LPM, na rysunku pojawi się okrągła “plama”. Obrysowanie kadłuba najwygodniej jest wykonać za pomocą krótkich odcinków linii prostych. Aby zacząć taką sekwencję, kliknij LPM w narożnik obszaru, który chcesz zaznaczyć. Następnie przesuń myszkę trzymając wciśnięty Shift (Rysunek 3.13.4). Widzisz, że ciągniesz koniec prostej linii? Gdy trzymasz wciśnięty Shift, GIMP zawsze łączy aktualne położenie kursora z końcem ostatnio narysowanej linii. W ten sposób możesz szybko i dokładnie narysować kształt przyszłej selekcji.
Rysunek 3.13.4 Rysowanie prostymi odcinkami
“Ciągnięta” w ten sposób linia zakończy się tam, gdzie klikniesz LPM. Po obrysowaniu kształtu należy zamalować wnętrze obszaru (Rysunek 3.13.5):
Rysunek 3.13.5 Do wypełniania wnętrza wygodniej jest zmienić rozmiar narzędzia na większy
Jeżeli pomylisz się i narysujesz coś, czego nie powinieneś — użyj polecenia Edit→Undo (Ctrl-Z).
Jeżeli na rysunku masz już zaznaczony obszar selekcji — GIMP pozwoli Ci rysować tylko wewnątrz tego obszaru. Możesz go więc wykorzystywać do celowego nakładania ograniczeń (np. aby na pewno żadna linia nie wystawała poza założony obrys).
Do usunięcia czegoś z obrazu służy “gumka”: Tools→Paint Tools→Eraser . Znajdziesz ją także w oknie przybornika, pod odpowiednią ikoną (Rysunek 3.14.1). Możesz także skorzystać ze skrótu na klawiaturze: Shift-E. Po wybraniu narzędzia, wybierz jego kształt z zakładki Brushes. (Rysunek 3.14.1). W zakładce opcji narzędzia ustal rozmiar (Size — Rysunek 3.14.2):
Rysunek 3.14.1 Wybór narzędzia (“gumki”) i jej kształtu | Rysunek 3.14.2 Wybór rozmiaru gumki |
Teraz już możesz wymazać z rysunku to, czego nie ma na nim być (Rysunek 3.14.3):
Rysunek 3.14.3 Wymazywanie z rysunku niepotrzebnych elementów
Gumka ściera, gdy trzymasz wciśnięty LPM. (Ta zasada obowiązuje w Gimpie dla każdego narzędzia: pędzla, aerografu, itd.). Jeżeli pomylisz się i zetrzesz coś, czego nie powinieneś - użyj polecenia Edit→Undo (Ctrl-Z).
Jeżeli na rysunku masz już zaznaczony obszar selekcji — GIMP pozwoli Ci usuwać obraz tylko wewnątrz tego obszaru. Możesz go więc wykorzystywać do celowego nakładania ograniczeń (np. aby na pewno nie usunąć niczego więcej).
Zaznaczanie obszaru wyboru za pomocą prostokąta jest w GIMP najprostszą formą selekcji. Naciśnij na klawiaturze klawisz R, lub wybierz z menu polecenie Tools→Selection Tools→Rectangle Select:
Rysunek 3.15.1 Zaznaczenie obszaru selekcji
Rysunek 3.15.2 pokazuje wybrany obszar. Nadal można go jeszcze zmienić (powiększyć, pomniejszyć). Służą do tego uchwyty w narożnikach obszaru. (Są tak duże, że trudno ich nie zauważyć):
Rysunek 3.15.2 Prostokątny obszar wyboru
Aby wyłączyć obszar selekcji — wystarczy wywołać polecenie Select→None.
Narzędzie dla ludzi o pewnej ręce! Wybierz polecenie Tools→Selection Tools→Free Select (lub F z klawiatury). Zacznij rysować zamknięty obszar (Rysunek 3.16.1):
Rysunek 3.16.1 Rysowanie granic obszaru selekcji
Obszar po zamknięciu jest obrysowany linią przerywaną (Rysunek 3.16.2):
Rysunek 3.16.2 Przykład nieregularnego obszaru selekcji
Aby wyłączyć obszar selekcji — wystarczy wywołać polecenie Select→None.
W GIMP obszar selekcji może być dowolną plamą/plamami. Może także mieć rozmyte krawędzie. Takie efekty możesz uzyskać tylko w jeden sposób: malując obszar selekcji, tak jak maluje się jakiś kształt.
Narysowanie obszaru selekcji nie zadziała, jeżeli rysunek jest zapisany w trybie tzw. indeksowanych barw. Aby mieć pewność, że wszystko będzie poprawnie, przełącz go w tryb RGB (Image→Mode→RGB).
Pokażę, jak to zrobić na przykładzie opisanym w pierwszej części tej książki (str. 42). Chodzi o objęcie ściśle “przylegającą” selekcją rysunku tylnej części kadłuba samolotu. Linie rysunku znajdują się w tym przykładzie na warstwie o nazwie P40B-JJ-Top.tif.
Obszary selekcji będziemy malować na oddzielnej warstwie, którą stworzymy wyłącznie dla tego celu. Wywołaj polecenie Layer→New Layer. Dodaj do rysunku na nową warstwę, o nazwie Mask (szczegóły — str. 73). Warstwa musi być zupełnie przejrzysta. (Podczas tworzenia, w oknie dialogowym New Layer, określ kolor tła jako Transparency).
Rysunek 3.17.1 pokazuje, jak należy przygotować układ warstw (szczegóły - str. 68):
Ukryj wszystkie inne warstwy poza Mask i P40B-JJ-Top.tif;
Przesuń warstwę ze wzorcem kształtu do narysowania — P40B-JJ-Top.tif — ponad Mask;
Ustaw nieprzejrzystość P40B-JJ-Top.tif na 50%, by wygodniej dopasować rysowany kształt do linii kadłuba;
Podświetl Mask, aby stała się warstwą aktywną.
Po ustaleniu stanu warstw należy na warstwie Mask obrysować i wypełnić (szczegóły — str. 75) kształt kadłuba (Rysunek 3.17.2):
Rysunek 3.17.2 Rysowanie kształtu selekcji
Na koniec zmień narzędzie na “gumkę” (Tools→Paint Tools→Eraser, z klawiatury Shift-E). Kształt narzędzia pozostaw bez zmian, za to rozmiar przestaw na 1.0. Użyjemy go do drobnych wygładzeń i korekt narysowanego kształtu, np. wymazania naddatku linii (Rysunek 3.17.3).
Rysunek 3.17.3 Końcowe przygotowania - wymazanie “naddatków”
Pozostaje zmienić narysowany kształt w selekcję. Wywołaj polecenie: Layer→Transparency→Alpha to Selection.
I to wszystko. Na koniec porządkujemy warstwy (Rysunek 3.17.4):
ukryj Mask (można by ją było usunąć, ale może się przydać przy następnym takim przypadku);
odkryj inne warstwy (te, które są potrzebne do dalszej pracy);
podświetl warstwę, na której chcesz coś zmienić, za pomocą aktualnie wybranego obszaru (np. P40B-JJ-Top.tif). (Stanie się w ten sposób warstwą aktywną)
W GIMP kształt selekcji “przenika” przez wszystkie warstwy. Nie jest związany w szczególny sposób z żadną z nich. Dzięki temu warstwa, na której go rysowałeś, może być zaraz usunięta
Jeżeli w GIMP jakiś obszar jest wybrany (selekcją) — obrót będzie dotyczył tylko tego obszaru. Jeżeli jednak nic nie jest wybrane, obracana jest cała zawartość warstwy aktywnej. Operację pokażę na przykładzie właśnie takiej sytuacji.
Jeżeli wykonujesz obrót po raz pierwszy, warto odpowiednio ustawić opcje tego narzędzia.
Zaznacz je w przyborniku (Rysunek 3.18.1), aby w panelu Tool Options GIMP wyświetlił aktualne ustawienia operacji Rotate (Rysunek 3.18.2). Proponuję wyłączyć wyświetlanie siatki linii pomocniczych dla tej operacji, bo jest na tyle gęsta, że wydaje się zasłaniać obracany obraz. Wyłącza się je wybierając z listy rozwijalnej Guides pozycję No guides (Rysunek 3.18.2):
Rysunek 3.18.2 Przygotowanie do obrotu (Rotate)
Przed każdym obrotem upewnij się, że Twój obraz jest dostatecznie duży (Rysunek 3.18.2). Chodzi o to, że GIMP obraca zawartość obrazu, ale jego granice („ramka”) pozostaje nieruchoma. Jeżeli obrócisz zbyt niski obraz, górna część po obrocie może zostać obcięta, tak jak to pokazuje Rysunek 3.18.3:
Rysunek 3.18.3 Obcięcie części obróconego obrazu
Jeżeli chcesz obrócić tylko zaznaczony obszar rysunku (aktualną selekcje) — zacznij od wywołania polecenia Select→Float. W przeciwnym razie będziesz obracać całą zawartość warstwy aktywnej.
Wywołaj polecenie Tools→Transform Tools→Rotate (Shift-R). Pojawi się dodatkowe okno Rotate (Rysunek 3.18.4). Zauważysz także pewne pogorszenie jakości wyświetlanego obrazu. Linie stały się mniej gładkie, gdyż GIMP przełączył się na wyświetlanie “roboczej kopii” rysunku. Pokazuje teraz, jak będzie wyglądał obraz, gdy zatwierdzisz ten obrót. (Czyli taki, jaki byłby, gdybyś w tym momencie nacisnął przycisk Rotate. Jeżeli naciśniesz Cancel — zrezygnujesz z całej operacji).
Rysunek 3.18.4 Obrót obrazu (Rotate)
Zwróć uwagę, że okno Rotate nie przeszkadza w zmianie powiększania widoku, ani w przesuwaniu poziomym i pionowym suwakiem. To bardzo wygodne, gdyż z większą dokładnością możesz obserwować zgodność linii pomocniczej i linii na kadłubie samolotu. Podczas obrotu pokazywana jest także oś obrotu — kółko z krzyżykiem, wyglądające jak celownik (Rysunek 3.18.4). Możesz w każdym momencie ją złapać (LPM) i przesunąć w nowe miejsce.
Obraz można obracać przesuwając myszkę z wciśniętym LPM (dobre na pierwsze przybliżenie). Można także zmienić numeryczną wartość kąta obrotu w oknie Rotate, polu Angle (tak najwygodniej wprowadzać ostatnie, drobne poprawki). Wartość kąta w polu Angle zmienia się także wtedy, gdy obracasz obraz myszką.
Obrót zatwierdzamy naciskając przycisk Rotate.
Jeżeli obracałeś tylko zaznaczony fragment obrazu (selekcję), po zakończeniu obrotu wywołaj jeszcze polecenie Layer→Anchor Layer (Ctrl-H).
(To scali “pływający” ponad rysunkiem, obrócony obszar z resztą obrazu, i zakończy całą operację).
Jeżeli chcesz przesunąć tylko zaznaczony obszar rysunku (aktualną selekcje) — zacznij od wywołania polecenia Select→Float. W przeciwnym razie będziesz przesuwać całą zawartość warstwy aktywnej.
Transformację zademonstruję na przykładzie, gdzie przesuwam obraz na jednej warstwie tak, by pokrył się ze wzorcem (umieszczonym na innej warstwie — Rysunek 3.19.1). Naciśnij na klawiaturze M (jest to skrót polecenia Tool→Transform Tools→Move). “Złap” zmieniamy obszar (LPM) i przenieś we właściwe miejsce:
Rysunek 3.19.1 Przesuwanie zawartości warstwy
Przesunięcie kończysz, zwalniając LPM (Rysunek 3.19.2):
Rysunek 3.19.2 Obraz po przesunięciu
Jeżeli przesuwałeś tylko zaznaczony fragment obrazu (selekcję), po zakończeniu przesuwania wywołaj jeszcze polecenie Layer→Anchor Layer (Ctrl-H).
(To scali “pływający” ponad rysunkiem, deformowany obszar, z resztą obrazu, i zakończy całą operację).
Jeżeli chcesz zdeformować tylko zaznaczony obszar rysunku (aktualną selekcje) — zacznij od wywołania polecenia Select→Float. W przeciwnym razie deformacji ulegnie cała zawartość warstwy aktywnej.
Jeżeli wykonujesz przekoszenie po raz pierwszy, warto odpowiednio ustawić opcje tego narzędzia. Zaznacz je w przyborniku (Rysunek 3.20.1), aby w panelu Tool Options GIMP wyświetlił aktualne ustawienia operacji Shear (Rysunek 3.20.2). Proponuję wyłączyć wyświetlanie siatki linii pomocniczych dla tej operacji, bo jest na tyle gęsta, że wydaje się zasłaniać deformowany obraz. Wyłącza się je wybierając z listy rozwijalnej Guides pozycję No guides (Rysunek 3.20.2).
Często takie operacje jak przekoszenie wywołujemy, aby dopasować obraz na jednej warstwie do wzorca na drugiej warstwie. Aby podczas transformacji nie stracić ani przez chwilę wzorcowego obrazu z oczu, włącz w panelu Tool Options opcję Show preview image, oraz zmniejsz jego nieprzejrzystość (Opacity) do 50% lub mniej (Rysunek 3.20.2). Aby nie zmieniać tych ustawień za każdym razem, możesz potem je zapisać jako domyślne (służy do tego ikona dyskietki u dołu tego panelu — por. Rysunek 3.20.2).
Przekoszenie pokażę na przykładzie transformacji prostokątnego fragmentu obrazu. Ponieważ deformujemy selekcję, wywołaj najpierw polecenie Image→Float. Potem użyj Tools→Transform Tools→Shear (lub Shift-S). Pojawi się dodatkowe okno Shear (Rysunek 3.20.3). Zauważysz także pewne pogorszenie jakości obrazu w zaznaczonym obszarze. Linie stały się mniej gładkie, gdyż GIMP przełączył się na wyświetlanie “roboczej kopii” tego fragmentu. Pokazuje teraz, jak będzie wyglądał obraz, gdy zatwierdzisz tę transformację. (Czyli gdy naciśniesz przycisk Shear. Jeżeli naciśniesz Cancel — zrezygnujesz z całej operacji).
Rysunek 3.20.3 Przekoszenie (poziome)
Polecenie Shear działa podobnie do obrotu. (Zresztą wszystkie transformacje w GIMP działają w taki sposób). Obecność okna Shear nie przeszkadza w zmianie powiększenia widoku, ani w przesuwaniu pionowym i poziomym suwakiem. Przekoszenie nie ma, niestety, widocznego środka, który można by było przesunąć. Punkt ten jest stały i znajduje się w środku obszaru selekcji.
Podświetlony na rysunku fragment można deformować przesuwając myszkę z wciśniętym LPM (dobre na pierwsze przybliżenie). Można także zmienić numeryczną wartość transformacji w oknie Shear, polu Shear magnitude X (Rysunek 3.20.3) (tak najwygodniej wprowadzać ostatnie, drobne poprawki). Wartość w polu Shear magnitude X zmienia się także wtedy, gdy dokonujesz deformacji myszką. Przekoszenie zatwierdzasz naciskając przycisk Shear.
W GIMP nie można wskazać środka tej transformacji. Po jej zakończeniu zmieniony fragment może leżeć niezupełnie tam, gdzie trzeba. Potem trzeba go wtedy przesunąć (M, por. str. 83) we właściwe miejsce.
Jeżeli deformujesz tylko fragment obrazu, wywołaj na koniec polecenie Layer→Anchor Layer (Ctrl-H). To scali “pływający” ponad rysunkiem deformowany obszar z resztą obrazu, i zakończy całą operację.
Jeżeli chcesz zdeformować tylko zaznaczony obszar rysunku (aktualną selekcje) — zacznij od wywołania polecenia Select→Float. W przeciwnym razie deformacji ulegnie cała zawartość warstwy aktywnej.
Jeżeli przeskalowujesz po raz pierwszy, warto odpowiednio ustawić opcje tego narzędzia.
Zaznacz je w przyborniku (Rysunek 3.21.1), aby w panelu Tool Options GIMP wyświetlił aktualne ustawienia operacji Scale (Rysunek 3.21.2). Proponuję wyłączyć wyświetlanie siatki linii pomocniczych dla tej operacji, bo jest na tyle gęsta, że wydaje się zasłaniać deformowany obraz. Wyłącza się je wybierając z listy rozwijalnej Guides pozycję No guides (Rysunek 3.21.2).
Często takie operacje jak skalowanie wywołujemy, aby dopasować obraz na jednej warstwie do wzorca na drugiej warstwie. Aby podczas transformacji nie stracić ani przez chwilę wzorcowego obrazu z oczu, włącz w panelu Tool Options opcję Show preview image, oraz zmniejsz jego nieprzejrzystość (Opacity) do 50% lub mniej (Rysunek 3.21.2). Aby nie zmieniać tych ustawień za każdym razem, możesz potem je zapisać jako domyślne (służy do tego ikona dyskietki u dołu tego panelu — por. Rysunek 3.21.2).
Wywołaj polecenie Tools→Transform Tools→Scale (lub Shift-T). Pojawi się okno dialogowe Scale (Rysunek 3.21.3). Zauważysz także pewne pogorszenie jakości wyświetlanego obrazu. Linie stały się mniej gładkie, gdyż GIMP przełączył się na wyświetlanie „roboczej kopii” rysunku. Pokazuje teraz, jak będzie wyglądał obraz, gdy zatwierdzisz tę zmianę skali. (Czyli gdy naciśniesz przycisk Scale. Jeżeli naciśniesz Cancel — zrezygnujesz z całej operacji).
Rysunek 3.21.3 Zmiana rozmiaru obrazu w kierunku pionowym
Zwróć uwagę, że okno Scale nie przeszkadza w zmianie powiększania widoku, ani w przesuwaniu poziomym i pionowym suwakiem. To bardzo wygodne, gdyż z większą dokładnością możesz obserwować zgodność linii pomocniczej i linii na rysunku samolotu.
Jeżeli nie zamierzasz zmieniać skali tak samo w obydwu kierunkach: upewnij się, że wysokość i szerokość są „rozprzęgnięte”. (Ogniwa łańcucha w oknie dialogowym Scale powinny być przerwane). Następnie w polu Height lub Width wpisz nowy rozmiar obiektu.
Transformację zatwierdzamy naciskając przycisk Scale.
Na Inkscape natknąłem się przypadkiem. GIMP miał tylko marginalne możliwości rysowania linii wektorowych. A ja szukałem więc czegoś, w czym można by było wygodnie rysować (i poprawiać) linie nitów i łączenia blach. Gdy jednak wertowałem jego plik podpowiedzi, szukając szczegółów tej funkcji, natknąłem się na zdanie:
„Rysowanie linii w GIMP nie jest tak wygodne, jak w wyspecjalizowanych programach, np. Inkscape”.
Co to jest to „Inkscape”? Wystarczyło wpisać to hasło w Google, by znaleźć stronę tego projektu. Jest to najmłodszy z programów, używanych w tej książce. Nie osiągnął jeszcze “pełnoletniości” (aktualne wersje mają nadal numer poniżej 1.00). W związku z tym potrafi czasami się zawiesić, lub zakończyć się nagle z jakimś krytycznym błędem. Na szczęście nie dzieje się to zbyt często. W każdym razie nie zapominaj o częstym zapisywaniu swojej pracy do pliku!
Pobierz (z http://inkscape.org/en/download/ ) i uruchom program instalacyjny. Na początku pojawia się ekran “powitalny”, a następnie ekran z umową licencyjną (Rysunek 4.1.1):
Rysunek 4.1.1 Instalacja GIMP — pierwsze dwa ekrany
Po naciśnięciu przycisku Next > na ekranie License Agreement, przejdziemy do ekranu Choose Components (Rysunek 4.1.2):
Rysunek 4.1.2 Wybór opcji instalacji
Warto dopilnować, aby na ekranie Choose Components. wyłączyć z komponentów wszelkie tłumaczenia poza angielskim (obowiązkowe) i polskim. Na ekranie Choose Install Location można zmienić domyślny folder programu.
Po naciśnięciu przycisku Install wykonuje się instalacja (Rysunek 4.1.3):
Rysunek 4.1.3 Instalacja Inkscape - ekrany: postępu i finalny
Kiedy otworzysz po raz pierwszy Inkscape, program może być w języku polskim (choć nie zawsze — wydaje mi się że to zależy od wersji Windows, której używasz). Proponuję przełączyć się na język angielski (z tych samych przyczyn, dla których sugeruję używać języka angielskiego w GIMP — por. str. 52). Zacznij od otwarcia okna ustawień programu (Plik→Ustawienia Inkscape’a — Rysunek 4.1.4):
Rysunek 4.1.4 Inkscape: przejście do ustawień programu
W oknie ustawień wybierz sekcję Interfejs. W niektórych Windows język angielski może figurować jako język Domyślny systemu (Rysunek 4.1.5) w innych znajdziesz go jako angielski (w kilku odmianach: amerykańskiej, kanadyjskiej, brytyjskiej):
Rysunek 4.1.5 Inkscape — zmiana języka programu
Przełącz język na angielski (lub, jeżeli nie możesz znaleźć takiej pozycji na liście — na Domyślny systemu). W oknie Ustawienia Inkscape’a nie ma żadnego przycisku „OK”. Wystarczy że zamkniesz Inkscape i uruchomisz go powtórnie.
Po powtórnym uruchomieniu program wyświetla wszelkie opisy w języku angielskim (Rysunek 4.1.6):
Rysunek 4.1.6 Okno Inkscape (wygląd zaraz po instalacji)
Nie wiem dlaczego, ale domyślny układ ekranu Inkscape po instalacji wcale nie jest „domyślny”! Pasek z poleceniami systemowymi jest umieszczony po prawej (Rysunek 4.1.6), zamiast — w sposób typowy dla Windows — u góry okna, pod menu rozwijalnym. Tych pasków narzędzi nie można przesuwać myszką. Zmień ich układ wybierając opcję View→Default (Rysunek 4.1.7):
Rysunek 4.1.7 Przeniesienie przybornika z poleceniami systemowymi pod nagłówek okna
Wreszcie ostatni szczegół: wersja 64-bitowa z partha.com (por. str. 20) ma interfejs utrzymany w ciemniejszych barwach niż w standardowym oknie Inkscape (Rysunek 4.1.8):
Rysunek 4.1.8 Okno 64-bitowego Inkscape (z partha.com )
W wersji 0.48 nie można jeszcze zmieniać barw programu w oknie preferencji. Aby sobie z tym problemem poradzić, musimy użyć metody nieco hakerskiej. Zacznij od pobrania z http://inkscape.org/en/download/ plików oficjalnej wersji 32-bitowej, spakowanej w formacie 7z (Rysunek 4.1.9):
Rysunek 4.1.9 Pobranie oficjalnej (32-bitowej) wersji Inkscape w postaci spakowanego folderu
Format *.7z to alternatywa popularnego formatu *.zip. Jeżeli do tej pory nigdy jeszcze takich plików nie rozpakowywałeś, pobierz ze strony http://7-zip.org/ i zainstaluj program Open Source o tej samej nazwie.
Gdy zajrzysz do wnętrza pliku pobranego ze strony Inkscape, przekonasz się że zawiera pojedynczy folder o nazwie inkscape (Rysunek 4.1.10):
Rysunek 4.1.10 Zawartość pliku *.7z, pobranego z portalu Inkscape (okno programu 7-zip)
Gdybyś chciał używać wersji 32-bitowej, mógłbyś po prostu rozpakować ten folder gdziekolwiek na swój dysk twardy i uruchomić umieszczony w środku plik inkscape.exe.
My jednak chcemy używać zainstalowanej wersji 64-bitowej, dlatego wykorzystamy tylko niektóre podkatalogi folderu inkscape z pliku 7z.
Na ilustracji poniżej pliki 64-bitowego Inkscape znajdują się w folderze C:\Program Files\Inkscape-0.48\. Zacznij od zmiany nazwy podkatalogu etc\ na etc.org\ 1 (Rysunek 4.1.11):
Rysunek 4.1.11 Podmiana podkatalogu etc\ na nowy, pobrany z pliku *.7z.
Następnie skopiuj do folderu Inkscape katalog etc\ z pliku 7z (Rysunek 4.1.11). Najprościej to zrobić przeciągając ten folder z okna 7-zip do folderu Inkscape w oknie Eksploratora Windows.
Następnie przejdź w obydwu oknach do podkatalogów o nazwie share\ (w oknie Inkscape to Inkscape-0.48\share, w pliku 7z to inkscape\share — por. Rysunek 4.1.12):
Rysunek 4.1.12 Skopiowanie folderu themes z pliku 7z do katalogu share\
Skopiuj z pliku 7z do katalogu share folder o nazwie themes (Rysunek 4.1.12). Po tych zmianach, gdy powtórnie wywołasz 64-bitowy Inkscape, okno będzie maiło jaśniejszy odcień, i nie będzie problemu z widocznością jakichkolwiek ikon (Rysunek 4.1.13):
Rysunek 4.1.13 Poprawione barwy okna 64-bitowej wersji Inkscape
Rysunek 4.2.1 pokazuje, jak wygląda ekran Inkscape zaraz po pierwszym otwarciu:
Rysunek 4.2.1 Okno Inkscape
Okno programu jest tu jednocześnie oknem obrazu. Wokół krawędzi są rozmieszczone różnorodne przyborniki z ikonami (Rysunek 4.2.1). Pionowo, po lewej — przybornik z narzędziami edycji. U góry — m.in. pola umożliwiające zmianę położenia i rozmiarów wybranego obiektu.
W zależności od kompilacji Inkscape wykorzystuje różne odmiany okna wyboru plików (otwieranych poleceniem polecenia File→Open. Oficjalne, 32-bitowe wersje programu, wykorzystują standardowe okno wyboru plików Windows. Wersja 64-bitowa, pochodząca spoza oficjalnego portalu (por. str. 20) ma takie same okna wyboru plików, jak w Gimpie (Rysunek 4.3.1 — por. str. 60):
Rysunek 4.3.1 Inkscape (64-bitowe) — okno wyboru plików
Inkscape umożliwia podgląd zawartości pliku, podświetlonego na liście — ale tylko do pewnego rozmiaru. Po naciśnięciu przycisku Open, w Inkscape pojawi się załadowany plik.
Podobnie w przypadku zapisu pliku (polecenie File→Save As): 32-bitowa wersja Inkscape używa standardowego okna Windows, a 64-bitowa — okna z tej samej biblioteki (komponentu) co GIMP (Rysunek 4.3.2):
Rysunek 4.3.2 Inkscape (64-bitowe) — okno zapisu plików
Wywołaj polecenia File→Document Properties. (Rysunek 4.4.1):
Rysunek 4.4.1 Ustalenie rozmiaru dokumentu
W oknie dialogowym Document Properties, w pola Width, Height sekcji Custom size, wpisz wymiary dokumentu. Sugerowałbym, aby — dla wygody — założyć, że 1 jednostka Inkscape = 1 piksel weryfikowanego obrazu.
Okno Document Properties nie ma przycisku “OK.” — zmiany zostają wprowadzone, gdy tylko opuścisz to okno.
Wywołaj polecenie File→Import. W oknie dialogowym wyboru plików, które się pojawi, wskaż jakiś plik rastrowy (Rysunek 4.5.1a):
Rysunek 4.5.1 Wybór pliku rastrowego (wersja 32-bitowa)
Gdy naciśniesz przycisk Otwórz, Inkscape wyświetli jeszcze dodatkowe okno dialogowe (Rysunek 4.5.1b). Wybierz na nim opcję link. Wówczas wybrany obraz zostanie wstawiony do aktualnego rysunku (Rysunek 4.5.2):
Rysunek 4.5.2 Kolejny obraz rastrowy, dodany do dokumentu Inkscape
64-bitowa wersja Inkscape używa okien dialogowych wyboru plików w stylu GTK+ — takich jak te używane w GIMP (por. str. 60).
Wywołaj File→Export Bitmap l. Inkscape otworzy odpowiednie okno dialogowe (Rysunek 4.6.1):
W sekcji Export area naciśnij przycisk (przełącznik) Page. W tym trybie eksportowany jest zadeklarowany obszar rysunku (por. str. 98). W sekcji Bitmap size ustal rozmiary obrazu rastrowego. Jeżeli eksportowany plik ma być użyty jako tekstura, postaraj się, by miał taką samą wysokość i szerokość. Jeszcze lepiej, gdy rozmiar obrazu w pikselach jest jakąś potęgą liczby 2. Zazwyczaj stosuje się rozmiary 512, 1024, 2048. Jak widać na ilustracji, ja wybrałem 2048 (aby było widać jak najwięcej szczegółów) .
W polu Filename ustalamy nazwę pliku. Inkscape zapisuje (na razie?) bitmapy tylko w jednym formacie: *.png. Nie jest to jednak duży problem, możemy ją później przekształcić na inny format za pomocą Gimpa. Zresztą Blender akceptuje obrazy także w formacie *.png.
Po naciśnięciu przycisku Export zostanie utworzony obraz, gotowy do użycia w Blenderze.
Eksportowana jest tylko zawartość tych warstw Inkscape, które są aktualnie widoczne!
Obsługa zmiany powiększenia (zoom) i przesuwania obrazu (pan) jest w Inkscape prawie taka sama jak w GIMP.
Zmiany powiększenia można dokonać na dwa sposoby:
szybko i mniej dokładnie: trzymając wciśnięty Ctrl i obracając kółkiem myszki (KM);
dokładnie: wpisując %powiększenia w pole Zoom, u dołu ekranu (Rysunek 4.7.1);
Rysunek 4.7.1 Widok: dwie metody zmiany powiększenia (Zoom)
Przesunięcie widoku to ruch myszki z wciśniętym SPM (identycznie jak w GIMP — str. 65). Możesz także użyć w tym celu pasków przewijania (scrollbars), umieszczonych z boku ekranu.
Dodatkowo, zgodnie ze standardem Windows, obrót KM powoduje przewijanie obrazu w górę i w dół. Już poza tym standardem, kombinacja Shift - KM przesuwa widok w poziomie.
W Inkscape, podobnie jak w GIMP, istnieją warstwy, za pomocą których możesz grupować elementy rysunku. Gdy wywołasz polecenie Layer→Layers (Shift-Ctrl-L), na ekranie pojawi się dodatkowy panel (Rysunek 4.8.1) :
Rysunek 4.8.1 Panel zarządzania warstwami
Panel sterowania warstwami zapewnia pełną kontrolę ich stanu. Zwróć szczególną uwagę na kontrolkę Opacity — zmienia przejrzystość podświetlonej na liście warstwy. Będziesz jej często używał. Panel Layers (i wszystkie inne) możesz “schować” lub przywołać z powrotem naciskając F12 (View→Show/Hide Dialogs)
Oprócz paneli zarządzania, Inkscape ma dodatkową kontrolkę u dołu ekranu (Rysunek 4.8.2). Za pomocą tej listy rozwijalnej i dwóch przełączników można:
zmienić aktualną warstwę;
włączyć lub wyłączyć widoczność warstwy;
włączyć lub wyłączyć blokadę zmian dla obiektów umieszczonych na warstwie.
Rysunek 4.8.2 Elementy szybkiego zarządzania warstwami
Z kontrolki umieszczonej u dołu ekranu korzysta się najczęściej, gdyż nie zajmuje tyle cennej przestrzeni ekranu, co panel Layers.
Warto zwrócić uwagę na pewne konwencję prezentowania nazwy warstw na liście rozwijalnej:
nazwa zablokowanej warstwy jest ujęta w nawiasy kwadratowe.
nazwa warstwy ukrytej jest szare, a nie czarna.
W ten sposób, zaraz po rozwinięciu listy, możesz się szybko zorientować co do stanu każdej z warstw.
Otwórz panel Layers (Layer→Layers). Na panelu naciśnij przycisk . Możesz także (alternatywnie) użyć polecenia z menu: Layer→Add Layer.... Pojawi się okno dialogowe nowej warstwy (Rysunek 4.9.1):
Rysunek 4.9.1 Dodawanie nowej warstwy
W oknie Add Layer wpisz w pole Layer name nazwę nowej warstwy. W polu Position możesz ustalić, w którym miejscu na liście ma być umieszczona (powyżej lub poniżej warstwy aktualnej).
Otwórz panel Layers (Layer→Layers). Na panelu podświetl warstwę do usunięcia i naciśnij przycisk (Rysunek 4.10.1). (Możesz także — alternatywnie — użyć polecenia z menu: Layer→Delete Current Layer..).
Rysunek 4.10.1 Usunięcie warstwy
W Inkscape każdy obiekt jest umieszczony “ponad” albo “poniżej” innych. Przyjrzyjmy kwadratowi i elipsie, umieszczonym na tej samej warstwie (Rysunek 4.11.1). Elipsa zasłania kwadrat — jest obiektem pierwszoplanowym:
Rysunek 4.11.1 Oryginalna kolejność obrazów
Zaznacz elipsę. Następnie wywołaj polecenie Object→Lower to Bottom. Sytuacja ulegnie zmianie (Rysunek 4.11.2):
Rysunek 4.11.2 Kolejność obrazów po przesunięciu pierwszoplanowego “na dno”.
Spośród czterech poleceń, za pomocą których można w Inkscape zmieniać kolejność obiektów, w praktyce używałem tylko dwóch:
Object→Lower to Bottom (skrót klawiatury: End, ikona: ): umieszcza zaznaczony obiekt poniżej wszystkich innych;
Object→Raise to Top (skrót klawiatury: Home, ikona: ): umieszcza zaznaczony obiekt powyżej wszystkich dotychczas narysowanych;
Każdy nowy obiekt, który tworzysz, jest umieszczany ponad wszystkimi narysowanymi do tej pory.
W Inkscape istnieją także warstwy, pełniące podobną rolę jak w GIMP: podzielenia rysunku na fragmenty, łatwiejsze do zarządzania (patrz str. 102). W ogólnej hierarchii Inkscape najważniejsza jest kolejność warstw. To ona określa “zgrubnie”, co jest widoczne, co nie widoczne, a także co jest na wierzchu a co pod spodem. Omawiane w tej sekcji operacje — “przesuń na spód”, “przesuń na wierzch” — zmieniają kolejność obiektów tylko w obrębie pojedynczej warstwy.
W Inkscape możesz użyć linii pomocniczych (guides). Służą do zaznaczania jakiegoś istotnego miejsca, a także porównań. Tworzy się je tak samo jak w GIMP: poprzez “wyciągnięcie” z linijki z boku lub z góry ekranu (Rysunek 4.12.1):
Rysunek 4.12.1 “Pobranie” linii pomocniczej
Linia pomocnicza nie jest częścią obrazu — nie jest drukowana, ani nie pojawia się w obrazach wyeksportowanych do pliku rastrowego.
Istniejące linie pomocnicze można przesuwać. Gdy zbliżasz do nich wskaźnik myszki na odległość kilkunastu pikseli, linie zmieniają kolor na czerwony. W ten sposób Inkscape sygnalizuje, że wciśnięcie w tym obszarze LPM i przesunięcie myszki przeniesie linię pomocniczą w nowe miejsce. Zostanie umieszczona tam, gdzie zwolnisz LPM.
Aby usunąć linię pomocniczą — trzymając wciśnięty Ctrl, kliknij w nią LPM.
Jeżeli w oknie Document Properties (Shift-Ctrl-D) jest włączone “przyciąganie” do punktów charakterystycznych (Rysunek 4.12.2) — tworzone lub edytowane obiekty będą się dopasowywać do linii pomocniczych.
Przesunięcie za pomocą myszki zawsze jest obarczone jakimś błędem. Inkscape umożliwia — jako alternatywę — wpisanie dokładnych wartości numerycznych dla położenia i rozmiaru obiektu. Można to zrobić w trybie wyboru obiektów. Służą do tego pola X, Y, W, H, umieszczone w przyborniku ponad rysunkiem (Rysunek 4.13.1):
Rysunek 4.13.1 Obraz: ustalenie dokładnego położenia
Najczęstsze zastosowanie tej funkcji, to dokładne pozycjonowanie obrazów na rysunku. Aby ustalić ostateczną pozycję, wpisz w pola X i Y współrzędne lewego górnego narożnika obrazu (Rysunek 4.13.1).
Inkscape dolicza do rozmiaru obiektu także grubość jego obrysu (jeżeli kształt obiektu jest obrysowany — tzn. ma włączoną opcję Stroke — por. str. 109).
Rysowanie linii zaczynamy od przełączenia się w odpowiedni tryb pracy — rysowania linii (Rysunek 4.14.1):
Rysunek 4.14.1 Rysowanie linii w Inkscape
Linię zaczynasz od kliknięcia LPM w punkt, który będzie początkiem pierwszego odcinka. Od tej chwili za kursorem myszki zaczyna się “ciągnąć” czerwona kreska (mimo, że nie naciskasz żadnego klawisza). Gdy po raz drugi klikniesz LPM — wskażesz koniec odcinka. Linia może się składać z jednego lub więcej takich segmentów. Zwróć uwagę, że po wskazaniu drugiego punktu Inkscape “z własnej inicjatywy” rozpoczął “ciągnąć” kolejny odcinek linii. Musisz na koniec nacisnąć Enter, aby zasygnalizować programowi, że “na tym kończymy”.
Aby usunąć ostatnio narysowany odcinek linii — naciśnij Backspace.
Jeżeli rysowany odcinek ma być poziomy lub pionowy — podczas rysowania trzymaj wciśnięty Ctrl.
Inkscape stara się ułatwić rysowanie linii jako figury zamkniętej. Stąd, gdy podczas rysowania linii zbliżysz koniec ostatniego odcinka do początku pierwszego — punkt początkowy ulegnie podświetleniu (Rysunek 4.14.2). Gdy umieścisz w nim punkt końcowy odcinka, który rysujesz (kliknięcie LPM) — linia stanie się zamknięta.
Każdy obiekt w dokumencie Inkscape — poza obrazem rastrowym — jest figurą geometryczną, złożoną z dwóch elementów:
Dla obydwu można ustalić kolor, a w bardziej złożonych przypadkach — gradient czy deseń, jakim są rysowane. Linia konturu dodatkowo posiada takie właściwości jak grubość i wzór (ciągła, kreskowana, kropkowa,...)
Kontury otwarte także mogą posiadać wypełnienie — choć w takim przypadku wygląda nieco dziwnie.
Do zmiany wypełnienia i linii konturu obiektu służy panel Fill and Stroke (Rysunek 4.15.1):
Rysunek 4.15.1 Okno właściwości kształtu (Fill and Stroke)
W zakładce Stroke style ustalasz grubość i deseń linii obrysu. W zakładce Stroke paint ustalasz barwę (lub gradient, lub deseń) linii (Rysunek 4.15.2):
Rysunek 4.15.2 Zmiana barwy linii — zakładka Stroke paint
Zakładka sterująca wypełnieniem obiektu to Fill. Zawiera identyczne kontrolki jak Stroke paint.
Spośród możliwych trybów wypełnienia wyróżnia się pierwsza opcja od lewej — (Rysunek 4.15.3). Gdy ją wybierzesz w zakładce Fill, obiekt w ogóle nie będzie miał wypełnienia. (Analogicznie, wybór tej opcji w Stroke paint spowoduje, że obiekt w ogóle nie będzie miał obrysu).
Na zakończenie warto wspomnieć o jeszcze jednej właściwości obiektu w Inkscape. Możesz tu sterować nieprzejrzystością pojedynczego obiektu dokładnie tak samo, jak w GIMP steruje się nieprzejrzystością całych warstw. Służy do tego niewielka kontrolka O, umieszczona u dołu ekranu (Rysunek 4.15.4):
Rysunek 4.15.4 Zmiana nieprzejrzystości obiektu (O pacity)
Linie (a właściwie — “ścieżki”, bo Inkscape określa je jako paths), które narysowałeś, możesz później modyfikować. Służy do tego oddzielny tryb — edycji węzłów (Rysunek 4.16.1). (Węzłem linii jest każdy z jej wierzchołków):
Rysunek 4.16.1 Edycja wierzchołków wybranej linii
W tym trybie każdy punkt linii (węzeł) jest oznaczony małym rombem. Możesz za nie „łapać” (LPM) i przesuwać w nowe miejsca. Obowiązują tu dokładnie te same reguły, co przy edycji całych obiektów. Pojedyncze kliknięcie w węzeł oznacza go jako wybrany (Węzeł wybrany zmienia swój kolor na niebieski). Jeżeli podczas wskazywania węzłów będziesz trzymać wciśnięty klawisz Shift - możesz zaznaczyć wiele punktów naraz. Możesz je także zaznaczać obszarem prostokątnym.
Aby dodać do linii nowy wierzchołek — kliknij dwukrotnie LPM w segment, w miejscu w którym ma być wstawiony.
Aby usunąć wybrany węzeł/węzły — naciśnij klawisz Del. To zazwyczaj powoduje zmianę kształtu linii.
Inkscape pozwala od razu rysować linie krzywe — wystarczy w trakcie rysowania kolejnego segmentu trzymać przez cały czas wciśnięty LPM. Muszę jednak przyznać, że dla dokładnego odwzorowania kształtu ta metoda jest trochę nieodpowiednia. (A może — nie przećwiczyłem jej dostatecznie.) W każdym razie pokażę tu sposób, którego używam “na co dzień”.
pierwszym przybliżeniu obrysu za pomocą linii łamanej (patrz str. 108, 116);
przekształceniu kolejnych segmentów łamanej w odcinki krzywej.
Aby zmienić kształt linii łamanej w krzywą, musisz się przełączyć w tryb edycji. Potem wystarczy “złapać” za segment linii LPM i wygiąć w odpowiedni kształt (Rysunek 4.17.1):
Rysunek 4.17.1 Linia krzywa uzyskana poprzez “wyciągnięcie”
Alternatywną metodą jest zamiana poszczególnych węzłów (wierzchołków) z “ostrych” na “gładkie”, poprzez naciśnięcie ikony . Rysunek 4.17.2 przedstawia, na czym to polega:
Rysunek 4.17.2 Linia krzywa uzyskana poprzez zmianę typu węzła na “gładki, symetryczny”
W węźle pojawiły się dwie styczne do krzywej. Możesz sterować kształtem linii zmieniając ich pochylenie i długość. Przedstawiony na rysunku węzeł jest “symetryczny”, co oznacza że zmiana jednej stycznej powoduje identyczną zmianę drugiej. (Dzięki temu wygięcie będzie bardziej “płynne”, gdyż krzywe z obydwu stron węzła mają w tym miejscu taki sam promień krzywizny).
Jeżeli nie zależy Ci na aż tak “dokładnych” zaokrągleniach — możesz węzeł przełączyć w tryb (Rysunek 4.17.3). Wtedy styczne z każdej strony węzła będą utrzymywały współliniowość. Mogą się jednak różnić długością.
Rysunek 4.17.3 Węzeł gładki, niesymetryczny
Krzywe, uzyskane w ten sposób, “na oko” wyglądają na gładkie. Gdy jednak styczne w węźle różnią się długością, występuje w nich skokowa zmiana promienia krzywizny.
Gdy chcesz uzyskać w węźle „narożnik” — przełącz się w tryb . Wtedy możesz manipulować każdą ze stycznych oddzielnie (Rysunek 4.17.4):
Rysunek 4.17.4 Węzeł ostry
Ostateczny kształt krzywej uzyskujesz, przekształcając kolejne węzły na “gładkie” i — zazwyczaj — symetryczne (Rysunek 4.17.5). Zaczynasz ten proces od jednego krańca linii łamanej. Sukcesywnie przekształcasz w krzywą i nadajesz właściwy kształt kolejnym segmentom, dopóki nie dotrzesz do końca linii.
Rysunek 4.17.5 Krzywa z wieloma wierzchołkami
Łuk to specjalny przypadek krzywej. Operację pokażę na przykładzie formowania obrysu krawędzi natarcia statecznika pionowego. Jest to odcinek prostej i fragment łuku. Zacząłem jednak od narysowania dwóch prostych odcinków (Rysunek 4.18.1a):
Rysunek 4.18.1 Obrys — wygładzanie
Aby zmienić drugi segment w łuk:
przełącz się w tryb edycji węzłów;
kliknij w środek segmentu, który ma być zakrzywiony. (Jego obydwa wierzchołki powinny zabarwić się na niebiesko);
naciśnij przycisk w pasku narzędzi, zmieniający odcinek w segment krzywej (Rysunek 4.18.1a);
ustaw odpowiednio uchwyty stycznych na końcu linii, aby nadać krzywiźnie właściwy kształt (Rysunek 4.18.1b);
W Inkscape każda krzywa to tzw. krzywa Beziera. Pojedynczy segment takiej linii potrafi całkiem dokładnie odwzorować łuk o kącie do 60º. W tym przypadku kąt nie przekracza 45º, więc nie dodawałem żadnego dodatkowego węzła pośrodku.
Gdy za pomocą krzywej Beziera masz zamodelować łuk, trzymaj się następujących zasad:
kierunki stycznych na końcach krzywej powinny być takie same, jak styczne łuku;
długości obydwu odcinków stycznych powinny być równe.
W tej sekcji pokażę, jak za pomocą krzywych odwzorować zadany kontur - na przykładzie obrysu steru kierunku P-40. (Odwzorowanie przedniej części — konturu krawędzi natarcia statecznika pionowego — jest opisane na str. 115). Jeżeli do tej pory w Inkscape rysowałeś tylko linie łamane — zerknij na str. 112. Znajdziesz tam wprowadzenie do tworzenia linii krzywych.
Najpierw obrysuj kontur linią łamaną (Rysunek 4.19.1a). Wierzchołki linii wstawiaj w takich miejscach, by największe wybrzuszenie krzywej leżało w równej odległości od początku i końca odcinka (Rysunek 4.19.1b).
Rysunek 4.19.1 Wstępny obrys steru kierunku — odcinkami prostych
Po narysowaniu linii, włącz tryb edycji węzłów. Zamień łamaną na krzywą, wygładzając kolejne wierzchołki (p. str. 113).. Dla kolejnych węzłów (poza krańcowymi):
zaznacz węzeł jako “symetrycznie gładki” (Rysunek 4.19.2);
dostosuj krzywiznę za pomocą stycznych. Czasami trzeba także przesunąć węzeł.
Podczas wygładzania może się także zdarzyć, że zdecydujesz się jakiś węzeł dodać lub usunąć.
Przełącz się w tryb rysowania prostokątów (Rysunek 4.20.1):
Rysunek 4.20.1 Rysowanie kwadratu
Wciśnij LPM w miejscu, gdzie ma się znajdować jeden z narożników prostokąta. Następnie, trzymając wciśnięty LPM, przesuwaj kursor. Będziesz “ciągnął” w ten sposób przeciwległy narożnik prostokąta. Aby uzyskać kształt kwadratu, trzymaj jednocześnie wciśnięty Ctrl. Miejsce, w którym zwolnisz LPM, wyznaczy przeciwległy narożnik obiektu.
Zaznacz prostokąt i przełącz się w tryb “prostokąta” (Rysunek 4.21.1):
Rysunek 4.21.1 Punkty sterujące rozmiarem prostokąta
Możesz przeciągnąć LPM kwadratowe uchwyty, umieszczone w narożnikach prostokąta, w nowe miejsce. W ten sposób zmienić rozmiar tego obiektu. Alternatywnie — możesz ustalić rozmiar w sposób dokładny — wpisując wartości numeryczne w pola W, H, umieszczone w przyborniku ponad obszarem rysunku (Rysunek 4.21.1).
Dodatkowo, prostokąt ma w pobliżu prawego górnego narożnika widoczne jeden lub dwa okrągłe węzły. Gdy widzisz jeden, oznacza to, że są na siebie nałożone (por. Rysunek 4.21.1). Węzły okrągłe służą do ustalenia promienia zaokrąglenia narożników prostokąta (Rysunek 4.21.2):
Rysunek 4.21.2 Prostokąt - zaokrąglanie
Jeżeli przeciągniesz jeden okrągły węzeł do dołu, a drugi - w lewo (Rysunek 4.21.2) — narożniki prostokąta staną się zaokrąglone. Jeżeli zsuniesz je w to samo miejsce — narożniki staną się ostre. Możesz ustalić dokładne wartości promieni zaokrąglenia, wpisując je w pola Rx i Ry, umieszczone ponad obszarem rysunku. Zwróć uwagę, że zaokrąglenia mogą być eliptyczne (gdy Rx i Ry nie są równe).
W Inkscape okręgi rysuje się tak samo jak kwadraty (por. str. 117). Wybierasz tylko inny tryb rysowania: okręgów (oznaczony ikoną: ). Następnie naciskasz LPM w miejscu, gdzie mają sięgać lewe, górne granice elipsy. Przeciągasz kursor z wciśniętym LPM, i zwalniasz ten przycisk w miejscu, do którego mają sięgać prawe, dolne granice elipsy (Rysunek 4.22.1):
Rysunek 4.22.1 Rysowanie okręgu
Podobnie jak w przypadku kwadratów, ważne jest wciśnięcie klawisza Ctrl podczas “przeciągania” drugiego punktu, bo inaczej narysujesz elipsę.
Jeżeli podczas tworzenia okręgu będziesz trzymał wciśnięty klawisz Shift — początkowe położenie myszki stanie się środkiem okręgu, a nie narożnikiem jego „ramki”
Zaznacz okrąg/elipsę i przełącz się w tryb “okręgu” (Rysunek 4.23.1):
Rysunek 4.23.1 Węzły sterujące elipsy/łuku
Kwadratowe węzły sterujące, umieszczone z lewej strony i u góry, służą do zmiany długości promieni elipsy/ promienia okręgu.
Okrągłe uchwyty służą do zmiany elipsy w łuk (eliptyczny) (Rysunek 4.23.2):
Rysunek 4.23.2 Przekształcenie w łuk
Dokładną wartość kąta początkowego można wpisać w pole Start, a końcowego — w pole End, umieszczone w przyborniku ponad obszarem rysunku (Rysunek 4.23.2).
Ikona , umieszczona z lewej strony, służy do ponownego zamknięcia elipsy (zmiany kąta łuku na 360º).
Jeżeli nie chcesz widzieć linii skierowanych od krańców łuku do środka elipsy — przełącz się na alternatywny tryb rysowania (Rysunek 4.23.3).
“Złap” LPM obiekt (tylko nie ramkę zaznaczenia!) i przesuwaj. Punkt, gdzie zwolnisz LPM, określi nowe położenie obiektu. Na przykład, złap LPM za obraz rzutu z góry i przesuń, aby wyrównać z rzutem z lewej (Rysunek 4.24.1).
Rysunek 4.24.1 Przesunięcie — dopasowywanie rzutu z góry do rzutu z boku
Aby dobrze dopasować do siebie obydwa obrazy, często warto użyć linii pomocniczych (Rysunek 4.24.2):
Rysunek 4.24.2 Linie pomocnicze — ułatwiają dopasowanie dwóch obrazów
Zamiast przesuwać obiekt myszką, możesz także wpisać dokładne współrzędne jego nowego położenia. Możesz to zrobić w polach X, Y, w przyborniku ponad obszarem rysunku (Rysunek 4.24.1).
W Inkscape, wokół każdego zaznaczonego obiektu rysowana jest ramka. Nazwijmy ją ramką selekcji.
Początkowo ramka selekcji pojawia się zawsze w trybie “zmiany rozmiaru” (Rysunek 4.25.1). Jeżeli jednak jeszcze raz klikniesz w zaznaczony obiekt LPM, przełączysz się w tryb “obrotu/przekoszenia” (Rysunek 4.25.2):
Rysunek 4.25.1 Ramka zmiany rozmiaru | Rysunek 4.25.2 Ramka obrotu/przekoszenia |
Ramka obrotu zawiera bardzo ważny punkt — środek transformacji. Jest oznaczony niewielkim krzyżykiem (Rysunek 4.25.2). (Gdy nie możesz go od razu dostrzec, zmniejsz powiększenie — wtedy łatwiej go znaleźć).
Środek transformacji można “złapać” LPM i przesunąć w inne miejsce (Rysunek 4.25.3).
Środek jest zawsze wykorzystywany przez Inkscape podczas obrotu, oraz — gdy trzymasz wciśnięty klawisz Shift — podczas zmiany skali i przekoszenia.
Zaznacz obiekt, który ma być zmieniony. Następnie złap LPM za uchwyt ramki selekcji i przeciągnij. Nowe rozmiary obiektu będą ustalone dla miejsca, w którym zwolniłeś LPM (Rysunek 4.26.1):
Rysunek 4.26.1 Zmiana rozmiaru (skali) obiektu
Domyślnym środkiem skalowania jest przeciwległy narożnik ramki.
Aby zmieniać skalę względem środka obiektu (patrz str. 122) — podczas przesuwania myszki dodatkowo trzymaj wciśnięty klawisz Shift.
Aby zmienić skalę równomiernie we wszystkich kierunkach — podczas przesuwania myszki dodatkowo trzymaj wciśnięty klawisz Ctrl.
Jeżeli chcesz dokonać zmiany skali o dokładnie ustaloną wartość — otwórz panel Transform za pomocą polecenia Object→Transform (Shift-Ctrl-M) . Wybierz w niej zakładkę Scale (Rysunek 4.26.2). W pola Width, Height możesz wpisać dokładne wartości nowej skali.
Zaznacz obiekt, który ma być przekoszony. Kliknij w niego jeszcze raz, aby przełączyć ramkę selekcji w tryb przekoszenia (szczegóły - str. 122). Następnie złap LPM za jeden z uchwytów na boku ramki, i przesuń. Przekoszenie obiektu będzie ustalone dla miejsca, w którym zwolnisz LPM (Rysunek 4.27.1):
Rysunek 4.27.1 Obrót obiektu
Przed przekoszeniem możesz przesunąć środek transformacji w inne miejsce. Wystarczy go “złapać” LPM i przesunąć (szczegóły — str. 122).
Aby przekoszenie następowało skokowo, dokładnie co 15º — podczas przesuwania myszki dodatkowo trzymaj wciśnięty klawisz Ctrl.
Jeżeli chcesz dokonać przekoszenia o dokładnie ustaloną wartość — otwórz panel Transform za pomocą polecenia Object→Transform (Shift-Ctrl-M) . Wybierz w niej zakładkę Skew (Rysunek 4.27.2). W pola Horizontal, Vertical możesz wpisać dokładne wartości przekoszenia.
Czytając wcześniejsze rozdziały, zapewne przekonałeś już się, że uwielbiam umieszczać u dołu strony przypisy z dodatkowymi informacjami. Ta część książki to właściwie wybór takich “uwag na marginesie”, które w trakcie pisania urosły do rozmiaru całej sekcji ☺.
Jak w każdym dodatku, są to informacje, z których nie musisz korzystać, aby stworzyć e-model samolotu. Czasami jednak mogą się przydać, by coś wyjaśnić lub ułatwić. Mam jednak nadzieję, że znajdziesz tu rozwinięcie wielu zagadnień, które świadomie skracałem w głównym tekście książki.
Można powiedzieć, że jest to rozdział dla prawdziwych modelarzy — istot, które chcą odtworzyć pierwowzór najdokładniej, jak to jest możliwe. Efektem porównań, które pokażę poniżej, będzie poprawiona sylwetka P-40. Szczerze mówiąc, metody, które tu przedstawiam, pozwoliłyby opracować solidne plany modelarskie. Nie to było to jednak w tym przypadku moim celem.
Znalazłem w Internecie ([1] ) obrazy kilku rysunków fabrycznych P-40. Niestety, nie mają zbyt dużej rozdzielczości, więc większości wymiarów nie można odczytać (Rysunek 5.1.1). Mimo tego się przydadzą. W tej sekcji spróbujemy porównać z nimi odpowiednie fragmenty planów samolotu.
Rysunek 5.1.1 Przykładowy, zeskanowany rysunek fabryczny (z www.p40warhawk.com)
To porównanie wykonamy w Inkscape (wprowadzenie — patrz str. 96), a nie w GIMP. Dlaczego? W Inkscape wygodniej jest skalować i obracać obrazy. GIMP na czas takiej operacji wyłącza wszelkie “przejrzystości” warstw. Inkscape podczas transformacji niczego nie przełącza ani nie wyłącza - warstwy pozostają przejrzyste. Dzięki temu przez cały czas nie tracisz z oczu wzorca, do którego się dopasowujesz. To ogromna różnica. Dopóki nie chcemy ingerować we “wnętrze” porównywanych rysunków, Inkscape jest lepszym narzędziem porównawczym.
Zaczniemy od weryfikacji kształtu usterzenia poziomego. Zmień nazwę pierwszej warstwy (utworzonej domyślnie w nowym rysunku przez Inkscape) z Layer 1 na Image (szczegóły — str. 102). Dodaj także drugą warstwę — nazwijmy ją Drawing.
W warstwę Image wstawimy obraz rzutu z lewej:
wybierz warstwę Image jako aktualną;
wczytaj (File→Import, str. 99) plik P40C-ML-Left.tif (por.str. 47);
dosuń wczytany rysunek do lewego górnego narożnika obrazu (Rysunek 5.1.2):
Rysunek 5.1.2 Przesuwanie obrazu na docelowe miejsce
Na koniec zablokuj warstwę Image przed zmianami (p. str. 102). Dzięki tej blokadzie nie będziesz w stanie omyłkowo zaznaczyć i przesunąć obrazu.
Teraz załadujemy rysunek fabryczny steru kierunku na warstwę Drawing:
wybierz warstwę Drawing jako aktualną;
wczytaj Source\Curtiss\Tail-Rudder framework.gif (z pliku source.zip — por. str. 17)
Rysunek 5.1.3 pokazuje rezultat:
Rysunek 5.1.3 Rysunek steru kierunku, zaraz po wczytania
Jak widać (Rysunek 5.1.3), wczytany obraz musimy nieco przygotować, nim zaczniemy przymierzać do planów:
wywołaj polecenie Object→Rotate 90º CW (lub użyj przycisku z paska skrótów);
ukryj na razie warstwę Image (p. str. 102);
zmniejsz nieprzejrzystość warstwy Drawing do 60% (p. str. 102);
Rysunek 5.1.4 pokazuje rezultat:
Rysunek 5.1.4 Wstępne przygotowanie rysunku
Zbliż się do obrazu steru kierunku (str. 101) i przyjrzyj mu się uważnie. Czy osie są proste? Czy są wzajemnie prostopadłe? (Rysunek 5.1.5):
Dodaj do rysunku kilka linii pomocniczych (p. str. 106). Rozmieść je tak, by można było sprawdzić, czy kluczowe linie rysunku są pionowe lub poziome.
W przykładzie, który pokazuje ilustracja (Rysunek 5.1.5), wygląda na to, że oś steru ma odchylenie. Jednocześnie linie żeber są poprawne, czyli poziome. Taka sytuacja oznacza, że rysunek ma drobne przekoszenie. Będzie to trzeba poprawić przez transformację odwrotną (por. Rysunek 5.1.6c, szczegóły — str. 124).
Musimy jednak wcześniej zadbać o właściwe położenie środka tego przekoszenia (p. str. 122). Przesuń rysunek tak, by dolny zawias steru znalazł się tam, gdzie przecinają się dwie linie pomocnicze. Następnie przesuń w to miejsce także środek obrazu (Rysunek 5.1.5, Rysunek 5.1.6b).
Rysunek 5.1.6 pokazuje szczegóły przekoszenia (Skew), którym skorygujemy odchylenie osi na rysunku fabrycznym (Rysunek 5.1.6a). Środkiem tej transformacji jest punkt, w którym oś rysunku pokrywa się z linią pomocniczą (Rysunek 5.1.6b):
Rysunek 5.1.6 Korygowanie przekoszenia obrazu
Tak niewielkie przesunięcia, jak przedstawiona powyżej, staraj się wykonać w jak największym powiększeniu. (Wystarczy widzieć na ekranie uchwyt, który masz „złapać” myszką, i mieć trochę miejsca na przesunięcie).
Rysunek 5.1.7 pokazuje, w jakim powiększeniu można wygodnie i dokładnie skorygować niewielką deformację osi. Widzimy tu tylko fragment ramki obrotu (Rysunek 5.1.7a). To nic nie szkodzi, bo najważniejszy element — uchwyt przekoszenia — jest nadal dostępny do “złapania”. Na ekranie jest także miejsce na jego przesunięcie.
Rysunek 5.1.7 Przykład powiększenia, w którym koryguję oś steru
Przeciągnij uchwyt w prawo tak, by oś na obrazie pokryła się z linią pomocniczą (Rysunek 5.1.7).
Jeżeli w czasie przeciągania drgnęła Ci ręka - dopóki nie zwolnisz LPM, możesz nacisnąć Esc. To przerwie całą operację.
Jeżeli już skończyłeś - i skrzywiłeś rysunek - zawsze możesz wycofać ostatnie polecenie (Edit→Undo, albo Ctrl-Z).
Włącz z powrotem widoczność warstwy Image, z sylwetką samolotu. Nasuń (por. str. 121) obraz steru na sylwetkę tak, by w tym samym miejscu miały dolny zawias. (Pamiętasz? tam umieściliśmy środek tego obrazu). Zmniejsz rysunek steru, za pomocą narożnego uchwytu ramki (Rysunek 5.1.8). Zrób to, tak, by rozmiar zmienił się proporcjonalnie względem ustalonego środka transformacji. (Trzymaj wciśnięte klawisze Shift i Ctrl — por. str. 123)
Rysunek 5.1.8 Nanoszenie rysunku fabrycznego na sylwetkę samolotu
Podobnie jak rysunek steru kierunku, wczytaj i dopasuj rysunek statecznika pionowego (plik Source\Curtiss\Tail-Fin.gif, z pliku source.zip). Uwaga: rysunek jest nieco obrócony i przekoszony — popraw go nim złożysz ze obrazem steru. Statecznik dopasuj do steru tak, by pokrywały się ich osie oraz punkty zawiasów. Obraz statecznika umieść na tej samej warstwie, co obraz steru (Drawing).
Rysunek 5.1.9 przedstawia ostateczny efekt nałożenia rysunków fabrycznych na rzut z lewej. Widać różnice pomiędzy liniami planów modelarskich i dokumentacji samolotu. To, że są niewielkie, dobrze świadczy o autorach planów.
Rysunek 5.1.9 Efekt nałożenia rysunków fabrycznych na rzut z lewej
Gdy znaleźliśmy takie różnice — warto je uwzględnić przy budowie modelu. Jednak korzystanie wprost z rysunków fabrycznych bywa trochę nieporęczne. Jest ich dużo, i zawierają sporo nieczytelnych wymiarów. (Takie wymiary są zupełnie bezużyteczne). Proponuję nanieść na rzut z lewej poprawiony obrys usterzenia pionowego, odpowiadający rysunkom fabrycznym. Linię tego obrysu narysujemy w Inkscape, na oddzielnej warstwie. Nazwiemy ją — Correction. Aby nasze poprawki odróżniały się od reszty rysunku, wszystko na tej warstwie będzie w kolorze czerwonym. Złożenie warstw Correction i Image wyeksportujemy jako rysunek rastrowy (por. str. 100) P40C-ML-Right.png, który użyjemy w Blenderze.
Zróbmy to. Zablokuj warstwę Drawing przed zmianami. Dodaj do rysunku nową warstwę — Correction (str. 103).
Rysowanie poprawek zaczniemy od naniesienia osi i kilku linii pomocniczych. Narysujemy je w kolorze niebieskim, by zaznaczyć w ten sposób, że nie są żadnym “namacalnym” elementem konstrukcji.
Narysuj linię osi steru (Rysunek 5.1.10). Po narysowaniu pierwszej linii przestaw (por. str. 109):
grubość na 0.5 px;
wzór na linię kreskowaną;
barwę na kolor niebieski.
(Dopóki tych ustawień nie zmienisz, każdy kolejny obiekt, który narysujesz, będzie miał właśnie taką grubość, barwę i wzór).
Na rysunku statecznika pionowego znajduje się także oś i zarys profilu statecznika poziomego. Teraz narysuj samą oś, potem skopiuj także profil. (Na wszystkich planach modelarskich statecznik wydaje się mieć zbyt zaokrągloną krawędź natarcia. Dokumentacja fabryczna i zdjęcia wskazują raczej na zastosowanie profilu z ostrym noskiem — p. str. 159).
Rysunek 5.1.10 Naniesienie na rysunek osi steru i kilku pomocniczych obrysów
Rysunek 5.1.10 zawiera, oprócz linii, także okrąg. Na planach fabrycznych jest zaznaczone, że obrys zaokrąglonej końcówki statecznika był łukiem. Aby to sprawdzić, umieściłem w podanym przez plany środku okrąg, o odpowiednim promieniu (rysowanie okręgu — p. str. 119). Zgadza się z zarysem statecznika!
Teraz narysuj wszystkie ważne linie wewnętrzne. Są to linie proste, czasami składające się z kilku segmentów. Po narysowaniu pierwszej z nich zmień jej właściwości: barwę linii na kolor czerwony, a wzór linii na linię ciągłą.
Rysunek 5.1.11 Poprawianie narysowanych linii
Podczas rysowania nie zapomnij trzymać wciśnięty klawisz Ctrl, aby linie były dokładnie pionowe lub poziome. Gdy jednak zdarzy Ci się popełnić błąd — możesz to poprawić. Wystarczy przełączyć się w tryb edycji węzłów (p. str. 111) (Rysunek 5.1.11).
Linie krzywe, odwzorowujące kształt samolotu, najlepiej jest tworzyć w dwóch etapach:
najpierw obrysować kontur przybliżoną linią łamaną, o niezbyt dużej liczbie wierzchołków;
potem wygładzić tę przybliżoną linię tak, by dokładnie oddać kształt obrysu.
Na str. 112 znajdziesz ogólne informacje o pracy z krzywymi w Inkscape. Na stronie 115 umieściłem się opis, jak odwzorować krawędź natarcia statecznika pionowego (jest to złożenie linii prostej i łuku). Na str. 116 znajdziesz opis, jak odwzorować kontur steru kierunku (jest to “ogólna” krzywa, a nie żadne złożenie łuków).
Rysunek 5.1.12 przedstawia ostateczny efekt korekt. Wykorzystałem tu wszystko, czym dysponowałem, nawet rysunek fabryczny owiewki wokół usterzenia i kadłuba. (Nie pokazałem, ani nie omawiałem go w tej sekcji.)
Rysunek 5.1.12 Korekty usterzenia pionowego
Szczególnie zaskakujące na tym rysunku jest przesunięcie tylnej krawędzi kadłuba. (Chodzi o krawędź ostatniej wręgi kadłuba, wzdłuż której biegnie oś steru kierunku — Rysunek 5.1.12.) Według wszelkich zdjęć, oś steru leżała z tyłu tej linii, a na rysunkach JJ/MŁ jest z przodu. Także kształt dolnej krawędzi owiewki usterzenia jest inny, niż na planach modelarskich.
Zachowaj to porównanie jako plik P40C-ML-Left.svg (por. str. 97). Wyeksportuj także do bitmapy (File→Export Bitmap) jako plik P40C-ML-Left.png.
Podsumowanie
Jeżeli dysponujemy rysunkami fabrycznymi, choćby fragmentów samolotu — warto je nałożyć na plany modelarskie. Możemy odkryć wiele różnic (str. 131)!
Do porównania (poprzez nałożenie) wielu obrazów wygodniej jest używać Inkscape, a nie GIMP. W Inkscape podczas każdej transformacji (skalowania lub obracania) nie tracisz z oczu żadnej z warstw. To zdecydowanie ułatwia wzajemne dopasowanie (str. 130).
Korekty oryginalnych rysunków nanosimy w Inkscape na oddzielną warstwę, w kontrastowym kolorze (np. czerwonym — por. str. 133)
Porównanie planów modelarskich z rysunkami fabrycznymi zmusiło nas w poprzedniej sekcji do naniesienia poprawek na plany. Mieliśmy do dyspozycji tylko rysunki fragmentów ogona: statecznika pionowego, jego owiewki, i steru kierunku. A co z resztą? Nie mamy już więcej fabrycznej dokumentacji kadłuba wersji P-40 B/C. Czy nie czają się tam kolejne niespodziewane różnice? Pozostaje porównać naszą sylwetkę z jakimś wyraźnym zdjęciem (Rysunek 5.2.1):
Rysunek 5.2.1 Tomahawk IIA (Hawk 81-A2, czyli P-40B) na lotnisku fabrycznym (Curtiss).
Wczytaj to zdjęcie (Source\Photo\P40B-Left-Photo.png z pliku source.zip, por. str. 17) do Inkscape. Warstwę, na której je umieścisz, nazwij Image. Zawsze zaczynaj od sprawdzania, czy fotografia jest zdeformowana — nieproporcjonalnie rozciągnięta w pionie lub w poziomie. Wybierz w tym celu na obrazie coś, co powinno być kołem. W przypadku tego zdjęcia (Rysunek 5.2.1) są to piasty podwozia głównego:
Rysunek 5.2.2 Oryginalne zdjęcie | Rysunek 5.2.3 Zdjęcie po przeskalowaniu (Y: -4%) |
Narysuj ponad piastą okrąg (rysuj z wciśniętym Ctrl, by na pewno nie był elipsą). Jeżeli dostrzeżesz odchylenia w kształcie piasty (Rysunek 5.2.2) — przeskaluj zdjęcie (tj. obraz), aby stała się z powrotem kołem (Rysunek 5.2.3).
Podczas dopasowywania zdjęcia, ułatwisz sobie pracę przesuwając środek transformacji do środka wzorcowego okręgu. Pamiętaj tylko, gdy będziesz zmieniał skalę obrazu, aby trzymać wciśnięty klawisz Shift. (W ten sposób wymusisz przeskalowanie względem środka transformacji obiektu).
Po sprawdzeniu i ewentualnym “wyprostowaniu” zdjęcia, usuń niepotrzebny już okrąg. Zablokuj także przed zmianami warstwę, na której znajduje się ta fotografia.
Używaj zdjęć o jak największej rozdzielczości. Na zdjęciach marnej jakości poprawny okrąg może się wydawać odrobinę spłaszczony, z powodu dużego rozmiaru rastra (pikseli). Kierując się tą fałszywą przesłanką, możesz spłaszczyć zdjęcie. Potem będziesz sądził, że cały rzut z lewej jest do poprawy, gdyż nie pasuje do fotografii.
Utwórz nową warstwę (o nazwie Drawing) i wczytaj na nią rzut z lewej (P40C-ML-Left.png). Następnie zwiększ przejrzystość tej warstwy (Rysunek 5.2.4):
Rysunek 5.2.4 Nałożenie na fotografię rzutu z lewej
Dopasuj rzut z lewej do sylwetki na fotografii. Pochyl go w ten sam sposób, co samolot na zdjęciu. Zmniejsz skalę tak, by wysokość kadłuba w okolicy najmniejszego zniekształcenia była zgodna z wysokością na zdjęciu (Rysunek 5.2.5):
Rysunek 5.2.5 Wstępne dopasowanie sylwetki do zdjęcia
Po wstępnym dopasowaniu sylwetki do zdjęcia widać, że nie będziemy ich w stanie od razu porównać. Zniekształcenie geometryczne fotografii jest zbyt duże. Pomijam zniekształcenie perspektywiczne skrzydła (jego końcówka jest o wiele bliżej obiektywu). Kształtem płata nie będziemy przejmować. Ważny jest tylko jego profil przy kadłubie, w szczególności punkt na krawędzi spływu.
W rzucie z boku najważniejszy jest obrys kadłuba. Linia ta leży na płaszczyźnie symetrii samolotu. Na analizowanym zdjęciu (Rysunek 5.2.2) uległa tzw. “zniekształceniu beczkowatemu”. Rysunek 5.2.6 i Rysunek 5.2.7 pokazują, jak wygląda takie zniekształcenie na przykładzie fotografii regularnej, prostokątnej siatki.
Rysunek 5.2.6 Proste zniekształcenie beczkowate | Rysunek 5.2.7 Złożone zniekształcenie beczkowate |
Gdyby soczewka obiektywu aparatu fotograficznego miała idealną ogniskową — uzyskalibyśmy zniekształcenie proste (Rysunek 5.2.6). Deformacja obrazu ma tu kształt hiperboli.
W realnym świecie nic nie jest jednak proste, a ogniskowe - idealne. Deformacja zdjęcia wykonanego obiektywem o złożonej ogniskowej może mieć skomplikowany kształt — przykład pokazuje Rysunek 5.2.7. W okolicy krawędzi tej fotografii krzywa deformacji obrazu ma końcówki wygięte do góry. (Dokładniejsze wyjaśnienie natury tej transformacji możesz znaleźć w dodatku 6.1, na str. 152).
Czy można jakoś zdeformować rzut z boku tak, by odpowiadał sylwetce na porównywanym zdjęciu? Ze względu na pracochłonność, bez zastosowania komputera jest to niewykonalne. A to oznacza, że wszelkie rysunki samolotów wykonywane metodą tradycyjną mogą zawierać różnorodne błędy kształtu. Autor takich rysunków na pewno dokładał wszelkich starań, aby zrobić je jak najdokładniej. Zazwyczaj jednak (prawie zawsze) podstawą do opracowania nowych planów modelarskich były:
rysunki samolotu opracowane przez innych autorów;
zdjęcia, które były porównywane z planami w dużej mierze “na oko”. Deformacja perspektywiczna była kompensowana tylko w za pomocą bardzo zgrubnych poprawek.
Z kolei sam fakt opracowania rysunków na komputerze nie świadczy jeszcze o tym, że są bezbłędne. Jeżeli bazowały wyłącznie na wcześniejszych opracowaniach - mogą tylko powtarzać popełnione wcześniej pomyłki innych autorów.
Obecnie istnieją już wyspecjalizowane programy, odwzorowujące deformację perspektywiczną — jednym z nich jest np. Hugin (dostępny w ramach licencji Open Source). Ku mojemu zaskoczeniu, znalazłem jednak tę funkcjonalność także w Gimpie. (W każdym razie oceniam, że jest wystarczająca do naszych celów). Spróbujmy ją zastosować. W tym celu przygotuj w Gimpie odpowiednie zestawienie:
wyeksportuj (File→Export Bitmap) z Inkscape zawartość warstwy z fotografią (por. Rysunek 5.2.5, str. 135) do pliku P40C-ML-Left-Photo.png;
wyeksportuj z Inkscape zawartość warstwy Drawing (zawiera odp. pochylony rzut z lewej) do pliku P40C-ML-Left-Drawing.png;
otwórz w GIMP utworzony przed chwilą plik P40C-ML-Left-Photo.png. Zmień nazwę jego warstwy domyślnej na Photo;
dodaj do niego, jako dodatkową warstwę, plik P40C-ML-Left-Drawing.png. Zmień nazwę tej warstwy na Drawing;
zapisz złożenie tych dwóch rysunków jako plik GIMP o nazwie P40C-ML-Left.xcf;
ustaw jako aktualną warstwę Drawing (czyli rzut z boku), i zmniejsz jej nieprzejrzystość (Opacity) do 50-60%. (Powinna się pod nią pojawić fotografia samolotu. Jako pierwsza z wczytanych, znajduje się „na dole” stosu warstw, na utworzonej przez GIMP warstwie Photo);
Rysunek 5.2.8 pokazuje efekt tych operacji - przeniesione do GIMP złożenie z Inkscape (por. Rysunek 5.2.5, str. 135):
Rysunek 5.2.8 Złożenie zdjęcia i rzutu z lewej — przeniesione z Inkscape do GIMP
Może, tak na marginesie, wyjaśnię dlaczego nie zacząłem od razu od Gimpa: w Inkscape jest wygodniej skalować i obracać obrazy. Do GIMP proponuję wczytać tylko obrazy wyeksportowane z Inkscape. W ten sposób zawartość obydwu warstw ma identyczne wymiary. Dzięki temu rzut z lewej znajdzie się w GIMP dokładnie w tym samym położeniu ponad zdjęciem, co w Inkscape.
Teraz wywołaj polecenie Filters→Distorts→Lens Distortion. Spowoduje to pojawienie się okna dialogowego, z parametrami zniekształcenia beczkowatego (Rysunek 5.2.9):
Rysunek 5.2.9 GIMP — okno dialogowe transformacji Lens Distortion.
Okno zawiera suwaki, odpowiadające następującym parametrom transformacji:
X shift, Y shift: położenie na fotografii środka obiektywu. (Chodzi o punkt, na który skierowany był aparat w chwili wykonywania zdjęcia). Położenie jest określane w zakresie od -100% do +100%. Wartość 0% odpowiada środkowi obrazu (patrz Rysunek 5.2.9);
Main: główny współczynnik zniekształcenia. Dodatni oznacza “skurczenie” obrazu wokół krawędzi. Ujemny — to oczywiście efekt odwrotny. Przy dopasowywaniu do zdjęć będziesz używać wartości dodatnich;
Edge: dodatkowa deformacja w okolicy krawędzi. Podobnie jak Main może być dodatnia (dodatkowe “skurczenie” obrazu) lub ujemna.
Zoom: powiększenie (zwykła zmiana skali, bez żadnej “magii”) względem punktu określonego przez X shift, Y shift. Ten parametr warto użyć, gdy nie doceniłeś deformacji zdjęcia i np. nie możesz osiągnąć odpowiedniej wysokości kadłuba w obszarze wokół środka obiektywu
Ustalanie transformacji zacznij zawsze od ustalenia punktu, na który była wycelowana kamera (X shift, Y shift). W przypadku klasycznego zdjęcia samolotu stojącego na lotnisku, współrzędna Y środka obiektywu wypada zazwyczaj na poziomie horyzontu/wzrostu człowieka. Położenia współrzędnej X możesz się domyśleć, szukając obszaru, w którym nie widać żadnego odchylenia płaszczyzn poprzecznych. (Na przykład — końcówki łopat śmigła, albo golenie podwozia, zasłaniające się wzajemnie).
Po ustaleniu celu kamery staraj się dopasować plany do zdjęcia za pomocą zmiany głównej krzywizny: Main. Staraj się ją dobrać w ten sposób, by przynajmniej długość obydwu sylwetek stała się taka sama. Jednocześnie, jak najwięcej “kluczowych” punktów konstrukcji w okolicy “celu” kamery (jak nasada skrzydła, statecznika poziomego, ramki kabiny...) powinno się zgadzać.
W oknie Lens Distortion jest dostępny podgląd efektu transformacji (Rysunek 5.2.9). Niestety, widać w nim tylko aktualną warstwę, więc nie wiemy, czy “trafiliśmy” w zdjęcie, czy nie. Pozostaje tylko taktyka “kolejnych przybliżeń”:
ustaw parametry transformacji (zazwyczaj zmieniasz tylko Main);
naciśnij przycisk OK;
obejrzyj rezultat;
gdy nie jest odpowiedni:
cofnij efekt transformacji (Ctrl-Z lub Edit→Undo Lens Distortion);
wywołaj ponownie okno dialogowe Lens Distortion (Filters→Re-Show “Lens Distortion”). Na szczęście okno “pamięta” ostatnio użyte wartości parametrów;
popraw parametry transformacji i spróbuj jeszcze raz.
Parametru Edge używaj dopiero wówczas, gdy w żaden sposób nie możesz odwzorować zdjęcia za pomocą samego parametru Main. Może to wyglądać tak:
długość zdeformowanej sylwetki dokładnie zgadza się z długością na zdjęciu, podobnie jak część kluczowych wymiarów;
mimo to kształt usterzenia pionowego nie jest zgodny ze zdjęciem.
Rysunek 5.2.10 pokazuje efekt transformacji dla X shift = -40%, Y shift = -10%, Main = 5.8 (pozostałe parametry są pozostawione w pozycji neutralnej):
Rysunek 5.2.10 GIMP — Rzut z lewej, dopasowany do zdjęcia (transformacja Lens Distortion)
Oprócz linii zgodnych, dostrzeżemy szybko na złożeniu wiele niedokładności. Widać nieco zbyt wygięty grzbiet kadłuba za kabiną, zbyt głęboka chłodnicę pod silnikiem... Czy można w jakiś łatwy sposób przenieść te poprawki na niezdeformowany rzut z lewej?
Oczywiście! Wystarczy, że poddamy odwrotnej deformacji nie plany modelarskie, a samo zdjęcie:
wycofaj (Edit→Undo Lens Distortion) ostatnią transformację;
zmień aktywną warstwę na Photo(to ta, zawierająca fotografię);
wywołaj ponownie okno dialogowe Lens Distortion (Filters→Re-Show “Lens Distortion”) i zmień znaki parametrów Main i Edge (Rysunek 5.2.11):
Rysunek 5.2.11 Parametry odwrotnej transformacji — z fotografii do rzutu prostopadłego
Rysunek 5.2.12 pokazuje efekt odwrotnej transformacji - zdjęcie dopasowane do rzutu z lewej!
(Main = -5.4, pozostałe parametry transformacji — bez zmian.)
Rysunek 5.2.12 Fotografia, “rozciągnięta” za pomocą Lens Distortion do rzutu prostopadłego
Teraz wystarczy przenieść zawartość warstwy Photodo Inkscape. W ten sposób będziemy mogli porównać rysunek z prawdziwym samolotem!
(w GIMP:) wyłącz widoczność warstwy Drawing (to ta z rzutem z lewej). Na ekranie powinna pozostać tylko zdeformowana fotografia;
zapisz widoczną warstwę (File→Export As) do pliku o nazwie P40C-Left-Photo.tif;
otwórz (w Inkscape) plik P40C-ML-Left.svg (stworzyliśmy go w poprzedniej sekcji — zobacz str. 133);
wyłącz w pliku P40C-ML-Left.svg (Inkscape) widoczność wszystkich warstw, oprócz warstwy Image;
dodaj nową warstwę: Photo. Umieść ją pod warstwą Image;
wczytaj na warstwę Photo (File→Import...) plik P40C-Left-Photo.tif. (To ten utworzony przed chwilą w Gimpie);
przesuń i obróć wczytany obraz, tak, by pasował do rzutu z lewej (Rysunek 5.2.13):
Rysunek 5.2.13 Inkscape — złożenie rzutu z lewej z “wyprostowanym” zdjęciem
Teraz pozostaje tylko obrysować różnice kształtu na warstwie Correction, tak jak to robiliśmy w poprzedniej sekcji (por. str. 132). Na przykład — ze zdjęcia wynika, że górny zawias steru kierunku jest nieco wyżej. Czy pamiętasz, że właśnie do tych zawiasów przykładaliśmy rysunki fabryczne (por. Rysunek 5.1.8, str. 130)? Założyliśmy wówczas, że są we właściwym miejscu. Teraz będzie trzeba przesunąć trochę cały obrys.
Jeżeli nie porównasz rysunków fabrycznych z odpowiednim zdjęciem, możesz je zastosować w sposób niepoprawny, i nie uzyskać prawdziwego kształtu samolotu
Podczas porównywania planów z fotografią pamiętaj także o tym, że nie wszystkie efekty zniekształcenia perspektywicznego zniknęły z rysunku. Przyjrzyj się końcówkom łopat śmigła (Rysunek 5.2.13): nadal są wygięte względem obserwatora. Ten efekt powoduje, że np. luk akumulatora na planach powinien znajdować się nieco bardziej z przodu, niż na zdjęciu. Jedynie elementy leżące dokładnie w osi symetrii kadłuba nie będą miały takiego przesunięcia. Możesz je oszacować, mierząc np. odchylenie przedniej krawędzi pokrywy kółka ogonowego. Potem proporcjonalnie zmniejszaj tę odległość, jeśli element jest bliżej centrum deformacji. (No cóż, jak widać, nawet tu odwzorowujemy coś “na oko”. Zapewniam jednak, że ogólna niedokładność tego porównania jest o niebo lepsza niż to, z czego mogliśmy korzystać przed “erą komputerów”.1)
Rysunek 5.2.14 pokazuje rezultat — korekty naniesione na rzut z lewej. Rysowałem je w kolorze czerwonym. Dodatkowo na rzut naniosłem wzorce profilu płata - w osi symetrii i u nasady skrzydła. (Zgodnie z dokumentacją, był to NACA 2215. Jeżeli chcesz dowiedzieć się, w jaki sposób na podstawie symbolu profilu narysować jego obrys — patrz „Kształt profili lotniczych (metody odwzorowania)” na str.154.) Kształt przekroju skrzydła bardzo się przydaje w weryfikacji dolnej krawędzi kadłuba każdego dolnopłata. Większość autorów rysuje ten fragment dość nieuważnie, podobnie jak rzut z boku skrzydła. (Na przykład - na rysunkach Jacka Jackiewicza i Mariusza Łukasika złożone koła podwozia głównego są w rzucie z boku za szerokie. Wygląda to tak, jak gdyby dotykały kadłuba.)
Rysunek 5.2.14 Korekty rzutu z boku, naniesione po porównaniu ze zdjęciem
Ogólnie rzecz biorąc, nasza sylwetka wyszła z porównania ze zdjęciem “obronną ręką”. Poważnych różnic nie ma. Z większych:
Chłodnica cieczy okazała się na fotografii płytsza, niż na rysunku.
Tylna krawędź kadłuba leży bardziej z przodu, niż na planach.
Oś obrotu steru pozostała w tym samym miejscu, więc obecnie jest poza kadłubem. (I tak było w prawdziwym samolocie).
Kołpak śmigła okazał się dłuższy, niż na planach (patrz Rysunek 5.1.10 — weryfikowałem to także z innymi zdjęciami).
Ta ostatnia poprawka wydłużyła całą sylwetkę o ok. 0,3%. Jednocześnie niemal niezauważalnie przesunęła się do przodu tylna krawędź steru kierunku. W sumie sylwetka wydłużyła się o 0,25%, co oznacza różnicę w skali rzeczywistej o ok. 2,5 cm. Może jestem chorobliwie dokładny, ale jest to zbyt drobna różnica, by powtórnie korygować cięciwę płata. (W skali rzeczywistej, w najszerszym miejscu, różnica wynosiłaby ok. 8 mm. To zupełnie niezauważalne. Mimo to, jak pokażę w następnej sekcji, dopasowałem płat do tego rozmiaru.)
Na koniec powiększyłem wysokość tego obrazu z 720 do 1024 jednostek, tak, by obejmował cały obrys dolnej łopaty śmigła. (Nie po to się męczyłem się nad jej obrysem, by teraz go obcinać.) Uzyskany rysunek zapisz, na wszelki wypadek, jako dokument Inkscape (P40C-ML-Left.svg). Stwórz także jego kopię rastrową (File→Export Bitmap). Nadaj jej nazwę P40C-ML-Left.png.
Dzięki porównaniu ze zdjęciami uzyskaliśmy poprawiony rzut z boku. Oszczędzamy sobie w ten sposób późniejszego odkrywania tych wszystkich różnic. (Modelowanie w 3D bezbłędnie wyłapuje wszelkie niekonsekwencje rysunku) Każda z nich objawia się tym, że nagle coś do czegoś nie pasuje. Takie błędy znajdowalibyśmy w trakcie budowy modelu, jeden po drugim. Zapewniam, że wtedy ich poprawianie wymaga większego wysiłku. Oznaczałoby konieczność ciągłego poprawiania ukończonych już elementów, a to hamowałoby cały postęp prac.
Za pomocą narzędzia GIMP — Lens Distortion — możesz “rozwinąć” zdjęcie, dopasowując je do rzutu z boku (str. 135 - 140). Otwiera to nowe możliwości weryfikacji planów modelarskich.
Zdjęcie, którego użyjesz do porównania z rzutem z boku, powinno mieć jak największą rozdzielczość. Samolot powinien być na nim jak najmniej zniekształcony (str. 135 - 136).
Staraj się zawsze sprawdzić, czy zdjęcie nie jest zdeformowane (zanadto wyciągnięte w pionie lub poziomie). W tym celu wybierz na fotografii kształt, o którym wiesz, że powinien być dokładnym kołem. Porównaj go z okręgiem, narysowanym w Inkscape (str. 134).
Uzyskane w GIMP “rozwinięte” zdjęcie można wczytać do Inkscape, aby wygodnie nanieść na plany poprawki (str. 141 - 142).
Sprawdziliśmy już tak dokładnie, jak się tylko dało, rzut z boku P-40. Pozostał nam jeszcze do sprawdzenia rzut z góry. Z nieocenionego http://www.p40warhawk.com uzyskałem rysunki fabryczne dwóch elementów:
kompletnego płata (znajdziesz go pod nazwą Source\Curtiss\Wing-overall.gif w pliku source.zip);
steru wysokości (znajdziesz go pod nazwą Source\Curtiss\Tail-elevator.gif w pliku source.zip);
Jeżeli chodzi o zdjęcia, to niestety, metoda jaką zastosowaliśmy do “wyprostowania” rzutu z lewej (patrz str. 134), tu nie zdaje egzaminu. Problem polega na tym, że rzut z góry nie ma jednej płaszczyzny, nad którą można by się było skoncentrować. Jest tu kilka ważnych powierzchni: płata, usterzenia poziomego, kadłuba. Niestety, każda z nich jest w innej odległości od obserwatora. W dodatku płaty mają wznios, co jeszcze bardziej komplikuje sprawę. Zresztą zdjęć z góry samolotu jest o wiele mniej niż zdjęć z boku. Wynika to z prostego faktu, że te z góry trzeba było zazwyczaj wykonać w powietrzu. Na taki “strzał” fotograf ma o wiele mniej okazji — aby go zrobić, musi się znaleźć w innym samolocie.
Szukając w ogóle jakichkolwiek zdjęć z góry, natknąłem się na następujące (Rysunek 5.3.1):
Rysunek 5.3.1 P40N — zdjęcie z góry (USAAF)
To nic, że fotografia przedstawia późną wersję P-40. Wszystkie — od pierwszych do ostatniej serii — miały takie same kształty skrzydeł i usterzenia poziomego.
Rysunek 5.3.1 zawiera unikalne ujęcie. Ten P-40N jest przechylony na lewo — o 7-8º. Dzięki temu lewy płat jest ustawiony niemal prostopadle do obserwatora. Jednocześnie zniekształcenie perspektywiczne jest niewielkie. Koło, w które wpisana jest gwiazda na lewym płacie nie ma żadnych widocznych zniekształceń. Także maszt anteny na ogonie samolotu jest tylko odrobinę odchylony od pionu. Kamera była skierowana na okolicę kabiny pilota. Całej fotografii “rozwinąć” z perspektywy, tak jak to zrobiliśmy z rzutem z lewej, nie jesteśmy w stanie. Ale pojedyncze obszary - to co innego! Użyjemy tego zdjęcia do weryfikacji dwóch elementów. Rysunek 5.3.1 pokazuje je, obrysowane liniami przerywanymi. To:
obrys płata1;
obrys usterzenia poziomego.
Ewentualne różnice naniesiemy jako poprawki na plany samolotu (tak samo, jak to zrobiliśmy z rzutem z lewej).
Zacznijmy od porównania płata z fotografii i płata z planów. Otwórz w Inkscape plik P40C-ML-Top.tif. Utwórz nową warstwę (pod spodem) i wczytaj na nią to zdjęcie (Source\Photo\P40N- Top-Photo.png z pliku source.zip). Dopasuj jak najdokładniej do planów lewe skrzydło samolotu z fotografii. W pierwszym kroku uzgodnij jego rozmiary (szerokość i wysokość). Następnie ustaw fotografię tak, by linia ostrzegawcza była pionowa. Jednocześnie osłony zasobnika z amunicją powinny być poziome (Rysunek 5.3.2). Osiągnięcie tego efektu wymaga drobnego obrotu i minimalnego przekoszenia fotografii. (Przekoszenie niweluje drobny efekt wzniosu płata, widzianego z góry, z tyłu):
Rysunek 5.3.2 Kształt płata — porównanie fotografii z planami M. Łukasika (i J. Jackiewicza)
Efekt jest zaskakujący: krawędź spływu i kocówka płata są na planach źle narysowane! Pociągnęło to za sobą także błędne położenie osi lotki — jest za bardzo przesunięta do przodu.
Na planach modelarskich samolotu, powierzchnie poziome — płat, usterzenie — zawierają częściej błędy, niż lepiej udokumentowane fotografiami powierzchnie pionowe
Upewnijmy się, czy możemy zastosować posiadany fragment dokumentacji fabrycznej. Wczytaj na kolejną warstwę plik z ogólnym zarysem płata (Source\Curtiss\Wing-overall.gif z pliku source.zip). Rysunek 5.3.3 pokazuje złożenie tego rysunku ze zdjęciem:
Rysunek 5.3.3 Porównanie fotografii z fabrycznymi rysunkami płata
Jak można było przypuszczać, tym razem różnic nie ma. Być może autorzy planów (Jacek Jackiewicz, a potem Mariusz Łukasik) nie mieli okazji skorzystać w odpowiednim czasie z tego rysunku.
Rysunek 5.3.4 przedstawia rzut z góry z naniesionymi poprawkami. O dziwo, poza tylnym dźwigarem, wszystkie łączenia blach i linie nitów na planach pasują do rysunków fabrycznych!
Rysunek 5.3.4 Rzut z góry — poprawiony obrys płata
W podobny sposób zweryfikujmy obrys usterzenia poziomego. W tym obszarze rysunki Jacka Jackiewicza i Mariusza Łukasika różnią się od siebie.
Na rysunku Jacka Jackiewicza ster wysokości ma bardziej zaokrągloną krawędź spływu. Jego kompensacja aerodynamiczna znajduje się także w innym miejscu, niż na zdjęciu — i nie jest to mała różnica (Rysunek 5.3.5). Ster na tym rysunku zawiera tyle różnic, że nie ma co się nim posługiwać2.
Rysunek 5.3.5 Obrys usterzenia P-40 wg planów Jacka Jackiewicza | Rysunek 5.3.6 Obrys usterzenia P-40 wg planów Mariusza Łukasika |
Mariusz Łukasik zauważył tę różnicę, i starał się ją poprawić. Jego obrys usterzenia jest bardziej zbliżony do fotografii (Rysunek 5.3.6). Krawędź steru znajduje się w poprawnym miejscu, a wyważenie masowe ma rozmiar zbliżony do rzeczywistego. Wygląda jedynie, że w tym przypadku autor nie zauważył niewłaściwych proporcji statecznika — jego krawędź natarcia jest nadal przesunięta do tyłu. To w efekcie spowodowało zmniejszenie promienia obrysu końcówek usterzenia. (Ster musiał pasować do statecznika). Wygląda na to, że Mariusz Łukasik starał się zachować kształt krawędzi natarcia jak na rysunkach Jacka Jackiewicza. Czyli — jest lepiej, ale też nie za dobrze.
Co z tym fantem robić? Spróbowałem złożyć całą posiadaną dokumentację fabryczną, która dotyczy tego fragmentu (Rysunek 5.3.7).
Na zdjęcie usterzenia nałożyłem rysunki fabryczne:
steru wysokości (Source\Curtiss\Tail-elevator.gif z pliku source.zip);
oprofilowania usterzenia (Source\Curtiss\Tail-fairing.gif z pliku source.zip);
Na pierwszym z nich jest oznaczony środek okręgu konturu końcówki usterzenia. Przedłużyłem go znad steru na statecznik, gdyż taki kształt jest zgodny ze zdjęciem.
Następnie narysowałem prostą linię krawędzi natarcia. Linia ta jest styczną do okręgu końcówki, a z drugiej strony — przechodzi przez punkt wskazany na rysunku oprofilowania usterzenia. Tak “wydedukowany” obrys jest zgodny ze zdjęciem, a więc — poprawny.
Rysunek 5.3.7 Obrys usterzenia P-40 — złożenie dostępnej dokumentacji fabrycznej
Rysunek 5.3.8 przedstawia korekty naniesione na plan usterzenia poziomego (statecznika i steru).
Rysunek 5.3.8 Korekty kształtu usterzenia poziomego
Łączenia blach poszycia statecznika poziomego biegną wzdłuż wzmocnionych podłużnic. Podobne podłużnice biegną przez statecznik pionowy. Obydwa stateczniki były, w miejscu styku tych podłużnic, skręcone śrubami. (Usterzenie pionowe “stało” na niedzielonym stateczniku poziomym, który z kolei był przykręcony do kadłuba). Na rysunkach fabrycznych statecznika pionowego zaznaczone są punkty połączeń z usterzeniem poziomym. Pozwoliło mi to wyznaczyć położenie podłużnic u nasady statecznika poziomego. (Rysunek 5.3.8 zaznacza je liniami przerywanymi.) Jak widać, różnią się tylko nieznacznie od położenia wg planów. Położenie tych podłużnic i szwów blachy przy końcówce statecznika wypada inaczej, gdyż skorygowana końcówka jest dużo szersza. Położenie żeber steru wysokości na rysunkach M. Łukasika jest zgodne z dokumentacją fabryczną.
Rysunek 5.3.9 przedstawia ostateczną postać rzutu z góry, zawierającą poprawiony obrys usterzenia poziomego i skrzydła:
Rysunek 5.3.9 Rzut z góry z naniesionymi poprawkami
Wyeksportuj ten rysunek Inkscape do pliku obrazu o nazwie P40C-ML-Top.png(File→Export Bitmap). Aby zaoszczędzić czas, nie kopiuję tych poprawek na drugą, symetryczną stronę samolotu, ani nie przenoszę ich na inne rzuty. Wystarczy, aby pamiętać, że płat lub usterzenie należy wykonywać z rzutu z góry, wg czerwonych, a nie czarnych (oryginalnych), linii.
Jak widzisz — każdy popełnia błędy, nawet twórcy planów modelarskich. Opierając się jednak na jak najlepszych planach, możemy zidentyfikować i poprawić większość pomyłek, które się na nich znalazły. Jest to możliwe za pomocą odpowiedniego oprogramowania, które pozwala na porównanie wielu obrazów naraz. W poprzednich dekadach taka możliwość jeszcze nie istniała3.
Zdjęcia samolotu z góry nie poddają się tak łatwo rozwinięciu, jak rzut z boku. Zrezygnowałem z tej operacji, bo możliwość błędu w rezultacie takiej pracy byłaby zbyt duża (str. 144).
Liczba dostępnych, w przybliżeniu prostopadłych, zdjęć samolotu z góry (lub z dołu) jest o wiele mniejsza od zdjęć “horyzontalnych”. Dzieje się tak dlatego, że takie fotografie muszą być robione wyłącznie z powietrza (str. 144).
Plany modelarskie mogą zawierać więcej błędów kształtu płata i usterzenia poziomego, niż kadłuba i usterzenia pionowego. Wynika to z mniejszej liczby dostępnych fotografii (str. 146, 148).
Rysunki fabryczne skrzydła, stateczników i sterów są w tej sytuacji właściwie jedyną metodą weryfikacji. (Chyba, że uda Ci się trafić na jakieś zdjęcie, wykonane z dużej odległości pod kątem niemal 90º).
W tym rozdziale umieściłem informacje “dla dociekliwych”. Znajdują się tu szczegółowe wyjaśnienia wybranych zagadnień, nad którymi nie chciałem się rozwodzić w części głównej. (Aby nie zbaczać z tematu).
Fotografia utrwala rzeczywisty obiekt w ściśle określonym ujęciu perspektywicznym. Podstawowym parametrem tego ujęcia jest długość ogniskowej obiektywu (patrz Rysunek 6.1.1). Powiedzmy, że wynosi 50mm. Wymiary kliszy są zazwyczaj standardowe (wysokość 35mm, szerokość 48mm). Obraz na odbitce 10x15cm wyglądałby “zupełnie jak prawdziwy”, gdybyś oglądał go z odległości 30 cm, zamknąwszy przy tym jedno oko. Oczywiście, nigdy tak zdjęć nie oglądamy. Napotykając je na co dzień, przyzwyczailiśmy się nawet do takich drastycznych deformacji beczkowatych jak “rybie oko”. (Mimo, że nie mamy szans zobaczyć świata w ten sposób — wyklucza to budowa ludzkiego oka).
Rysunek 6.1.1 Zniekształcenie beczkowate na fotografii
Rysunek 6.1.1 pokazuje:
po lewej: geometrię projekcji podczas wykonywania zdjęcia. Linia z punktami A, B, C to np. oś symetrii prawdziwego samolotu. Linia z punktami a, b, c to obraz tej osi na zdjęciu. Zwróć uwagę, że odcinek |Cc| jest o wiele dłuższy od |Aa|;
po prawej: sytuację, gdybyśmy odbitkę tej fotografii obserwowali z nieskończonej odległości (czyli nie byłaby to w ogóle perspektywa, a techniczny rzut z lewej). Dlatego tu wszystkie odcinki |Aa|, |Bb|, |Cc| są równoległe. Różne odległości pomiędzy obiektem a jego obrazem, występujące w perspektywie, zrobiły jednak już swoje. Jeżeli wysokości oryginału (np. kadłuba) w punktach A i C są identycznie, to w punkcie c (na zdjęciu) jest ona mniejsza niż w pkt. a.
Linię, demonstrującą stopień zniekształcenia beczkowatego, można uzyskać ustawiając linie |Cc|, |Bb|, |Aa| pod kątem 90º do płaszczyzny zdjęcia (Rysunek 6.1.1). Długość tych odcinków jest taka sama jak podczas tworzenia zdjęcia. Ich końce wyznaczają teraz krzywą deformacji. Krzywa deformacji ma w tym przypadku kształt hiperboli.
W rzeczywistości soczewki obiektywu nie mają idealnych ogniskowych. Na większości zdjęć krzywa deformacji nie jest idealną hiperbolą — może być dodatkowo wygięta na krańcach. Rysunek 6.1.2 pokazuje, jak powstaje taki efekt:
Rysunek 6.1.2 Przykład złożonego zniekształcenia beczkowatego
Wśród konstruktorów lotniczych funkcjonuje powiedzenie “the wing is the king”. Ma to znaczyć, że geometria płata ma decydujący wpływ na wszelkie charakterystyki samolotu. Na przykład — P-40E “Warhawk” i P-51A “Mustang” miały niemal identyczną powierzchnię płata. Używały takich samych silników Allison, miały bardzo podobną powierzchnię czołową — chłodnic, kadłuba, skrzydeł. Różniły się jednak drastycznie oporem, jaki stawiały podczas lotu. Współczynnik oporu P-40E wynosił 0.02421. Ten sam współczynnik dla P-51A wynosił 0.0176. Co powodowało tę różnicę? Przede wszystkim profil płata! W wyniku zastosowania skrzydła o profilu laminarnym pierwsze “Mustangi” był o 45 km/h szybsze od “Warhawków” 2.
Profil płata jest odwzorowywany w lotnictwie bardzo dokładnie — nawet nieznaczne różnice kształtu mogą w znaczny sposób zmienić np. charakterystyki przeciągnięcia. Rysunek 6.2.1 wyjaśnia podstawowe pojęcia, używane w opisie geometrii profili lotniczych:
Rysunek 6.2.1 Geometria profilu lotniczego
Tradycyjnie profile lotnicze rysuje się w płaszczyźnie XY. Z lewej strony, w punkcie (X=0, Y=0), znajduje się zawsze tzw. nos profilu, określający kształt krawędzi natarcia płata. Nos jest zazwyczaj zaokrąglony. Czasami jest podawany promień tego zaokrąglenia. Profil jest zawsze zakończony w punkcie (X=100, Y=0). Linia profilu jest często dzielona na dwie części: obrys górny i obrys dolny. Obrysy łączą się na krańcach profilu (w X = 0 i X=100).
Prosty odcinek, łączący nos z krawędzią spływu nazywamy cięciwą. Drugą linią charakterystyczną jest szkieletowa. Punkty tej linii leżą w równej odległości od górnej i dolnej krawędzi profilu. Można ją sobie wyobrazić jako linię przechodzącą przez środki okręgów, wpisanych w obrys profilu (Rysunek 6.2.1).
Dla profilu podawana jest często także:
maksymalną grubość (informacyjnie — chodzi tu o wysokość, mierzoną wzdłuż osi Y);
punkt maksymalnego ugięcia linii szkieletowej (Rysunek 6.2.1).
Gdzieś tak do lat dwudziestych XX wieku profile płatów opracowywali sami konstruktorzy. Robili to metodą prób i błędów. Na przykład popularny profil Clark Y powstał właśnie w tym czasie (opracował go w 1922 r. Virginius A. Clark). Użyto go w dziesiątkach samolotów z lat dwudziestych. Aby inżynierowie na całym świecie byli w stanie poprawnie odtworzyć kształt profili, zaczęto publikować współrzędne ich obrysów (Tabela 6.2.1, Rysunek 6.2.2):
| 0 | 1.25 | 2.5 | 5 | 7.5 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | 100 | |
| Yg | 3.49 | 5.53 | 6.50 | 7.87 | 8.86 | 9.63 | 11.35 | 11.73 | 11.40 | 10.52 | 9.18 | 7.72 | 5.54 | 3.32 | 0.25 |
| Yd | 3.49 | 1.94 | 1.46 | 0.94 | 0.61 | 0.40 | 0.04 | 0.00 | 0.00 | 0.00 | 0.00 | 0.00 | 0.00 | 0.00 | 0.00 |
Tabela 6.2.1 Współrzędne profilu Clark Y
Rysunek 6.2.2 Profil Clark Y, wykreślony na podstawie współrzędnych z Tabela 6.2.1
Gdzieś w latach dwudziestych coraz szerzej zaczęto używać profili, opracowanych przez placówki naukowe. Na przykład publikował je niemiecki uniwersytet w Getyndze. (Były oznaczane np. “Götingen - 623”, albo “Götingen - 543”.) W 1933 r. finansowana przez rząd USA NACA opublikowała istotny raport, zawierający geometrię i charakterystyki 78 profili lotniczych. Były to tak zwane “profile rodziny 4-cyfrowej”. Od tamtej pory profile te były szeroko wykorzystywane w wielu konstrukcjach lotniczych, nie tylko amerykańskich3. Do rodziny tej należą także profile płata P-36 i P-40: NACA 2215 i NACA 2209.
Czy wiesz, że numer profilu NACA nie jest wcale numerem kolejnym? Tak naprawdę zawiera opis jego kluczowych parametrów geometrycznych:
1 cyfra: największe ugięcie szkieletowej (czyli wartość Y max. ugięcia w %).
2 cyfra: odległość punktu o największym ugięciu szkieletowej od nosa profilu, podzielona przez 10. Na przykład — “2” oznacza, że max. ugięcie szkieletowej znajduje się 20% od krawędzi natarcia.
3 i 4 cyfra: grubość profilu (%).
Tak więc symbol profilu P-40 — “NACA 2215” — oznacza profil o grubości 15% i maksymalnym ugięciu szkieletowej 2%, w X = 20% cięciwy. W istocie kształty NACA 2215 i NACA 2209 różnią się tylko grubością. Gdy przeskalujesz rysunek NACA 2209, rozciągając go w pionie, uzyskasz NACA 2215. (Na odwrót to także działa!)
Co więcej — NACA opublikowało wzory matematyczne, które pozwalają odwzorować kształt profilu z dowolną dokładnością. (Trzydzieści punktów, jakie Tabela 6.2.1 dla profilu Clark Y, pozostawia jeszcze pole do pewnej dowolności).
NACA opublikowała parametry także tzw. “rodziny 5-cyfrowej”, ale nie będziemy się nią tu zajmować. Poza tym istnieją także profile NACA, noszące inne oznaczenia. Na przykład — laminarny profil płata “Mustanga” to NACA 45-100. A profil skrzydła Messerschmitta Bf 109 jest podany jako NACA 2R 1 14.2 (to oznacza podwójne załamanie szkieletowej).
Gdy zaczniesz szukać w Internecie hasła “NACA, airfoil”, znajdziesz szybko kilka stron podających współrzędne wielu różnych profili lotniczych. Uważam, że godny polecenia jest w szczególności serwis dostępny pod adresem http://www.ppart.de/programming/java/profiles/NACA4.html :
Rysunek 6.2.3 Serwis internetowy — generator współrzędnych 4-cyfrowych profili NACA
Rysunek 6.2.4 Wygenerowane współrzędne profilu NACA 2215
Gdy ustawisz na tej stronie odpowiednio parametry:
Maximum Camber: ugięcie szkieletowej (1-sza cyfra);
Max. Camber Pos: pozycja ugięcia szkieletowej (2-ga cyfra);
Thickness: grubość profilu (dwie ostatnie cyfry).
i naciśniesz przycisk Show Points, w polu po prawej stronie ekranu zobaczysz współrzędne. Wygenerowano je dla profilu o długości cięciwy = 1.0. (Po 100 pkt na obrys).
Zaznacz całą zawartość pola tekstowego ze współrzędnymi (Ctrl-A) i skopiuj ją do schowka (Ctrl-C).
Co dalej zrobić z tymi współrzędnymi? Będziemy pracowicie rysować w Inkscape ten profil, “punkcik po punkciku”? Na szczęście nie — istnieje szybsza droga.
Otwórz arkusz kalkulacyjny, który przygotowałem specjalnie tym celu (Source\Tools\airfoil.xls z pliku source.zip, por. str. 17 — Rysunek 6.2.5):
Rysunek 6.2.5 Arkusz kalkulacyjny — przygotowanie wyrażenia SVG
Teraz przełącz się do Inkscape, i: narysuj w nim dowolną linię prostą. Następnie przełącz się na tryb selekcji i otwórz okno edytora XML (Edit→XML Editor...)
Rysunek 6.2.6 Linia na rysunku i jej definicja w edytorze XML (SVG)
Wklej zawartość schowka (kopię obszaru SVG z arkusza airfoil.xls — por. Rysunek 6.2.5) jako nową wartość atrybutu d 4(Rysunek 6.2.7):
Rysunek 6.2.7 Wartość atrybutu d (wierzchołki linii) przeniesiona z arkusza airfoil.xls
Gdy naciśniesz przycisk Set, wprowadzisz nowe wartości do dokumentu Inkscape (Rysunek 6.2.8):
Rysunek 6.2.8 Uzyskany w Inkscape profil NACA 2215
W ten sposób nasza linia nagle zmieniła się w gotowy rysunek profilu NACA 2215! Pozostaje teraz tylko zmienić jego skalę i przesunąć w odpowiednie miejsce rysunku.
Na koniec warto wspomnieć o odmianie profili NACA, z końcówką “T”. Są to wersje o zmniejszonym promieniu noska. Profile “T” mają o 75% zmniejszony promień noska w stosunku do promienia użytego w serii NACA 00xx (bez końcowej litery). Odpowiednio do tego jest także zmodyfikowany cała kształt przedniej sekcji - na “ostrzejszą”. “T” w zamyśle twórców mogło to znaczyć tyle, co angielskie “thinner”, czyli “cieńszy” (albo, równie dobrze, “tapered”). Przykładem profilu “T” jest NACA 0018T (Rysunek 6.2.9):
Rysunek 6.2.9 Profil NACA 0018T (“T” oznacza zmieniony przód — zmniejszony promień noska)
Nigdzie nie znalazłem opisu, jaki przekrój miało usterzenie P-40. Przymierzałem do rysunków fabrycznych (np. owiewki usterzenia) wiele profili. Ostatecznie doszedłem do wniosku, że była to właśnie rodzina NACA 00xxT. W P-40 wykorzystano “cieńsze” wersje profilu, jaki pokazuje Rysunek 6.2.9:
usterzenie pionowe, u nasady: NACA 0008T;
usterzenie poziome, u nasady: NACA 0010T;
usterzenie poziome, u końca: NACA 0009T.
Tabela 6.2.2 określa współrzędne obrysu profilu NACA 0018 T dla piętnastu punktów. Wykorzystałem je do wyznaczenia obrysu profilu. Aby uzyskać z tych współrzędnych cieńszą wersję, wystarczy przeskalować je w kierunku pionowym. Na przykład, po “ściśnięciu” NACA 0018T o 50% uzyskamy NACA 0009T, wykorzystywany w końcówce usterzenia poziomego.
| 0 | 1.25 | 2.5 | 5 | 7.5 | 10 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 90 | 100 | |
| Yg | 0.00 | 1.87 | 2.83 | 4.28 | 5.41 | 6.32 | 8.46 | 9.00 | 8.62 | 7.67 | 6.44 | 5.09 | 3.65 | 2.05 | 0.00 |
| Yd | 0.00 | -1.87 | -2.83 | -4.28 | -5.41 | -6.32 | -8.46 | -9.00 | -8.62 | -7.67 | -6.44 | -5.09 | -3.65 | -2.05 | 0.00 |
Tabela 6.2.2 Współrzędne profilu NACA 0018T (cieńsze wersje profilu są używane w usterzeniach).
Aby znaleźć w książce jakieś słowo lub wyrażenie możesz użyć narzędzia wyszukiwania wbudowanego w czytnik, którego używasz. Jednak ta metoda może nie być zbyt efektywna w przypadku pojęć koncepcyjnych. (O wiele łatwiej znaleźć takie wyrażenie w skorowidzu drukowanej książki, niż poszukując go poprzez powiązane polecenia lub słowa kluczowe). Co więcej, niektóre aplikacje do czytania publikacji elektronicznych w formacie EPUB na komputerach PC w ogóle nie umożliwiają wyszukiwania w całej książce. Dlatego zdecydowałem się włączyć do tej publikacji skorowidz z wersji "stronicowanej" (PDF). Wystarczy kliknąć na jeden z numerów stron po prawej stronie hasła, by przejść do odpowiedniego fragmentu książki.
Po prawej stronie nagłówka każdego hasła umieściłem skroty do pozostałych nagłówków. Użyj ich, aby nie przewijać zbyt wielu stron przechodząc np. od litery Z do C.
Nazwy poleceń, skróty klawiatury, podane w skorowidzu, dotyczą Blendera, o ile w haśle nie jest zaznaczone inaczej: „(GIMP)”, „(Inkscape)”.
GPL, licencja — General Public Licence, udostępniająca produkt za darmo wszystkim odbiorcom. Licencja ta jest sformułowana w ten sposób, aby uniemożliwić komercyjne rozpowszechnianie produktu.
rastrowy, obraz — popularna metoda reprezentacji, polegająca na zapisie obrazu jako zbioru kolorowych lub czarno-białych punktów (pikseli). Tak jest np. wyświetlany obraz na ekran telewizyjnym, monitorze komputera. Wadą reprezentacji rastrowej jest pogorszenie jakości obrazu w dużych powiększeniach — gdy zaczynają być wyraźnie widoczne pojedyncze piksele. Zaletą jest stosunkowo prosty algorytm wyświetlania zawartości. Istnieje wiele różnorodnych sposobów zapisu (formatów) przechowywania obrazów rastrowych w plikach. Najpopularniejsze to *.jpg, *.png, *.bmp, *.tif.
shear (ang.) — przekoszenie (określane także jako “ścinanie”). Transformacja obrazu w GIMP. Przekształca kształt prostokąta w rąb (przeciwległe boki zachowują równoległość).
wektorowy, obraz — metoda reprezentacji, polegająca na zapisie obrazu jako zbioru kolorowych linii i obszarów. Każdy element obrazu ma określone współrzędne i kształt (prosta, łuk, koło, krzywa Beziera, ...). W ten sposób są zapisywane stworzone na komputerze rysunki techniczne. Zaletą reprezentacji wektorowej jest zachowanie dokładności przy dowolnym powiększeniu. Wadą jest złożony algorytm wyświetlania (gdyż oznacza przekształcenie na postać rastrową). Jednym ze sposobów zapisu danych wektorowych jest format *.svg, stosowany m.in. przez Inkscape.
wireframe (pol.: siatka?) — oznacza sposób reprezentacji modelu w którym nie rysowane są żadne ściany, tylko krawędzie łączące poszczególne wierzchołki. Jest ich zazwyczaj dużo i są cienkimi liniami. Stąd obrazowo w literaturze anglojęzycznej taka reprezentacja jest nazywana “drucianą siatką” czyli “wireframe”.
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Witold Jaworski pasjonował się lotnictwem i modelarstwem odkąd skończył 10 lat. Zaczynał od plastikowych zestawów do sklejania (1:72), potem wycinanek z „Małego Modelarza” (1:33), by skończyć na budowie modeli od podstaw (1:24). Te zainteresowania zaprowadziły go na Wydział Mechaniczny Energetyki i Lotnictwa Politechniki Warszawskiej, który ukończył w 1994r otrzymując dyplom mgr. inż lotnictwa. W 1987 przerysowywał w tuszu plany samolotów, m.in. do książki „Samoloty bombowe września” (te prace zlecał Andrzej Glass). Potem zaproponowano mu samodzielne opracowanie przekroju i kilku arkuszy planów do nowo powstającego magazynu. Mógł wybrać dowolny samolot. W ten sposób powstały dokładne rysunki myśliwca F-4 Phantom II, opublikowane w 1990r w pierwszym numerze miesięcznika „Aero HOBBY”. Nadal można znaleźć ich kopie w Internecie, na różnych portalach z planami. Podczas studiów na MEiL Witold zainteresował się także grafika komputerową i systemami CAD. W 1991r miał okazję po raz pierwszy wykorzystać tę wiedzę, pomagając w budowie prototypu szybowca PW-5 (zwycięzcy konkursu na tzw. szybowiec światowy w 1992).
Obecnie Autor pracuje jako specjalista IT. Mieszka wraz z żoną i trójką dzieci w Poznaniu. Od czasu do czasu pisze artykuły dla czasopism lotniczych. W tej książce łączy swoje dwie pasje - grafikę komputerową i lotnictwo - w nowy rodzaj modelarstwa: realistyczne, cyfrowye modele historycznych samolotów.